Part and Chapter Numbers

gr
grantmcduling
Posts: 20
Joined: Mon Mar 21, 2011 10:34 pm
Platform: Mac

Mon Dec 05, 2011 1:43 am Post

I want to use Part and Chapter numbers in a book I am writing but can't seem to do this. So for instance I need to have Part One, Chapter One, Two, Three, Part Two, Chapter One, Two, Three, etc. At present all I can achieve is Part One, Chapter Two, etc. They run sequentially instead of the Chapters starting from one each time. How can I do this and save the settings so I don't need to reformat each time?

User avatar
KB
Site Admin
Posts: 20719
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Mon Dec 05, 2011 10:35 am Post

You can use tagged numbering streams - to do so, just add an arbitrary keyword to the auto-number tag. For instance, for parts, use something like:

Part <$t:part>

And for chapters, use:

Chapter <$t:chapter>

This will create separate streams.

If you want to restart chapter numbering with each part, then for your parts use:

Part <$t:part><$rst_chapter>

The <$rst_chapter> part tells Scrivener to restart the numbering stream tagged "Chapter".

Place these in your title prefix level settings in "Formatting" in Compile, and you should be good. For more information about tags, see "Placeholder tags list..." under the Help menu.

Once you have everything set up as you want, you can just create a compile format preset (via the "Format As" menu - "Manage..." at the bottom).

Hope that helps.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

jg
jgould
Posts: 77
Joined: Tue Nov 23, 2010 3:16 pm
Platform: Mac + iOS
Location: Circleville, OH

Sun May 06, 2012 6:19 am Post

Keith,

Not to dredge up an old topic, but I'm currently working on a piece that has multiple parts to it. Using these directions, I have the program compiling with the part numbers and chapter numbers appearing where they should, but I want a page that has the name of the part (in this case, Part one is called "The Decision" that reads "Part One: (Line Break) The Decision" I have been playing with different settings and tags, but am unable to figure out how to make this work the way I want.

I've tried remaining the folder for the first part, adding a text file with what I want the first part to say, and played with various settings under the compile screen and haven't figured out a way to do this yet. Any help would be appreciated.

Thanks,
Josh

User avatar
MimeticMouton
Posts: 8780
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sun May 06, 2012 7:23 am Post

What part specifically are you having trouble with? The basic way I'd suggest doing this is to set up the "Part <$t>:" bit as the folder prefix (as explained above, using whatever variable is appropriate) and then to check the box to include the folder title as well, assuming that the binder title of your parts folders is the name, e.g. "The Decision". If you add a carriage return at the end of the "Part <$t>:" prefix in the Level Settings, then you'll get
Part One:
The Decision
as you're looking for. You can further format the prefix and title by clicking in those lines in the sample text in the formatting compile pane.

How you set the part number and title on its own page will depend on the structure of your binder. If the parts and chapters are both folders, with scenes as text documents, you can set this up easily by setting the Folder/Folder divider in compile's Separators to "page break". If parts are folders and chapters are not, you'd need to set the Folder/Text divider to "page break".
Jennifer Hughes
(MM for short)

jg
jgould
Posts: 77
Joined: Tue Nov 23, 2010 3:16 pm
Platform: Mac + iOS
Location: Circleville, OH

Mon May 07, 2012 2:54 am Post

MimeticMouton wrote:What part specifically are you having trouble with? The basic way I'd suggest doing this is to set up the "Part <$t>:" bit as the folder prefix (as explained above, using whatever variable is appropriate) and then to check the box to include the folder title as well, assuming that the binder title of your parts folders is the name, e.g. "The Decision". If you add a carriage return at the end of the "Part <$t>:" prefix in the Level Settings, then you'll get
Part One:
The Decision
as you're looking for. You can further format the prefix and title by clicking in those lines in the sample text in the formatting compile pane.

How you set the part number and title on its own page will depend on the structure of your binder. If the parts and chapters are both folders, with scenes as text documents, you can set this up easily by setting the Folder/Folder divider in compile's Separators to "page break". If parts are folders and chapters are not, you'd need to set the Folder/Text divider to "page break".


Except for the fact that I've got the settings set like this already. This isn't providing the export that I would like to have.

First the Binder setup:

Screen Shot 2012-05-06 at 21.55.02 PM.png
Binder Setup
Screen Shot 2012-05-06 at 21.55.02 PM.png (94.17 KiB) Viewed 1698 times


The manuscript is called Extreme Measures, Part one is the folder called The Decision and then the first chapter is the first folder called Chapter. The text document called 'The Decision' is the large text that I want to paper below the text Part One.

My compile settings are as follows:

Screen Shot 2012-05-06 at 22.11.04 PM.png
compile screen
Screen Shot 2012-05-06 at 22.11.04 PM.png (118.69 KiB) Viewed 1698 times

Screen Shot 2012-05-06 at 22.11.14 PM.png
compile 2
Screen Shot 2012-05-06 at 22.11.14 PM.png (33.87 KiB) Viewed 1698 times


The settings for Folders 2+ are Chapter <$t:chapter>, (I would have uploaded that but it wouldn't let me add more than three attachments.) No matter what I do, I can not get the large text to appear on the same page as the text Part One.

Any suggestions?

Josh

User avatar
MimeticMouton
Posts: 8780
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Mon May 07, 2012 5:56 am Post

"Separators" is probably the issue here, but I'm not entirely clear what results you are getting compared to the results you want. Just looking at the images posted, I'd expect you to be getting output for your first part folder that looks like

Part One
# # The Decision # #
(PROOF COPY -- Not for distribution.)

where "The Decision" is the folder title as listed in the binder. You then also have a sub-document group below it called "The Decision" which contains text in the editor that you want to appear on the same page as the Part One blah blah title above? And then a page break between that and the following chapter (indicated by the chapter folder)?

If that's the case, you'll want to make sure that in the Separators section of the compile window you have the Folder/Text separator not set to page break but rather to single return or empty line, and then have the Text/Folder separator as page break. Folder/Folder won't affect any of this. If at the bottom of that separators pane there's an option to include a page break before document groups, leave it unchecked. (Since "The Decision" is a document group--that is, it's got sub-documents--enabling this option would create a page break between the part info and The Decision's text, despite the Folder/Text separator. I'm not sure if this option is in the current 2.2 release or only in the public beta, so if you don't see it, don't worry about it.)

Is that what you're after? I apologize if I'm really just missing the point; I'm sort of shooting in the dark here. :|
Jennifer Hughes
(MM for short)

ma
marklawford
Posts: 1
Joined: Mon Oct 29, 2012 7:59 pm
Platform: Windows

Mon Oct 29, 2012 8:04 pm Post

KB wrote:You can use tagged numbering streams - to do so, just add an arbitrary keyword to the auto-number tag. For instance, for parts, use something like:

Part <$t:part>

And for chapters, use:

Chapter <$t:chapter>

This will create separate streams.

If you want to restart chapter numbering with each part, then for your parts use:

Part <$t:part><$rst_chapter>...


This is exactly what I was looking for. However... It doesn't seem to be working on my Windows Scrivener. Is this a Mac-only feature?

When I try this, my Parts are listed as PART <$T:PART> and the restart stream tag is displayed in full too.

I'm running Vista and Scrivener 1.2.5.0