How to change Heading background with new dark mode?

la
labyrinthium
Posts: 2
Joined: Sat Nov 10, 2018 3:58 pm
Platform: Mac

Sat Nov 10, 2018 4:11 pm Post

First, I want to say that I love the new dark mode.

However, I'm kind of confused at the moment. The very first time I changed it to dark mode after the update, it turned to various shades of grey. It was perfect, I liked it just like that. But I was curious what the other built-in themes looked like so I clicked through them just for fun. When I went to set it all back to default though, it either goes straight to one of the new dark mode themes or it turns back to light. I'd really just like to have the grey theme back without having to go into Composition Mode to get to it.

I've managed to change most of it manually by going through the hundreds of lovely color preferences under "Appearance" but there's one part I can't seem to change. I've attached a screenshot of it and it's fairly obvious, it's the only part that is still blue. Can someone tell me how to change it? Or better yet, can someone tell me how to get the grey dark mode back?

Thanks so much and I love the new updates!
Attachments
Screen Shot 2018-11-10 at 07.55.42.png
Screen Shot 2018-11-10 at 07.55.42.png (27.43 KiB) Viewed 122 times

User avatar
KB
Site Admin
Posts: 20321
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sat Nov 10, 2018 4:45 pm Post

You can return to the standard dark mode theme by going to Scrivener > Themes and picking “Default”. That header will remain blue, though, as you cannot change that - just like you cannot change it in light mode. When you have two editors open, the editor with the focus - the one that will be affected by the binder - has a blue header bar to indicate this. This is how it has always worked, in light mode too. Probably you only had one editor open earlier - if you only have one editor open then the header is not blue as there is nothing to indicate.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

la
labyrinthium
Posts: 2
Joined: Sat Nov 10, 2018 3:58 pm
Platform: Mac

Sun Nov 11, 2018 3:56 pm Post

KB wrote:You can return to the standard dark mode theme by going to Scrivener > Themes and picking “Default”. That header will remain blue, though, as you cannot change that - just like you cannot change it in light mode. When you have two editors open, the editor with the focus - the one that will be affected by the binder - has a blue header bar to indicate this. This is how it has always worked, in light mode too. Probably you only had one editor open earlier - if you only have one editor open then the header is not blue as there is nothing to indicate.


I've had two editors open for months, I guess I just never noticed that the header was blue :? Thanks for pointing that out.

I may not have worded my problem with the dark mode well enough... The problem I'm running into is this: I started out in the default light mode after the update. I went Scrivener > Apearance > Dark. The screen then turned dark to only the standard dark greys.I liked it like that. Then I was easily distracted by the new themes that came with the update. I clicked through the new themes, decided I still liked the standard grey the best, and went Scrivener > Themes > Default. It turns back to light mode. I also clicked Appearance > Default and it stays in light mode (which I expected). Next, I go to Appearance > Dark and it sets it back to the last dark theme I had clicked on, Solarized Dark. I can no longer get it to go back to the grey mode at all. I'm wondering if I'm missing something here, or if the standard grey mode is no longer in existence...

Thanks for the help, i really appreciate it

vg
vgorczeski
Posts: 12
Joined: Tue Nov 21, 2017 11:34 pm
Platform: Mac

Tue Nov 13, 2018 2:14 pm Post

I also loved the dark mode, thank you so much for that!
My question is how to make the margins in the editor have the same colors as the text area? For some reason, on my screen the text area is grayer than the margins, which have a darker shade of gray. Is that possible at all, as in the light mode margins and text area have pretty much the same color?
thank you if you could help -- if that's not possible, that'd be OK with me.

br
brookter
Posts: 1767
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Tue Nov 13, 2018 3:23 pm Post

Have a look in Preferences > Appearance > Main Editor > Colours

The two settings are in Editor (ie the background to the main text) and Fixed Width Background.

To change the colours, just click on the rectangle over the Choose Texture button, and you'll get the standard Apple Colour Swatch control.

HTH.