Dedication and Acknowledgements not top aligning

dp
dpouliot
Posts: 33
Joined: Fri Mar 30, 2018 10:45 pm
Platform: Mac

Sat Nov 10, 2018 3:49 pm Post

dedication.png
dedication.png (79.77 KiB) Viewed 112 times

I'm compiling to PDF, and as you can see in the attached screenshot, for some strange reason these 2 pages don't top align. I've recreated the Acknowledgements page by duping the Dedication page. I've determined that if the Acknowledgements page is not longer 1 page in length, the Titles align. For some reason, as soon as Acknowledgements exceeds 1 page, the title moves down. I've gone through the layouts, sections editor with a fine tooth comb, and none of the settings seems to apply here. Thoughts?

User avatar
KB
Site Admin
Posts: 20321
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sat Nov 10, 2018 4:00 pm Post

Would it be possible either to send us the project or to attach a sample project (zipped) up to this thread showing the issue?

Thanks and all the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

dp
dpouliot
Posts: 33
Joined: Fri Mar 30, 2018 10:45 pm
Platform: Mac

Sat Nov 10, 2018 4:27 pm Post

attached.
Attachments
Super Human TEMP.zip
(784.61 KiB) Downloaded 7 times

Jo
JoRo
Posts: 453
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Sat Nov 10, 2018 9:13 pm Post

Downloading the project and compiling to “US Trade (6x9”)” straight out of the box, the alignment looks fine, for me. What compile format are you actually using, as clearly – from our grabs – I am seeing a different font in the compiled PDF?

Slàinte mhòr.

Grab.jpg
Grab.jpg (385.21 KiB) Viewed 87 times

dp
dpouliot
Posts: 33
Joined: Fri Mar 30, 2018 10:45 pm
Platform: Mac

Sat Nov 10, 2018 10:28 pm Post

So strange. I shortened the Acknowledgements and now it is lining up. It's a mystery but at least it is working now. Thanks!

User avatar
KB
Site Admin
Posts: 20321
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Sun Nov 11, 2018 11:36 am Post

Thanks for the sample project. I've found the bug. It's caused by turning on widow or orphan control - the widow and orphan control is wrongly aligning the text area to the bottom of the page when a line is removed from the bottom to avoid widows or orphans. Ironically I missed this because I tested widow and orphan control with very complicated documents containing footnotes; the bug doesn't occur when there are footnotes. This will be fixed for 3.1.2.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."