[LH3255] Possible bug in corkboard view ...

To
TomGoodell
Posts: 86
Joined: Tue Nov 13, 2012 3:13 pm
Platform: Windows

Sun Sep 02, 2018 9:23 pm Post

I have Navigate/Corkboard Selection Affects/Other Editor set. When I click on an item in the corkboard in one side (let's say left), it appears on the right in whatever view I last used on the right. That was working fine until today when clicking on a card in the left editor would open the contents of the card in the right editor in text view mode, regardless of whether the card had child files or not. I could switch the right editor to corkboard view, but when I'd click on another card in the left editor, the right editor would open it in text view, even though there were stacked child files in the card I clicked on in the left.

I went into Options/Behavior to see if there were any settings there that I might need to adjust. I made no changes, clicked on OK (or possibly Cancel), and after that it worked as it should—clicking on the card in the left editor displayed the contents of that card in the right editor in whatever view I last used in the right editor.

Sorry this isn't more precise, and I haven't figured out yet how to reproduce it, but I thought it was worth posting. I'll keep my eyes out.

User avatar
MimeticMouton
Posts: 8680
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Mon Sep 03, 2018 12:32 am Post

Thanks for posting. If you can find a reproduction case, that would be extremely helpful. Other than the setting for how document groups should be handled, there aren't currently global options that would affect this. That is worth checking, though, should you encounter it again (or if you recall from previously): were the items opening in text view folders or document groups? When the latter aren't set to be treated as folders, they will by default open in the single text view, the same as other document files without subitems. Folders should always open in the current group view mode regardless.

The only other thing I can think of that would normally affect this is the ability to lock an item to a specific group view mode. When a container is locked this way, it will always open in *its* last group view, regardless of whatever is the current group view mode. When a container is locked, you should see a little lock icon on the group view icon in the main toolbar. You can lock or unlock a container to the group view mode via the document icon menu in the editor header bar or via Navigate > Editor > Lock Group View Mode.
Jennifer Hughes
(MM for short)

To
TomGoodell
Posts: 86
Joined: Tue Nov 13, 2012 3:13 pm
Platform: Windows

Tue Sep 04, 2018 10:16 pm Post

Thanks for those tips. I am currently working only with files; I haven't created any folders in the project. If I understand the terminology correctly, any file/folder with children is a "group," So the files that had sub-documents were groups. Groups are set in the Options to be treated as folders.

I have not experimented with locking. There are no lock icons appearing anywhere, and the Navigate>Editor>Lock Group Mode is not turned on.

I can reproduce this, tested it on two computers, with the project it originally appeared in, then with a new project I created for testing it. It does not occur in the tutorial project that comes with the beta.

Here's what I did:

Created a project with a few files, created sub-documents under some of them. I did not create any folders.

Viewed one of the groups in the left editor in corkboard
Set the Navigate>Corkboard selection affects to Other Editor
Clicked on a file with sub-documents in the right editor and put it in corkboard view
Clicked on a file that had sub-documents in the left editor corkboard
The file contents appeared in the right editor in text view
Tested this with a few other files, some of which had sub-documents and some didn't. All of them always appeared in text view, regardless of whether they had sub-documents.
Opened Options, clicked Cancel.
Tested clicking on files with children again; the problem persisted.
Opened Options, clicked on OK.
The problem went away.

Behavior was identical on two different computers with same projects.

I've attached the test project zipped up. Please let me know if there's anything else I can do to help narrow this down.
Attachments
Scriv 3 Test.scriv.zip
(38.62 KiB) Downloaded 40 times

th
thePhilosoraptor
Posts: 509
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Sat Oct 13, 2018 9:21 pm Post

Sorry for the delay in replying to this. This has now been filed. It appears there is an issue where "Treat documents with children as folders" is not working until after the project has been closed and reopened AND options have been 'OK'd again.

If you run into this again just know that closing and reopening the project, then pressing OK in the Options window should fix it.
Bryan Bender