Include Tag Processing

Jo
JoRo
Posts: 186
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Sat Jul 14, 2018 8:11 am Post

The sample project attached has two text files in the draft folder.

Both of these files have <$include:filename> tags that reference three texts stored in the research folder.

The first text file in the draft folder has no additional text after the include tags. When compiled (to PDF, RTF, etc), only the first include tag is processed.

The second text file in the draft folder has some additional text after the include tags. When compiled (to PDF, RTF, etc), all three include tags are processed.

The very strange thing here is that if the additional text is shortened, only one or two – depending on the length of the additional text – of the include tags are processed.

Is this a bug?

Include.pdf
(23.44 KiB) Downloaded 4 times


Include.zip
(53.44 KiB) Downloaded 5 times

User avatar
AmberV
Posts: 21681
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Sat Jul 14, 2018 11:59 am Post

Yeah it does look like there is something odd thereabouts. I also tried using the document link format instead of referring to section types by name in the placeholder, and still got the same result. I suppose I’ve never come across this one because I either use it as the sole content of the file (acting more like a proxy for the original item) or embedded within a much longer document as a short phrase.

I’ll make sure Keith gets these results, thanks!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Jo
JoRo
Posts: 186
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Sat Jul 14, 2018 4:52 pm Post

Thanks, Ioa.

Just as an FYI, the issue started here:

https://www.literatureandlatte.com/foru ... =2&t=52823

Which led to here:

viewtopic.php?p=270610#p270610

I replicated the issue (having previously only used include tags as you describe) and then posted this thread.

Be good if it could be made to work for the other poster or for anyone else in the future.

Best.

kc
kcs304
Posts: 45
Joined: Fri Dec 08, 2017 8:49 pm
Platform: Mac

Tue Jul 17, 2018 5:16 pm Post

Thank you @Jo for raising this as a bug. I appreciate it. Hope this gets fixed in the next update.

-Kasey