Spellchecker - making it work

Ze
Zelator
Posts: 1
Joined: Mon Mar 21, 2016 5:47 am
Platform: Linux

Mon Mar 21, 2016 6:39 am Post

There are some incredibly intricate solutions on this forum, but I found a variant of viewtopic.php?f=33&t=33533 did the trick:

Code: Select all

sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/


I had previously installed libaspell-dev, libqt4-gui, and libqt4-core to no effect.

There were some .rws files in /usr/share/scrivener/bin/Aspell/dict/ already but they are shown as type "unknown". On restart the spellchecker works, although the first time I used it it killed Scrivener. Now seems OK.

Netrunner 14.04

jo
joefidler
Posts: 1
Joined: Tue Apr 19, 2016 10:49 am
Platform: Linux

Tue Apr 19, 2016 11:07 am Post

Following this advice I was was able to get Scrivener spelling working on my Fedora 23 desktop (after months of being too lazy to try some of the other methods). Thanks Zelator !

Before copying the dictionaries I installed:
aspell.x86_64
aspell.i686
aspell-devel.i686
aspell-devel.x86_64
aspell-en.x86_64
aspell-en.i686

Code: Select all

sudo dnf install aspell-devel.i686 aspell-devel.x86_64 aspell.i686 aspell.x86_64 aspell-en.x86_64 aspell-en.i686


On Fedora the Aspell dictionary files are stored in /usr/lib. I keep Scrivener in a bin directory for my user - this will have to be modified this to match where you keep Scrivener. So for me the command to copy the dictionary files is...

Code: Select all

sudo cp     /usr/lib/aspell-0.60/en-*.rws     ~/bin/scrivener/bin/Aspell/dict

al
alec
Posts: 13
Joined: Sat Jul 02, 2011 4:37 pm
Platform: Linux
Contact:

Mon May 02, 2016 11:33 am Post

Thank you Zelator. Most appreciated!

This worked on Linux Mint:

Code: Select all

sudo apt-get install libaspell-dev


then

Code: Select all

sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/

He
HeywoodFloyd
Posts: 1
Joined: Sat May 14, 2016 2:51 pm
Platform: Linux

Tue Jul 19, 2016 7:24 pm Post

You can save a little disk space by linking to the dictionary files instead of copying them:

Code: Select all

sudo ln -s  /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/

Sa
SageMichael
Posts: 9
Joined: Wed Jan 27, 2016 5:24 pm
Platform: Linux

Tue Jul 19, 2016 10:03 pm Post

Can someone please make this a STICKY? Amazing! Easy! and SUPER USEFUL.

Wr
WritingIsKillingYou
Posts: 1
Joined: Fri Sep 22, 2017 2:39 pm
Platform: Linux

Fri Sep 22, 2017 2:49 pm Post

Excellent! Just one extra step. I found that I also needed to install libaspell-dev. Installing only aspell was not enough; when I restarted Scrivener, I still did not see any dictionaries available in Tools -> Options -> Corrections -> Select Dictionary.

OP mentioned having installed libaspell-dev without success, so I think this may have already been present on the system and part of this solution.

Code: Select all

sudo apt install libaspell-dev


After installing libaspell-dev and copying the dictionary files as described above, I can access the dictionaries in Scrivener. Success! Thanks so much!

Ga
GameLaw
Posts: 12
Joined: Sat Jan 13, 2018 5:30 pm
Platform: Linux

Wed Feb 07, 2018 8:16 pm Post

I did as recommended:

Code: Select all

sudo apt install libaspell-dev
sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/


and 3 dictionary choices showed for me under Options/Corrections/Dictionary/Select!
Running Scrivener 1.9.0.1 (64-bit) under Ubuntu Studio 16.10 on Asus/Centrino2/nVidia..

Thanks, all!!!

li
linux68s
Posts: 16
Joined: Fri Jul 04, 2014 11:36 pm
Platform: Linux

Tue Feb 13, 2018 6:39 am Post

This worked on Linux Mint 18.3:

Code: Select all

sudo apt-get install libaspell-dev


then

Code: Select all

sudo cp /var/lib/aspell/en-*.rws /usr/share/scrivener/bin/Aspell/dict/



thanks!

User avatar
AmberV
Posts: 21695
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Santiago de Compostela, Galiza
Contact:

Mon Feb 19, 2018 6:29 pm Post

SageMichael wrote:Can someone please make this a STICKY? Amazing! Easy! and SUPER USEFUL.


Wish granted. :)
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

cp
cperfumo
Posts: 7
Joined: Mon Aug 04, 2014 9:26 am
Platform: Linux

Wed May 16, 2018 10:16 am Post

Wonderful! I can't tell you how many times I tried to get this to work!!! Thanks!

By the way, I had to make a tiny modification to your instructions because I am using a different language (Spanish).

After installing the corresponding dictionary:

Code: Select all

sudo apt install aspell-es
, I expected to only need to change "en" by "es" in your command. However, the file name of the Spanish dictionary doesn't start with "es-" but with "es" (no dash).

Long story short, the command that worked for me was:

Code: Select all

sudo cp /var/lib/aspell/es*.rws /usr/share/scrivener/bin/Aspell/dict/


Again, muchas gracias amigo!