Numbers in compile offset by 126

ke
kein_o
Posts: 4
Joined: Sun Jul 12, 2020 7:31 pm
Platform: Windows

Sun Jul 12, 2020 7:41 pm Post

My EPUB2 custom format started numbering things in 127 instead of in 1:

- Part numbers
- Chapter numbers

etc.

Note this happens with that specific format for EPUB2 but also with the default format, in the same project.

This started happening when upgrading to Version: 2.9.9.8 Beta (984260) 64-bit - 12 Jul 2020 Windows

Default format in new project works fine.

Horribly frustrating, having to modify production scripts to go fixing XHTML output everywhere.

User avatar
tiho_d
Posts: 1206
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Sun Jul 12, 2020 7:44 pm Post

Toggle the compile option: "Treat compile group as complete manuscript"

ke
kein_o
Posts: 4
Joined: Sun Jul 12, 2020 7:31 pm
Platform: Windows

Sun Jul 12, 2020 8:03 pm Post

Would you care to explain?

- Where is that option? I've spent a few minutes already looking for it.
- Why is this offset appearing? I don't have 126 parts before part one.

User avatar
tiho_d
Posts: 1206
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Mon Jul 13, 2020 6:10 am Post

This is explained in the manual shipped with Scrivener inside chapter 23.4.1 Contents Tab, pages 454, 455, 456:

1. Treat compile group as complete manuscript: ordinarily when a portion
of the draft folder is selected for compile, counter numbering will be displayed
as though the rest of the manuscript existed; chapter 13 will remain
13. When this option is enabled, the smaller portion you selected will be
treated as though it were the entire manuscript. All counters (either in
compile settings or in the draft itself) will start at 1.
This is thus useful when hosting several complete and self-contained
works in the same draft folder, and using this setting to switch between
them. It can also be used to speed up the compiler if you are just proofing
and aren’t concerned with the numbers being accurate.

If you still get unexpected results which do not match the manual, please create a small demo project reproducing the problem and upload it to this thread. Hope this helps.

ke
kein_o
Posts: 4
Joined: Sun Jul 12, 2020 7:31 pm
Platform: Windows

Mon Jul 13, 2020 1:59 pm Post

Sorry, but I can't find that option, even after scouring the user manual. It's certainly in the manual, but I can't find in Scrivener's UI.

Also, to be precise, I'm not trying to generate a subset of the work, but a full copy.

You can see the problem in this file (too large to upload at 1.4 Megabytes) https://www.dropbox.com/s/ffbi3yprra0i0 ... T.zip?dl=0

And the generated ebook: https://www.dropbox.com/s/mkxrxhlz9gosk ... .epub?dl=0

I removed most of the documents, leaving only the first one, and now the generated numbers start at 4 instead of at 126. To be clear, I want the numbers to start at 1 for the entire work, I'm not trying to generate a subset of it.
Attachments
scrivener_screenshot.png
scrivener_screenshot.png (68.12 KiB) Viewed 358 times

User avatar
tiho_d
Posts: 1206
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Mon Jul 13, 2020 2:21 pm Post

Thanks! I managed to reproduce the problem, and it will be fixed in the next update.

To workaround the bug in the current build, select any folder from the "Compile:" dropdown box.
This will reveal the "Treat compile group as complete manuscript" option.
Check this option, and switch back to your "Manuscript"(Draft) root folder.

Compile again. Everything should start counting as before.

ke
kein_o
Posts: 4
Joined: Sun Jul 12, 2020 7:31 pm
Platform: Windows

Mon Jul 13, 2020 2:52 pm Post

That did it. Thanks a lot!!!

User avatar
LAP
Posts: 1023
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Tue Jul 14, 2020 12:47 am Post

This has now been fixed and will be available in next RC09 build.

jc
jchenn
Posts: 7
Joined: Fri Jul 31, 2020 10:33 am
Platform: Windows

Fri Jul 31, 2020 8:50 pm Post

Good to hear! I had same problem. The work around seems to have fixed the issue for me too. I was getting double chapter lines but that disappeared too once I selected compile as a group.