Setting Language Preference as English with System Default set at Japanese

xa
xanadu1962
Posts: 2
Joined: Thu Feb 13, 2020 7:55 pm
Platform: Mac
Location: Tokyo, Japan
Contact:

Thu Feb 13, 2020 8:14 pm Post

Hi. I am from Tokyo, a Japanese native, using Japanese language.

I find it a little messy with Japanese localization in Scrivener 3 and want to use it in English mode. Unfortunately, however, there is no "English" in the list of Scrivener 3 language preferences.

Since I chose System Default as the preferred language in Scrivener 3 and my OS-wide system default language is set at Japanese, Scrivener 3 launches in Japanese mode quite naturally. I want it to launch in English mode. How can I set Scrivener 3's language preference as English?

Setting English as the OS-wide language preference is an overkill since I want all the other applications than Scrivener 3 to launch in Japanese mode.

Thanks in advance. Oh, and happy Valentine's Day, incidentally BTW :-)
---

Tohru Okai <okai@me.com>
Tokyo, JAPAN

User avatar
kewms
Posts: 6434
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Feb 13, 2020 10:15 pm Post

Available interface languages in Scrivener 3.1.5 are:

English, French, German, Spanish, Italian, Japanese, Chinese, Korean, Portuguese, and Swedish.

On my system, the dropdown in the Scrivener -> Preferences -> Language pane lists System Default first, then the rest in the above order. What are you seeing?

Katherine
Scrivener Support Team

xa
xanadu1962
Posts: 2
Joined: Thu Feb 13, 2020 7:55 pm
Platform: Mac
Location: Tokyo, Japan
Contact:

Fri Feb 14, 2020 4:13 pm Post

Hi, thanks for your reply, Katherine. Results first: the problem solved!

My language preference's listed items among Pop-Up menu in Scrivener 3.1.5 (build 1228) are:

システムデフォルト (System default)
Translation (of which I don't know what it is and which does not seem to have been listed in your Pop-up menu)
フランス語 (French)
ドイツ語 (German)
スペイン語 (Spanish)
イタリア語 (Italian)
日本語 (Japanese)
中国語 (Chinese)
韓国語 (Korean)
ポルトガル語 (Portugese)
スウェーデン語 (Swedish)
and no 英語 (English) in the Pop-up menu.

While you have "English," I don't, but instead I have "Translation" which you don't have.

So, I tried "Translation," relaunched Scrivener 3 and then voila! System language has changed to English! Silly me, I hadn't tried it up till the time when I posted my question in the first place.

IMHO, "Translation" should read "英語" (English) BTW.

Thanks again, Katherine, for your post! :D
---

Tohru Okai <okai@me.com>
Tokyo, JAPAN

User avatar
kewms
Posts: 6434
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Fri Feb 14, 2020 4:39 pm Post

Ah, yes, that explains it.

Someone else mentioned that recently as well, and I've passed it along to the translation team.

Katherine
Scrivener Support Team

lo
lordvaldomero
Posts: 1
Joined: Tue Feb 18, 2020 3:57 am
Platform: Windows
Contact:

Tue Feb 18, 2020 4:03 am Post

Thats Awesome