Kerning problems with Compile / Can't change font color via Apperance Panel

ke
kej2u
Posts: 19
Joined: Tue Jul 01, 2008 12:03 am

Wed Dec 04, 2019 1:50 pm Post

Raised this before, but seems like it's still an issue. When I compile, the letter spacing (kerning) in the words isn't correct. The words don't render properly and end up looking jumbled, with the letters too close together. See image below.

Image

Also, the text color options don't work...

File>Options>Appearance>Colors>Composition Mode>Text
File>Options>Appearance>Colors>Editor>Text

No matter what is selected, the text remains black. This makes it impossible to create a custom dark mode because I can't change the black text to yellow or blue, etc. This bug has persisted for the past year, despite prior identification.

Image
Image

Thanks for all of your hard work! None of this is intended to come off snarky. Just wanted you to know that these are two bugs that seriously inhibit my use case and might do so for others as well. If I can't compile properly to send to an agent/editor, the app won't hold much value.

Version: 2.9.0.30 Beta (757109) 64-bit - 28 Nov 2019 running on Windows 10.

rw
rwfranz
Posts: 761
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Thu Dec 05, 2019 9:33 am Post

Text colors: Both of those work here quite well; just tested each. Not sure how to help you here. You might try a clean reinstall of Scrivener (uninstall and reinstall), making sure it's in its own directory (I usually completely delete the old installation directory before reinstalling).

As for the compile spacing, this may be related to another setting, which you'll have to experiment a little with.

In File -> Options -> Editing -> Options -> about a third down the dialog box, on the right side: Print and PDF hinting. Default may change based on platform, but you may see better results with a different setting. Some need this adjusted, others need it to remain as-is; thus the option.