Character style not persisting

ke
keithyd
Posts: 4
Joined: Sat Sep 08, 2018 4:09 pm
Platform: Windows

Mon Dec 02, 2019 12:30 am Post

Two issues actually.
1. I've used the Options and Formatting menus to create a standard format for my works - Palatino, 11 pt.
This appears okay in the editing screen for all new documents.
I've then applied a paragraph style to indent paragraphs with each Return and new paragraph: First Line Indent. The character style is set to 'body text'.
All this still looks okay in the editing screen - Palatino and first line indented.
However, when I press Return for a new paragraph, the new Paragraph retains the First Line Indent style that I've created but loses the 'body text' format of Palatino. It still looks okay on the editing screen, but the character style in the Styles box of 'body text' disappears - leaving just 'First Line Indent'- and when compiled into Kindle .mobi format, and read on my Kindle, this text is transformed into a sans serif font like Arial or similar.
Consequently, each time I Return for a new paragraph I have also to click the Styles box and click on 'body text' to ensure that what's created is in fact formatted in Palatino for compiling.

2. Is there a way to format the text created by the Folders in the Binder when compiled? My Folders create Chapter 1, Chapter 2, etc, but appear when compiled to Kindle format in a sans serif format, ranged left, when I want them to be in Palatino and centered.

br
brookter
Posts: 1980
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Dec 02, 2019 12:14 pm Post

A quick question:

Why are you assigning a body text character style to your default paragraph format? You shouldn't have to do that.

Basically: paragraph and character styles are only for use for exceptions to the rule -- to override your basic default paragraph for a specific purpose. The character style for your basic paragraph is built into the default paragraph style which you set with Options > Editing > Formatting. You don't need to apply a character style on top of that.

So, just make sure that the text in the Options > Editing > Formatting looks the way you want it to, including Font, size, indent, line spacing, colour -- everything. The easiest way to do this is to format a paragraph in an editor to look exactly how you want it, then select the whole paragraph and Options > Editing > Formatting and click "Use formatting in current editor".

By creating a specific Body Text style rather than building it into the default paragraph style, you're having to override the default for every paragraph.

The time to use character styles is when you want to override the paragraph style for a few words, phrases or sentences. E.g. I have a character style called Done, which adds strikethrough and changes the text to grey -- I use it for todo lists. I don't want it to apply to a whole paragraph, so it's a character style only.

HTH.

br
brookter
Posts: 1980
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Dec 02, 2019 12:21 pm Post

For your second question, you format how various elements of your document are governed in the compilation dialogue.

When you've chosen the Kindle format, click on Assign Sections Layouts, then on the Section Type you've used for Chapters (probably Heading), then on the Section Layout which is nearest to how you want it to look in the ebook. A quick glance suggests that it may be called Chapter Heading (Bordered).

If none of the available section layouts are suitable, then duplicate and edit the compilation format -- you'll be able to edit or create a layout which suits your needs then.

If you haven't gone through the Interactive Tutorial already, then now is a good time to do it (especially the section on compilation) -- it will really help you understand how the various elements hang together.

HTH.

ke
keithyd
Posts: 4
Joined: Sat Sep 08, 2018 4:09 pm
Platform: Windows

Mon Dec 02, 2019 4:02 pm Post

brookter wrote:A quick question:

Why are you assigning a body text character style to your default paragraph format? You shouldn't have to do that.



Thanks for the reply - very helpful. I set up a new style in the old Scrivener so I could highlight the first three words of a new chapter or section, then just click the character style to convert those words to Small Caps. I guess I was trying to duplicate that. It's a system I've used for 2-3 years now and I suppose I didn't expect it to have changed.

Anyway, I seem to have managed it now and the text and chapter headings are being created how I intended, though I think Scrivener is complicating the formatting somewhat with these new Section styles in Compile. :?

Thanks again for your help.

ke
keithyd
Posts: 4
Joined: Sat Sep 08, 2018 4:09 pm
Platform: Windows

Mon Dec 02, 2019 4:04 pm Post

brookter wrote:For your second question, you format how various elements of your document are governed in the compilation dialogue.



Thanks again - I've been using Scrivener for 4-5 years so I thought I'd cracked it! If I'd formatted the Chapter headings in the past, I'd forgotten how I did it. Anyway, all good now. Thanks.

PS Expect to see me here again! :lol:

br
brookter
Posts: 1980
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Dec 02, 2019 4:48 pm Post

Yes, the styles and compilation processes are probably the things which have changed the most in the new version.... they’re probably slightly more confusing if you’re steeped in the old ways than if you come to them fresh because some of the underlying assumptions have changed.

When you’re used to it, it’s more logical and more flexible than the old system (actually some of the old system is still there in advanced options), but there’s no denying there’s a learning curve. Have you seen the Tutorial to help people migrate from V2? It’s here: https://www.literatureandlatte.com/scrivener-3-update-guide.

Regards

br
brookter
Posts: 1980
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Dec 02, 2019 5:45 pm Post

Right -- I had to play around with this to refresh my memory, hence the delay.

Problem: You want to have the first three words of each Chapter set in small caps.

This is how you do it in Version 3 -- it's all done in compilation, no need for anything in the editor (or not much...)

As I understand it, in the Binder you have Chapters (folders with just the title, not actual text) and Scenes (the titles are ignored and only the text is compiled), which are subdocuments of the chapter folders.

So that's two basic Section Types (Chapter and Scene -- the names don't really matter). So you compile and choose the compile format, then assign each section type to a section layout. Normally this will be something like Chapter Heading and Section (here it's the look which matters, not the name.)

By default, most of the default Section Layouts don't come with a 'first three words small-cap' layout, so you'll have to create one. In fact it's much simpler just to modify a copy of the Scene layout which already does most of what you want, minus the small caps.

Duplicate the compilation format and edit it. In the edit dialogue choose Section Layouts on the left, then on the right, highlight the layout you use for scenes. Click the plus sign to duplicate it and give it a meaningful name ('Smallcap Scene').

With Smallcap scene selected, click on the tab marked New Pages in the dummy text box below. You'll see a number of options , including the number of words you want to make uppercase (3) and a tick box to choose Small Caps. Make sure that you tick the box Upper case even when section is not after a page break. Now click back on the Formatting tab to see the effect of the change. The dummy text should show the first three words in small caps.

Click save to exit the edit dialogue, and go to Assign Sections Layouts again, but time assign your Scene Section Type to your new SmallCap Scene layout. Compile and you should find that all the scenes now begin with 3 words in Small Caps.

But.... you may want only the first scene in a chapter to have the small caps, and subsequent scenes to be as before. No problem... all you need to do is create a new Section Type in the Editor (e.g. 'First Scene') and assign it to the first child scene of each binder. Then in compilation, assign First Scene to the layout 'Small Cap scene' and ordinary Scenes to the normal default Scene layout. That should be it -- the first scene of every chapter gets small caps, the rest don't.

(There are other ways of doing the same thing, but this is what I'd do.)

Again, it takes a lot longer to type out than it does to do, once you've got the hang of how compilation works.

You'll have to play around a bit to get it exactly how you want it, but I hope this helps to get you started!

ke
keithyd
Posts: 4
Joined: Sat Sep 08, 2018 4:09 pm
Platform: Windows

Tue Dec 03, 2019 12:14 am Post

Thanks again. I think I've managed to crack the Small Caps-first-three-words thing simply by creating a character style called Section Start. This is essentially a short cut to the Format/Small Caps menu item. So every time I start a new Chapter or Section (after a line break with a divider in it), I just highlight the first three words, click the Styles box (which I've added to the visible formatting boxes in the Editor) and then choose Section Start from the Character Styles list. This is what I used to do in the previous versions of Scrivener and it still works. I understand your route would mean that I don't have to think about it, but to be honest it's not a great hassle, and as I'm in the middle of the book I don't want to devote more time to re-learning Scrivener. When the final version for Windows comes out I'll read through the manual (the one linked to in Help is the Mac version - or at least has Mac imagery in it), and I'll watch the videos, too.

Thanks once more.

br
brookter
Posts: 1980
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Tue Dec 03, 2019 8:29 am Post

No problem. I was trying to work out how to do it anyway, once you'd raised the issue...