[LH4350] Space/Kerning issue in beta 3 - Urdu - Font Jameel Noori Nastaleeq - Right to Left

User avatar
bush46
Posts: 13
Joined: Fri Sep 13, 2019 3:08 am
Platform: Mac + Windows

Fri Oct 25, 2019 11:33 am Post

My comments apply to beta 3 in WIN10. Urdu language, text direction Right to Left, font Jameel Noori Nastaleeq.

The difference I have found in the beta 3 version is that of unpredictable (?) font kerning and space bar cursor movement.

The standard version 1.9.15.0 allows me to visibly advance a space when I tap the Space bar key after finishing a word. The cursor keeps on advancing each time I tap Space key. Also, the Urdu words appear well spaced.

Standard Version.png
Standard Version.png (24.24 KiB) Viewed 1756 times


In the beta version 2.9.0.26 there is NO visible space movement on tapping Space key after a word, no matter how many times I tap. The tiny space becomes visible only after typing the next word. Overall, the space between words appears crowded.

beta 3 version.png
beta 3 version.png (20.82 KiB) Viewed 1756 times


Strangely enough, the crowded end result actually looks more like if it had been traditionally hand written (scribers tend to overlap some words slightly depending on the edge characters to write more in a given space. This may be desirable but having no visible cursor movement as you tap Space bar is unexpected. What if I wanted more than one space between words?

User avatar
MimeticMouton
Posts: 8876
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Feb 15, 2020 9:19 am Post

Thanks for the report, and my apologies for the late reply here. This is logged in our bug tracker to take a look at; I'm afraid I don't have a solution for you immediately. If you copy and paste the text into another word processor that supports the font, does the spacing appear correct there? What if you compile it to RTF or PDF from Scrivener using the "Default" compile format?
Jennifer Hughes
(MM for short)

User avatar
bush46
Posts: 13
Joined: Fri Sep 13, 2019 3:08 am
Platform: Mac + Windows

Wed Feb 19, 2020 8:17 am Post

MimeticMouton wrote:Thanks for the report, and my apologies for the late reply here. This is logged in our bug tracker to take a look at; I'm afraid I don't have a solution for you immediately. If you copy and paste the text into another word processor that supports the font, does the spacing appear correct there? What if you compile it to RTF or PDF from Scrivener using the "Default" compile format?


Please see sample of results as you suggested.
TestSample20200219.png
TestSample20200219.png (48.6 KiB) Viewed 1086 times

User avatar
bush46
Posts: 13
Joined: Fri Sep 13, 2019 3:08 am
Platform: Mac + Windows

Tue Mar 31, 2020 6:58 am Post

MimeticMouton wrote:Thanks for the report, and my apologies for the late reply here. This is logged in our bug tracker to take a look at; I'm afraid I don't have a solution for you immediately. If you copy and paste the text into another word processor that supports the font, does the spacing appear correct there? What if you compile it to RTF or PDF from Scrivener using the "Default" compile format?


Further to the Space key not advancing cursor for Urdu fonts I have experimented with several Urdu fonts. Here is the result screen grab. Space key works with some but not with others.

I do not understand what difference there is in programming of Editor screen between Scrivener version 2 (1.9.16.0) and version 3 (2.9.0.44 (Beta) 26 March 2020. Space key works as expected in version 2 but not in version 3 for some fonts as per sample below. If it was a font problem then why does it work in version 2?
Unfortunately, I am using Version 3 beta and having problem with "Jameel Noori Nastaleeq", a font of my choice for my book.
ScrivenerMultifontSample_SpaceIssue.jpg
ScrivenerMultifontSample_SpaceIssue.jpg (242.55 KiB) Viewed 891 times

User avatar
MimeticMouton
Posts: 8876
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Apr 21, 2020 4:09 am Post

Thank you for your continued testing! I'm sorry we've not been able to address this yet; it is on our to-do list, and I hope will be solvable once the developers are able to dedicate more time to investigating it. There were various internal changes to the editor between 1.x and 3.0, not least major updates to the framework Scrivener is built on, so I don't know what particularly is causing the difference here.

One thing that might be helpful which I didn't consider earlier would be checking the screen resolution. To be very specific about this, Scrivener's log will grab this information, so the best way to share it would be to launch Scrivener via the "ScrivenerLog" file within the Scrivener installation folder:

1. In File Explorer, navigate into the Scrivener installation folder (usually C:\Program Files\Scrivener).
2. Right-click the "ScrivenerLog" file and choose "Run as administrator", supplying your password as needed. This will allow Scrivener to generate a log file and save it inside the Program Files folder.
3. Once Scrivener's open, type a line in the editor using the Jameel Noori Nastaleeq font--I don't really expect the log to show anything relative to that, but it wouldn't hurt.
4. Close Scrivener normally, and close any remaining console windows.
5. Refresh the view in File Explorer and find the new "log" folder in Scrivener's installation folder. Right-click the file within the "log" folder and choose "Send to \ Compressed (zipped) folder", then attach that here or mail it to win3beta@literatureandlatte.com; include a link back to this post.

One other thing you could try is using one of the fonts that does work for typing in the editor, and then trying to compile in the preferred Jameel Noori Nastaleeq font. This isn't really helpful of course for the matter of you being able to write in the font in the editor, but it would be helpful to know if it works to, and if it does it would at least let you output in your preferred font. You can set a global font override for compile at the top of the middle Section Layouts pane in the compile window where it says "Font:" and then has a dropdown menu that probably currently says "Determined by Section Layout". Click into the menu to choose the font you want, then try compiling. Does the spacing come out all right?
Jennifer Hughes
(MM for short)

User avatar
bush46
Posts: 13
Joined: Fri Sep 13, 2019 3:08 am
Platform: Mac + Windows

Thu Apr 23, 2020 9:06 am Post

Thank you
Launched batch file as per your instructions.
Opened newly created document with single line and typed in another line in Jameel Noori Nastaleeq font, adding single space between words (as usual, cursor doesn't show movement with Space key but tiny space becomes visible on typing next word).
Saved and closed document.
Attaching both screen grab and the zipped log file.

Will next try using different Urdu font that shows cursor advancing but will compile in Jameel Noori Nastaleeq.
Attachments
Scrivener-20200423-181751249.zip
(15.3 KiB) Downloaded 82 times
Test_Image_V2.9.9.4 Beta.png
Test_Image_V2.9.9.4 Beta.png (22.05 KiB) Viewed 742 times

User avatar
bush46
Posts: 13
Joined: Fri Sep 13, 2019 3:08 am
Platform: Mac + Windows

Sat Apr 25, 2020 2:03 am Post

Further testing re above Urdu fonts Space key cursor advance issue. My comments included with images. Hope it helps.
The plot thickens.... :lol:
Test_V2.9.9.4 Beta_Urdu_Fonts_Compile_Outputs.png
Test_V2.9.9.4 Beta_Urdu_Fonts_Compile_Outputs.png (58.37 KiB) Viewed 691 times

User avatar
bush46
Posts: 13
Joined: Fri Sep 13, 2019 3:08 am
Platform: Mac + Windows

Mon May 11, 2020 7:29 am Post

MimeticMouton wrote:....

One other thing you could try is using one of the fonts that does work for typing in the editor, and then trying to compile in the preferred Jameel Noori Nastaleeq font. This isn't really helpful of course for the matter of you being able to write in the font in the editor, but it would be helpful to know if it works to, and if it does it would at least let you output in your preferred font. You can set a global font override for compile at the top of the middle Section Layouts pane in the compile window where it says "Font:" and then has a dropdown menu that probably currently says "Determined by Section Layout". Click into the menu to choose the font you want, then try compiling. Does the spacing come out all right?


Results of doing as suggested above.
This time I am using WIN 7 64-bit on laptop. Will check the same also on my PC WIN10 64-bit.
1. In Editor layout used style font Noto Urdu Nastaliq
2. In Compile set up asked default font Jameel Noori Nastaleeq
3. Compiled PDF output is NOT in Jameel Noori Nastaleeq
4. In Editor layout selected all text and changed font to Jameel Noori Nastaleeq.
- Compile setting remains default font Jameel Noori Nastaleeq as per No. 2.
5. Compiled PDF output is in Jameel Noori Nastaleeq.
Attachments
4.5.Jameel2JameelCompile.jpg
4.5.Jameel2JameelCompile.jpg (110.03 KiB) Viewed 493 times
1.2.3.Noto2JameelCompile.jpg
1.2.3.Noto2JameelCompile.jpg (149.64 KiB) Viewed 493 times