Problem with Compiling

ki
killerberg
Posts: 2
Joined: Fri Dec 14, 2018 6:01 am
Platform: Mac

Thu Jun 13, 2019 5:08 pm Post

I have a fairly basic folder = chapter and text = scene structure for my current WIP, but whenever I go to compile it, I get a really weird output. You can see it better in the attached screenshot, but it appears that Scrivener is compiling the text that appears on the text documents inside the folders. appropriate chapter headings, but not the text that goes with them. So I'll have long stretches of nothing but chapter headings without any of the text between them.

For example, on the left. You can see I have text documents inside folders labeled "Gardens", " Attempted Kidnapping," "Dungeon Conversations" etc. When I view the preview for the output of a Standard Manuscript Format, those sections are the only ones whose text appears correctly. In addition, those are all supposed to be scene breaks, not separate chapters, but I think that's a separate issue.

I'll happily add more details or screenshots if needed.

Thanks in advance for any help!
Attachments
Screenshot2.png
Screenshot2.png (266.93 KiB) Viewed 116 times
Screenshot1.png
Screenshot1.png (276.93 KiB) Viewed 116 times

User avatar
rdale
Posts: 1505
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Thu Jun 13, 2019 6:34 pm Post

If I'm seeing things correctly, your folders don't "contain" text documents. If they did, then you'd see that little "disclosure triangle" like the one to the left of "Kaylee gets mad...", and when you clicked on it, the document would appear indented below it.

Instead, what you've done is to write "on" the folder itself. Folders can freely be changed into text documents and vice-versa, but the compile presets treat them differently by default (folder text is usually ignored).

Based on the majority of your project, I think you could convert most of your folders, the ones without documents "in" them (the Kaylee and the Privy Chat folders DO have documents in them, as a counter-example), into text documents. The compile settings will then take the title from the "level 1" documents, but still include the text they contain.

You can do this conversion by selecting one or more folders (click on the first, SHIFT-click on the last that you want to select), and then use the gear icon at the bottom of the binder.

So long as your compile settings don't change from the defaults, the results should be the same as if you converted each folder to a text document and then created a folder for each to be put into, while allowing you to keep the level 1 folders with text documents that are indented below them as-is.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

ki
killerberg
Posts: 2
Joined: Fri Dec 14, 2018 6:01 am
Platform: Mac

Fri Jun 14, 2019 12:54 pm Post

Thanks a ton for your help. That worked beautifully. This was driving me bananas!

User avatar
rdale
Posts: 1505
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Jun 14, 2019 4:15 pm Post

FYI, there's a section of the manual (and probably the tutorial project template) that has a list of binder icons that explain what each means. The folder with a text page overlay means you've written "on" the folder. You can see those from your screenshot, and the difference when you put your text into documents that are indented beneath your folders. It's helpful to know what each icon means, and which ones override which others.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".