Selecting Documents to Compile

Posts: 4
Joined: Mon Apr 11, 2016 5:19 am
Platform: Mac

Fri May 17, 2019 3:41 pm Post

I've been unable to get anything to compile beyond one blank page.

In the Compiling your Work video, the Compile window is magically populated with the entire manuscript. Mine is blank.

In the main Scrivener window I select a Folder that has documents in it and then it does appear in the Compile window checked, but no documents appear underneath it, and I get only one blank page when I compile.

How do you get your documents to appear in the Compile window? Doesn't selecting a folder also select everything in it?

Thank you

User avatar
Posts: 3922
Joined: Wed Aug 21, 2013 4:24 pm
Platform: Mac + iOS
Location: Sweden 64° N

Fri May 17, 2019 4:10 pm Post

No, because the folders in the binder are just documents with a different icon.

If you choose to compile ”selection” you need to select all the documents you want to compile.
I am a user, writing non-fiction and science, using:
* Mac Scrivener 3 on a Macbook 12”, MacBook Pro 13”, and iMac 27”, all running Mojave.
* iOS Scrivener 1 on an iPhone 11 Pro, iPad Air 9.7”, and iPad Pro 12.9”, all running the latest iOS

User avatar
Posts: 24139
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza

Fri May 17, 2019 6:27 pm Post

It depends on precisely how you are compiling, it would help to know what settings you are using. But for using the "Current Selection" as your compile group, via the dropdown menu at the top of the contents list, you will note there is an Include subdocuments checkbox that does just what it says.

While you're there, it also kind of sounds like you really aren't interested in compiling your selection in the first place, so maybe setting that dropdown to compile the whole Draft folder, as it would be by default, is a better place to start from. Compiling only what you have selected in the binder beforehand is a more advanced way of using the software.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles