Compiling is not working...

pl
plocploc2017
Posts: 15
Joined: Thu Jul 27, 2017 8:58 pm
Platform: Mac

Mon Feb 05, 2018 11:44 am Post

Hello everybody,

I'm using Scrivener for many years now and I love it. But compiling is difficult for me.
I've seen the videos, I've tried many times, I can't do it properly.

I'm writing a novel and I just want to change the size of the font in my compiling mode.

Here is a screenshot (it's in french)

par défaut 2018-02-05 à 12.41.20.jpg
par défaut 2018-02-05 à 12.41.20.jpg (512.89 KiB) Viewed 2684 times


As you can see my page layout is supposed to end around 16 cm. And the font is Cochin 11.

I attributed the text section to my section. I followed the steps described in the videos...

But when opening my document in Word... My text is still Cochin 14 (like in my scrivener editor) and the tab is not correct
par défaut 2018-02-05 à 12.34.26.jpg
par défaut 2018-02-05 à 12.34.26.jpg (422.79 KiB) Viewed 2684 times


What am I doing wrong ?

thanks for any help...

pl
plocploc2017
Posts: 15
Joined: Thu Jul 27, 2017 8:58 pm
Platform: Mac

Mon Feb 05, 2018 11:52 am Post

Oh and off course I didn't forget to assign my layout


par défaut 2018-02-05 à 12.53.57.jpg
par défaut 2018-02-05 à 12.53.57.jpg (293.37 KiB) Viewed 2681 times

User avatar
AmberV
Posts: 24273
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Feb 05, 2018 12:01 pm Post

It looks like your compile format is mostly set up correctly. You have formatting overridden since the sample text for “Texte” is black. The other component would be: are the document types in your editor actually assigned to use this Layout? That is going to be set up somewhere outside of these screenshots, in the compile overview area itself. If you haven’t done so, and the “Texte” document type is simply printing “as-is”, well then no amount of adjustment to the Layout (incidentally also named “Texte”) is going to change it.

As for the right-indent usage, it looks like you’re trying to use that like a margin setting. Better to drag the right-indent marker all the way to the right to disable it entirely, and make adjustments to global margins in the Paramètres des pages compile format pane.

But if for some reason you really do need to indent all text from the margin on the right side, keep in mind that 16cm from the left edge of the text block is not reliably the same thing as 16cm from the left edge of the paper itself. You have 2.54cm unaccounted for it seems, from the left margin.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

pl
plocploc2017
Posts: 15
Joined: Thu Jul 27, 2017 8:58 pm
Platform: Mac

Mon Feb 05, 2018 12:54 pm Post

Thanks for your answer Amber !

I'm not sure to understand it quite well.

1/ For your first remark, are you talking about this assignment ?
par défaut 2018-02-05 à 13.49.51.jpg
par défaut 2018-02-05 à 13.49.51.jpg (196.9 KiB) Viewed 2677 times



2/ I've tried to deal with the margin but my word document is still out...

par défaut 2018-02-05 à 13.52.26.jpg
par défaut 2018-02-05 à 13.52.26.jpg (262.23 KiB) Viewed 2677 times

User avatar
AmberV
Posts: 24273
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Feb 05, 2018 1:17 pm Post

Oops, yes it looks like you posted the layout assignment while I was writing the other response. Yes, that looks good.

Hmm, one other thing that might be changing the text size (and indent for that matter) is if you have a style applied to the text, and that style (in the Styles compile format pane) is set up to 14pt Cochin.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

pl
plocploc2017
Posts: 15
Joined: Thu Jul 27, 2017 8:58 pm
Platform: Mac

Mon Feb 05, 2018 1:22 pm Post

Thanks again Amber....

Really I don't understand...

I've played with the style option but it doesn't have any change...

par défaut 2018-02-05 à 14.22.28.jpg
par défaut 2018-02-05 à 14.22.28.jpg (265.17 KiB) Viewed 2671 times


Each time I want to compile my document into a word doc I don't have the right font size and the tabulations are out the page...

User avatar
AmberV
Posts: 24273
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Feb 05, 2018 2:04 pm Post

It might be helpful to post a copy of this sample project you are taking screenshots of. You can attach as a .zip here (or if it has private information, you can send it via email from our contact page.

Simply adding a style called “Cochin” isn’t what I meant to try and do, sorry for the lack of clarity. I was more concerned that there was already something there with 14pt Cochin. If there is no text styled as “Cochin” in the editor, then this style in the compiler will do nothing. This feature is for cases where say you have a heading in the editor marked “Heading 1”, and you want that heading to look different than in the editor when you compile. If you want it to look the same as in the editor you don’t need to do anything special, if that makes more sense.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

pl
plocploc2017
Posts: 15
Joined: Thu Jul 27, 2017 8:58 pm
Platform: Mac

Mon Feb 05, 2018 2:19 pm Post

Thanks Amber for try to help...

Before I sent you the project...

Let's try to be as clear as possible...

In my editor I have a style : which "Cochin, 14 pt" (because I found easier to write with a 14pt size)
When compiling before printing I want to change that style into a "Cochin, 11pt" so I've tried to format the text in the compile area or to use a style within the format box of the compile window...

Sorry my english is not so good, I hope I made myself clear...

User avatar
AmberV
Posts: 24273
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Feb 05, 2018 3:00 pm Post

If I understand you correctly, we are maybe close to the problem. You are saying that all of your text in the editor is styled, and that the style uses Cochin 14? If so then that makes perfect sense with the rest of the above: styles wil force their formatting when you compile. They are a way of breaking the rules. So normally you would not want to style all of your text, as that would then mean none of your text can be easily changed when you compile.

But for the sake of what already exists, you might be able to override that editor style using that very “Styles” compile format pane. You just have to make sure the name of the style is precisely the same as the name of the style you are using in your text.

In case my English is difficult, I have attached a sample project that you can test with, that shows the difference between styled text and unstyled text:

  • In the editor, if you click in each paragraph you will see the first paragraph is styled (“Body Text”). The second paragraph is not styled. They look the same, but one is styled to look that way. They also have a bad indent, it is too wide for the page.
  • Now compile, and edit the “Test Styles” format I made.
  • In layouts, see how the text formatting is set to Cochin 11pt?
  • Click the Test... button in the lower left, and open the RTF in Word. You will see in the first paragraph what you describe. Cochin 14pt, and the indent runs off the page. But notice the second paragraph? That one is fine! That is because it does not have a style.

All right, so if the first paragraph in the experiment matches your project settings, here is how to fix it:

  1. Click on the Styles panel in that test project.
  2. Click the + button and choose the “Body Text” style. We choose that because this is what the text is using in the editor.
  3. Change the font size to 11pt, and drag the right indent marker all the way to the right to disable it.

Now click Test... again and open the RTF. Now both paragraphs should look the same.

So there are two ways to fix this. One is to add the style to the compile settings, as above. The other is to go into the editor and strip out styles from all of the text that doesn’t need to be special (like block quotes and headings). The second choice is more how Scrivener is designed to be used, but the first choice might be easier if you have 100,000 words already typed with styles.

Update: The attachment is not working for some reason. So I have uploaded the test project to the server.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

pl
plocploc2017
Posts: 15
Joined: Thu Jul 27, 2017 8:58 pm
Platform: Mac

Mon Feb 05, 2018 4:47 pm Post

You're right Amber. It works !

I'm deeply sorry... I thought that compiling the document would overwrite the styles...

Thanks a lot !!

User avatar
AmberV
Posts: 24273
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Mon Feb 05, 2018 5:05 pm Post

Glad it's working now! No problem. :)
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
gr
Posts: 2179
Joined: Wed Feb 14, 2007 3:57 am
Platform: Mac + iOS
Location: Florida

Wed Feb 07, 2018 1:57 pm Post

For the future, instead of using a style to get the appearance you want when working in Scriv, I am thinking you should:

1) In Scriv Prefs set the default font to Cochin. Set the font size not to what you want to see in Scriv, but the size you usually want when you compile to output.

2) Now at the bottom of the Editor pane in Scriv, increase the magnification for the editor area until the text is as big as you wish to see it while working.

If you do things this way going forward, you will not have to style your paragraphs and will not have to override those styles during compile.

gr
gr : Scrivener user : not affiliated with Lit^Lat
Image
"Nothing, like something, happens anywhere." —Philip Larkin