1.7.0.2 - Windows shortcuts for "copy" and "paste"

Li
Lilith
Posts: 351
Joined: Sat Nov 13, 2010 3:50 pm
Platform: Windows
Location: Belgium

Sat Feb 15, 2014 9:31 am Post

There are typical Windows related shortcuts for "cut", "copy" and "paste".

ctrl+delete = cut
ctrl+insert = copy
shift+insert = paste

These shortcuts do exist in the current release, but seem to have been deactivated in the beta.
Although I know (and use) the different workarounds, I'm missing them so much...

User avatar
MimeticMouton
Posts: 8824
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Feb 15, 2014 10:13 am Post

The Shift+Delete shortcut does still work to cut the text, but I've logged the issue with the two Insert key shortcuts. Since the betas introduced overwrite mode, toggled with the Insert key, this probably inadvertently broke the shortcut.
Jennifer Hughes
(MM for short)

Li
Lilith
Posts: 351
Joined: Sat Nov 13, 2010 3:50 pm
Platform: Windows
Location: Belgium

Sat Feb 15, 2014 11:53 am Post

Right. I have noticed that, when using them (by habit), I begin to overtype.

User avatar
Marta
Posts: 537
Joined: Sat Feb 05, 2011 2:23 am
Platform: Windows
Location: Los Angeles
Contact:

Tue Feb 18, 2014 8:20 am Post

MimeticMouton wrote:The Shift+Delete shortcut does still work to cut the text, but I've logged the issue with the two Insert key shortcuts. Since the betas introduced overwrite mode, toggled with the Insert key, this probably inadvertently broke the shortcut.


Ah it's a new feature! I thought I'd inadvertently hit a wrong key, and had to keep hitting the INSERT key to get back to insert mode

How can I disable overwrite mode? I so totally hate it
Marta
Scrivener 1.9.7.0
http://www.spookyfilms.com

Li
Lilith
Posts: 351
Joined: Sat Nov 13, 2010 3:50 pm
Platform: Windows
Location: Belgium

Tue Feb 18, 2014 9:21 am Post

You disable overtype by simply pressing the "insert" key on the keyboard. That is also how you activate it.
(I hate it too :) )

User avatar
Marta
Posts: 537
Joined: Sat Feb 05, 2011 2:23 am
Platform: Windows
Location: Los Angeles
Contact:

Tue Feb 18, 2014 10:16 am Post

Lilith wrote:You disable overtype by simply pressing the "insert" key on the keyboard. That is also how you activate it.
(I hate it too :) )


Hi Lilith,
Yes, I know. I've had to press the INSERT key way too many times in the last few days

It's annoying--- seriously annoying -- to realize you've written an entire sentence, or even more in OVERTYPE (many times I'm looking at a photo of a character or location when I write, not at the page)
GRRR. :evil:
Marta
Scrivener 1.9.7.0
http://www.spookyfilms.com

User avatar
Mad Girl Disease
Posts: 367
Joined: Sat Jan 11, 2014 11:33 pm
Platform: Windows

Wed Feb 19, 2014 12:52 pm Post

Marta wrote:It's annoying--- seriously annoying -- to realize you've written an entire sentence, or even more in OVERTYPE (many times I'm looking at a photo of a character or location when I write, not at the page)
GRRR. :evil:


Yeah, I'm not a fan of the Insert key either... though it's not as bad as the caps lock key... which I've deactivated.
Lead me not into user error.