13th APRIL - LEE'S UPDATE - BETA 023 RELEASED

User avatar
LAP
Posts: 1007
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Wed Apr 13, 2011 7:42 am Post

Hi All,

It is evident that our performance improvement code introduced several nasty bugs in beta 022. Firstly, our sincere apologies caused by this previous beta release.

What made most of these bugs particularly difficult to fix was that we were unable to reproduce all of them. However, given the large amount of feedback clearly there were issues.

The following bugs have been addressed:

1. Scrivener saving issue. Hopefully, this has been addressed. Unfortunately, we were not able to reproduce this most sinister issue so we'll have to wait for confirmation that our changes have in fact worked.

2. Scrivener Crash when editing folders text. Fixed.

3. Pulled 7Zip code fix attempts out. Reverted to standard Windows zip archiving once again. Please note to open Scrivener zipped backups please use the built in Windows zip tool not 7Zip. Which is not supported.

4. Additional View/Group mode changes to align functionality identically to Mac platform. Fixed.

5. Project search and replace saved after project close. Fixed.

6. Templates now work as expected and no longer open to blank template. Fixed.

7. Document inspector sticking to previous document when using splits and closing out of project and returning. Fixed.

8. Paste and Match Style within fullscreen with short cut keys. Fixed.

9. Horizontal split screen mashing up of text for scrivenings and long documents. Fixed.

10. Minor installer fixes with wording. Addressed.

Beta Release 023 is now available for download (Windows and Linux).
http://www.scrivenerforwindows.com
(Please remember to refresh your browser as it may have cached contents from the previous release)

IMPORTANT NOTE: a full install is required and any personal settings that you've made within Scrivener will be lost so you'll need to customise them again. This was unfortunately due to the need to rename a registry keys to align with the Mac platform. There should be no further changes so you're settings should be safe moving forward. I'm sorry about that too.

Moving forward, we are still aware of the following issues: various compile fixes, word count not showing issues, total word count issues, binder icon refresh issues, rtf lang issues when importing non utf-8 Chinese text. We are also aware that the CTRL+ALT short cut key combination are going to need changing due to international languages and Windows legacy code using the right ALT key combination for creating accented characters. As usual we will do our best to address these outstanding issues as soon as possible.

Thank you for you continued support with the beta and once again apologies for any inconvenience beta 022 may have caused.

Regards

Lee

sc
scribbles
Posts: 61
Joined: Tue Oct 26, 2010 2:44 am
Platform: Windows

Wed Apr 13, 2011 8:25 am Post

Woohoo! Thanks, Lee. Here's crossing fingers (and toes) that particularly nasty saving bug has been squashed. Off to download and play/test! :lol:

El
Elminster
Posts: 38
Joined: Sun Apr 10, 2011 2:02 pm
Platform: Win + iOS
Location: Germany

Wed Apr 13, 2011 8:37 am Post

Thanks! Looking forward to trying it out.

Wo
Wonder
Posts: 28
Joined: Fri Oct 15, 2010 12:40 pm
Platform: Windows

Wed Apr 13, 2011 9:12 am Post

Thanks Lee! So far no more saving issues for me. But I've only been playing around with it a little bit, so I don't know for sure.

Interesting GUI changes. I'm not quite used to the grey at the moment, but anyway, it's nothing.

One thing I noticed while fiddling around with the customisation options -- in the snapshots, the text is only at 100% zoom, even though I usually use 135% zoom. This is a bit of a problem as I usually have a small font with the 135% zoom setting, and with the 100% zoom in the snapshots, the text is illegible and I can't compare the two versions. Could you please add a zoom setting for the snapshots, too? Thanks!

Sm
Smee
Posts: 4
Joined: Wed Apr 13, 2011 8:43 am
Platform: Windows

Wed Apr 13, 2011 9:40 am Post

So glad of this update, thanks.

Put back in text that went poof. Everything seems to be ok.

Decided to export everything as a back up but the notes are not saving. I have tried twice, checking the notes box and unless I am doing something very daft (which could be possible) the notes are definatley not saving. Meta Data and main filess are saving ok however.

Ay
Ayane
Posts: 5
Joined: Wed Apr 13, 2011 2:08 am
Platform: Windows
Location: Germany

Wed Apr 13, 2011 11:36 am Post

Thanks for your continuous efforts and great work on the Windows version of Scrivener! I just came across the Inspector bug on beta 2.2 and hope the new beta will resolve the problem.

Pe
PeterWH
Posts: 5
Joined: Mon Apr 11, 2011 7:23 pm
Platform: Windows

Wed Apr 13, 2011 12:31 pm Post

Thanks Lee
I'm back in business!

Could you promote the new update more widely - just spent all morning backing up and preparing to reinstall Windows thinking it was my machine that was knackered. I've been on the Windows Troubleshooting forum first thing, but the news of the update is not there - just in Bug Hunt.

thanks

Peter

al
alba
Posts: 21
Joined: Sun Feb 17, 2008 7:13 am
Location: Japan
Contact:

Wed Apr 13, 2011 12:40 pm Post

Thanks for doing this.

Just wondering where the instructions for installation are. The stuff on the wiki seems to be for a different type of file. Can anybody point me to the right link?

User avatar
garpu
Posts: 2041
Joined: Mon Oct 25, 2010 9:38 pm
Platform: Linux

Wed Apr 13, 2011 1:39 pm Post

Looks nice! Some UI tweaks? Looks more like my fiance's copy now. ;)

Compile bugs (pdf, odt) still there, but it's something one can work around. Do you need screencasts of those still?
Slackware-current 64-bit, XFCE

Jo
JoGirl
Posts: 25
Joined: Mon Oct 11, 2010 5:38 pm

Wed Apr 13, 2011 6:28 pm Post

alba wrote:Thanks for doing this.

Just wondering where the instructions for installation are. The stuff on the wiki seems to be for a different type of file. Can anybody point me to the right link?


Installation for me was straightforward as with any Windows installers. You might check the reference documentation here in the pdf file:

viewtopic.php?f=32&t=12531 Which is a draft of the User Manual for Scrivener for Windows. I wish I could be more helpful to you. :)

Sp
Spartachris
Posts: 38
Joined: Fri Oct 29, 2010 3:00 am
Platform: Windows

Wed Apr 13, 2011 6:45 pm Post

Hi. Thanks for the quick update. But it re-introduced another bug. :(

I posted before about compiling for docx and receiving the error that it "may require MS Word to be installed." This was version 021. Then in version 022 it went away and I could compile for docx no problem. I downloaded 023 and it is giving me the same error again. So something was fixed and now is not again.

FWIW, I do have Windows 7, Word 2010 installed, all bought and paid for, legal eagle, scout's honor.

Please let me know what I can do to help you find this little bugger.

Thanks!

User avatar
narrsd
Posts: 710
Joined: Wed Sep 22, 2010 8:34 pm
Platform: Win + iOS

Wed Apr 13, 2011 10:03 pm Post

Lee, good stuff, which is looking very well.

I actually encountered the release at 4:30 this morning when I woke up for a while, and just wanted to check again that the split-stuck synopsis bug was really fixed: looks like it is.

The binder scriv highlight still isn't keeping up when you close the editor split, but things do work otherwise both before and after a close-reopen. I'm keeping a little list of misses like this, and will send a set up soon.

Confirm with garpu that compile-to-pdf isn't there again yet, and that it is a low priority until getting ready for actual release. Probably something very simple, since it tries to work, and worked before.

7-zip. It's a tight compression framework, but a nasty little program, perhaps just in its GUI add-on, as I think it started out in command-land. I suspect that by comparing what it prefers from Winzip with the QT output, you can figure out the actuality of the flags, but there are many more important fish to fry at this time, much agreed.

Saves themselves are looking solid: I tried to rush them by creating a text and immediately hitting the close button, no 2-second wait I intended. The writing was there when I opened Scrivener again, which I imagine is your intent.

Great job on the recovery, Lee, and the other team (ExpressionEngine) also got a fix in this interval, so software works again in this world. Kind of amazing, isn't it ;).

Best,
Clive

User avatar
LAP
Posts: 1007
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Wed Apr 13, 2011 10:23 pm Post

Thanks guys and girls.

I have noted the following issues raised:

1. ...Compile bugs (pdf, odt) still there, but it's something one can work around. Do you need screencasts of those still?


YES PLEASE. I can't duplicate the ODT, PDF or DOCX compile generation issues reported. I produced all the files immediately after reading the post. I did however notice that I had to press F5 to refresh my desktop and see the files which wasn't usual, but it's probably my machine needing a re-boot?

2. ...fiddling around with the customisation options -- in the snapshots, the text is only at 100% zoom, even though I usually use 135% zoom. This is a bit of a problem as I usually have a small font with the 135% zoom setting, and with the 100% zoom in the snapshots, the text is illegible and I can't compare the two versions...

3. ...export everything as a back up but the notes are not saving...

4. ...Could you promote the new update more widely...DONE.

5. I posted before about compiling for docx and receiving the error that it "may require MS Word to be installed." This was version 021. Then in version 022 it went away and I could compile for docx no problem. I downloaded 023 and it is giving me the same error again. So something was fixed and now is not again.

I was not able to reproduce point 5. See notes on point 1.

Lee

User avatar
MimeticMouton
Posts: 8766
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu Apr 14, 2011 12:21 am Post

Lee wrote:YES PLEASE. I can't duplicate the ODT, PDF or DOCX compile generation issues reported.


Here's a link to the post with the screencast on this I posted yesterday, in case you didn't see; might be helpful. Doesn't show the "requires MS Word" issue, but I'll toss that up when I can get it if someone else doesn't first.
Jennifer Hughes
(MM for short)

Sp
Spartachris
Posts: 38
Joined: Fri Oct 29, 2010 3:00 am
Platform: Windows

Thu Apr 14, 2011 12:39 am Post

Ok Weird. I have 023 on my home computer--also Win7, also Word 2010, and it does fine. Something hincky with the installation on the laptop. I'll re-install Scriv and see what happens.

And I still love Sciv so much it's probably sinful.