Does doing this make your Scrivener lag?[ADDRESSED]

Mi
Mirrorscape
Posts: 17
Joined: Wed Oct 27, 2010 4:35 pm
Platform: Windows

Thu Oct 28, 2010 5:11 pm Post

As promised I have been using Scrivener for my writing today. I used a new project from the short story template and did not change anything other than the title of the project. I used the netbook as during my tests the lag was worse on that machine as well as surfacing earlier.

Using scrivener for two hours of normal (for me) use I noticed no real lag. Only time I experienced anything like lag was when I paused and then started typing again before the autosave feature was done saving my work. I used the F11 distraction free mode and only created a new document once to start a new scene.

I intentionally did not mess around with labels or status changes and did not needlessly change documents.

Go
GoddessofBirth
Posts: 2
Joined: Fri Oct 29, 2010 1:40 am
Platform: Windows

Fri Oct 29, 2010 4:28 am Post

I am using a regular laptop, and once I started adding files and renaming things my text started lagging big time. Sometimes as much as ten seconds. My stats are:

Toshiba Satellite A-105
1GB Ram
1.6 MHz Intel Celeron Processor
Microsoft XP SP3

La
Lanie
Posts: 26
Joined: Tue Oct 26, 2010 7:49 pm
Platform: Windows

Fri Oct 29, 2010 11:35 pm Post

I posted on the second page about lag, but I started a new project and am getting the same thing. Just wanted to add about it, since it's under different circumstances.

Under my draft folder, I have one page (Title Page), a WIP folder with 5 folders and each folder has 7 pages. (There is absolutely no text on anything except Title Page--which has 18 words.

Under Research, I have: 3 folders, a blank page and a copy of the shortcuts for reference. 2 folders have 3 pages with probably under 30 words each. The third folder has 12 pages with a one or two line Synopsis--no text on the actual pages. There's also a few sentences under Document Notes (probably less than 500 words total, including all 12 cards). Last night, I got a ridiculous amount of lag when I was I typing a few sentences under the Document Notes. Like, 10 second lag to type 3 words.

Something I did notice, though--if I'm typing on the card itself (not on the page or Doc Notes), there doesn't seem to be nearly as much lag. I was typing there, then cutting/pasting into the Notes.


I'm only mentioning this because I assumed originally that the lag was caused by having so much text, but that doesn't seem to be the case. On my end, it seems that the amount of folders/pages is what is causing the lag. Also, the lag seems to be better after reopening Scrivener.

Ps
Psychomacologist2.0
Posts: 26
Joined: Tue Oct 26, 2010 4:28 pm
Platform: Windows

Sat Oct 30, 2010 12:01 am Post

Lanie wrote:I'm only mentioning this because I assumed originally that the lag was caused by having so much text, but that doesn't seem to be the case. On my end, it seems that the amount of folders/pages is what is causing the lag. Also, the lag seems to be better after reopening Scrivener.

I have exactly the same problem when working with a lot of folders/subfolders etc. It causes a lot of lag when trying to type into the documents, but restarting Scrivener seems to fix it and then it works fine, until I move stuff around... it's definitely a source of lag.
~I aim to misbehave~
"People should not be afraid of their Governments. Governments should be afraid of their people."

no
nohika
Posts: 33
Joined: Mon Oct 25, 2010 9:09 pm
Platform: Windows

Sat Oct 30, 2010 12:20 am Post

I have about 72 files in a folder (yaaaay phases!) and I tried to type into the document notes of one of them (the synopseshad been working fine - no lag or anything) and Scrivener almost froze. It lagged for a good 20 seconds.

So...I don't know if that's helpful or not, but still! :) I'm running Windows Vista 64-bit w/4GB RAM.

Go
GoddessofBirth
Posts: 2
Joined: Fri Oct 29, 2010 1:40 am
Platform: Windows

Sat Oct 30, 2010 3:33 am Post

I have exactly the same problem when working with a lot of folders/subfolders etc. It causes a lot of lag when trying to type into the documents, but restarting Scrivener seems to fix it and then it works fine, until I move stuff around... it's definitely a source of lag.


Exactly this. You explained it a lot better than I did up-post :lol:

La
Laxaria
Posts: 125
Joined: Tue Oct 26, 2010 3:10 am
Platform: Mac + iOS

Sat Oct 30, 2010 3:36 am Post

It might be how Scrivener handles the meta-data and links of each file within the program. This does narrow down the issues though.

La
LaughSing
Posts: 19
Joined: Tue Oct 26, 2010 3:06 am
Platform: Windows

Sun Oct 31, 2010 9:34 am Post

Laxaria wrote:On a more curious note, does anyone experience this slowdown in normal usage over a longer period of time, like making 10-20 document files over the course of an hour? If this causes lag, then there could be a more concerning problem, since so far, our tests have involved speed and stress and not expected, typical behaviour in normal usage.


I copied a 50k word file in, and created 24 more files to split the document into scenes for revising, and the slow response occurred while the original file contained more than 30k words. As soon as I'd stripped out 20k or so words, it speeded up.

Maybe not exactly what you were looking for, but close, perhaps.
Samsung N130 netbook, Windows 7 starter,Intel(R) Atom CPU N270 1.60 GHz, 1GB RAM, 32 bit

sc
scribbles
Posts: 61
Joined: Tue Oct 26, 2010 2:44 am
Platform: Windows

Mon Nov 01, 2010 8:03 am Post

My settings:
Acer Aspire Laptop
Windows 7
4GB RAM
Intel Core Duo processor T7300

I've installed the exe updates from Oct 29 and I've disabled the check spelling. That said, I've been using Scrivener to prepare all my research, so I've got about 80++ ( :shock: ) files and folders all set up. There was a little bit of lag while compiling all this information, but nothing that hindered me. Admittedly, I was mostly importing files, filling up character/location sheets and making short notes.

That said, today, while I kicked off for NaNo, I found it lagged a lot while trying to type continuous streams of prose. I've tried shutting down the the program and/or rebooting my machine, but while the lag goes away initially, it comes back pretty quickly. (Or perhaps I'm just typing too fast?)

Unfortunately, I've had to migrate to Word to do most of my typing, and then copy and paste into Scrivener to keep it all together.

I'll try to do a more structured procedural test later,... after I've met my NaNo quotas. :wink:

User avatar
LAP
Posts: 1022
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Mon Nov 01, 2010 11:35 am Post

Thanks everyone for the excellent feedback here. We will look into resolving this obvious issue.

Lee

La
Laxaria
Posts: 125
Joined: Tue Oct 26, 2010 3:10 am
Platform: Mac + iOS

Thu Nov 04, 2010 2:01 pm Post

Lee has just posted an update on the issue. Hopefully, we can try to break (:P) Scrivener this way again when we get our hands on beta 1.3

User avatar
Freelancer
Posts: 19
Joined: Wed Nov 03, 2010 12:56 am
Platform: Windows
Location: Alaska
Contact:

Sat Nov 06, 2010 12:59 am Post

Just to add some computer information to this bug hunt, since i have also been experiencing a lag after adding and moving about sufficient files to start writing. The lag seems to have vanished after I closed and reopened Scrivener, so I can't say exactly what it was that caused it, because I am not able to replicate it for some reason. The initial lag happened last night and just a few minutes ago as I was setting up things to begin writing. Vanished when I restarted Scrivener to attempt to reproduce for reporting.

(Side Note: Scrivener had froze and locked up as I typed (70 wpm) and when I restarted it had the text, even if I had not been able to see it before closing and restarting.)

System info:

64 bit HP a4313w running Windows 7 Home Premium
AMD Sempron Processor LE-1250 2.20 GHz
2.75 usable RAM
Running Dual monitors via an Arkview 2.0 USB adapter, with Scrivener on primary monitor


Using Scrivener 1.2
Added 3 folders and 16 files in varying arrangements of category and sub-category.
Also added 3 new labels with color tweaks for push pins.

Most of the file moving had been done within the Outliner view from the main "CHAPTER" Folder to move around sub folders and documents in there.
Using:
Scrivener Beta: Version: 1.7.0.5 beta - 24 Apr 2014

System:
Windows 7 Home Premium on an HP Pavilion desktop
AMD Sempron Processor LE-1250 2.20Ghz
64 bit OS with 2.75 GB usable RAM
Dual monitors via an Arkview USB 2.0 Display Adapter