Ellipses preference odd behavior (2.0b)

Mi
MightyLost
Posts: 4
Joined: Wed Oct 27, 2010 3:59 pm
Platform: Mac

Thu Oct 28, 2010 4:14 pm Post

Encountered some odd behavior with the ellipses conversion preferences. Scrivener doesn't seem to be respecting the "Disable smart quote, em-dash and ellipsis substitution in script mode" setting. Additionally it seems to do the opposite. Three dots get subbed for an Ellipses in script mode but not default text mode.

Steps:
1. Create a new project with the screenplay template
2. In preferences select "Replace triple periods with ellipses" AND "Disable smart quote, em-dash and ellipsis substitution in script mode"
3. Start typing in scene one with script mode enabled and type three periods (...) and watch them get converted to an ellipsis despite the setting.
4. Create another new scene, turn OFF script mode and type three periods and watch them NOT get converted.

[Edit - I was wrong about it also doing the opposite, see my next post for clarification]
Last edited by MightyLost on Fri Oct 29, 2010 2:40 pm, edited 1 time in total.

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Oct 28, 2010 5:02 pm Post

I can't reproduce this. Are you sure you're definitely in script mode, with the footer bar showing the script elements?
Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Sean Coffee
Posts: 509
Joined: Wed Jan 24, 2007 7:10 pm

Thu Oct 28, 2010 5:40 pm Post

I can't reproduce this either. Works as it should in script mode for me.

User avatar
Script-O-Matic
Posts: 29
Joined: Sun Jul 25, 2010 7:04 pm
Location: San Francisco

Thu Oct 28, 2010 7:10 pm Post

[EDIT] You can skip this post, unless you're just the curious type, as the source to the problem is revealed below -- that being the OS X System Text Preferences. [END EDIT]

I'm having similar problems with ellipses in Script Mode. After posting about it in another topic I was pointed here to contribute what I could.

I originally installed 2.0 alongside my existing installation of 1.54. Later I completely removed all traces of the 1.54 and 2.0 installations (including preference files), and did a clean install of 2.0.

I un-selected the first four Substitutions in Auto-Correction Preferences, and tested them individually. When I turn smart quotes on, I get smart quotes while typing, when turned off, no smart quotes. When I turn em-dashes on, I get an em-dash while typing, when turned off, no em-dash. However, when I turn ellipses on and off, the result is always ellipses. This time I looked more closely and observed that when "Replace triple periods with ellipses" is turned on, the ellipses appear instantly when I've typed the third period. When "Replace triple periods with ellipses" is turned off, the triple periods are still there after typing the third period -- but as soon as I hit the space bar, there is a brief pause and then they convert to ellipses.

I then re-selected the first four Substitutions so that smart quotes, em-dashes, and ellipses would be used as substitutions -- but would be disabled in Script Mode. This was the default setup from the 2.0 installation. With these all selected -- no smart quotes or em-dashes are created -- but triple periods convert into an ellipses (after I hit the space bar, followed by a brief pause).

Now let me put this another way. If I un-select the first four Substitutions in Auto-Correction Preferences, there should now be no smart quotes, em-dashes, or ellipses created. I select Script Mode. When I type double quotes there are no smart quotes created. When I type a double hyphen there is no em-dash created, but when I type triple periods, ellipses are created (after hitting the space bar, followed by a brief pause). And if I turn Script Mode off, I get the same results.

I don't know if this is a clue or not, but there are no Scriptwriting Project Templates installed. When I first installed 2.0 on top of the existing 1.54, and opened a copy of my 1.54 project, I remember there was a step where I accepted the default choice to convert? an existing (1.54) scriptwriting template, and it then appeared inside the Miscellaneous category of Project Templates. But since performing the clean install of 2.0, I have no Scriptwriting Project Templates. There is one Blank template, and three Fiction templates. Nothing in any of the other categories. I remember reading somewhere that the other templates were still forthcoming with the official release of 2.0.

So something is still amiss here in San Francisco. I wonder if anybody else can confirm this behavior on their installation, or whether it is unique to mine for some strange reason?
Last edited by Script-O-Matic on Fri Oct 29, 2010 6:26 pm, edited 23 times in total.

In
Insignia
Posts: 70
Joined: Mon Dec 17, 2007 7:14 pm
Platform: Mac
Contact:

Thu Oct 28, 2010 7:26 pm Post

I tried this, and indeed three dots got turned into an ellipsis even when turned off. Further investigation revealed that said substitution was checked in System Preferences too. Turning it off there made it respect Scrivener's settings :-)

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Thu Oct 28, 2010 8:46 pm Post

Sorry, I haven't got time to read all of this at the moment. If anyone can post a short set of instructions to reproduce, that would be great.
Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
Sean Coffee
Posts: 509
Joined: Wed Jan 24, 2007 7:10 pm

Thu Oct 28, 2010 9:06 pm Post

I can confirm that if the ellipsis preference is ticked in Apple System Preferences, Scrivener will condense the ellipsis regardless of what Scrivener Preferences says.

Also, is anyone using TextExpander? Because that may be overriding the double dash thing.

In
Insignia
Posts: 70
Joined: Mon Dec 17, 2007 7:14 pm
Platform: Mac
Contact:

Thu Oct 28, 2010 9:16 pm Post

Keith,
I don't know about the others, but in my case it only happened because I had a dots-to-ellipsis substitution in the system text preferences. So if Scrivener didn't change it, OSX did.

User avatar
Script-O-Matic
Posts: 29
Joined: Sun Jul 25, 2010 7:04 pm
Location: San Francisco

Thu Oct 28, 2010 9:46 pm Post

OK well now I'm shuffling my feet a bit. I've been completely unaware that there was a 2nd variable in all of this -- an ellipsis preference in Apple System Preferences? Sheesh! I'll go locate this and report back.
Last edited by Script-O-Matic on Sat Oct 30, 2010 7:20 pm, edited 1 time in total.

User avatar
Script-O-Matic
Posts: 29
Joined: Sun Jul 25, 2010 7:04 pm
Location: San Francisco

Thu Oct 28, 2010 10:02 pm Post

Oh Crikey! I never knew about this OS X text preference until now. Once I turned it off -- presto chango -- now the triple periods are behaving according to Scrivener preferences. So this was overriding Scrivener's settings.

Is this detailed in the Scrivener Manual for screenplay writing? I couldn't find any screenplay specific documentation, but I was scanning fairly quickly so may have missed it. I'm certain there's gonna be folks like me out there who will trip over this too.

User avatar
Sean Coffee
Posts: 509
Joined: Wed Jan 24, 2007 7:10 pm

Thu Oct 28, 2010 10:29 pm Post

I wonder if this isn't actually a bug. I don't remember having to do this before. Shouldn't an application's specific preferences override any global system prefs?

Mi
MightyLost
Posts: 4
Joined: Wed Oct 27, 2010 3:59 pm
Platform: Mac

Fri Oct 29, 2010 2:34 pm Post

I know what's happening now, Scrivener 2.0 respects the global replacement setting but 1.54 did not.

I totally forgot that Snow Leopard's default setting is to replace three periods with an ellipses (the setting is under System Preferences > "Language and Text" > "Text" tab). This is indeed why the Scrivener 2.0 preference was not working. The system was replacing three periods, not Scrivener. If you follow my original steps with the global System Preference set to replace three periods, the behavior I indicated should still happen (except skip step 4, I was wrong about that part)

The odd part is that I just fired up Scrivener 1.54 and its preference for converting three periods into ellipses seems to override the system setting. Meaning that if I have it set in System Preferences to replace three periods but set in Scrivener 1.54 to NOT replace periods, it does NOT replace periods.

Hence thinking it was a bug in 2.0b, since I was used to the behavior in 1.54. Does this make sense?

Perhaps Scrivener 2.0 should override the global setting? Or at least warn users that the global setting may interfere?

Please let me know if I can provide any more information.

rv
rvdparis
Posts: 64
Joined: Fri Mar 09, 2007 12:47 am
Location: France

Mon Nov 01, 2010 2:04 pm Post

Hi I am having the same problem SUDDENLY with em-dashes.

I have both 1.54 and 2.0 installed...Usually when I type double hyphens I get an em-dash immediately. Not anymore.

Suddenly, double hyphens do not become em-dashes when I write. Only when I hit the space bar do they become em-dashes, there is a delay...which would be ok, except that when I decide to turn a comma into an em-dash by typing double hyphens, it won't work. I have to hit that space bar every time.

It still works in 1.54, I checked. I type the two hyphens and MAGICALLY an em-dash appears immediately. So I can rule out System Preferences/Text settings.

I have checked my preferences in 2.0 (I do not use script mode, well, maybe I do, I am not a script writer, how do I know? The manual is moot on how to change to script mode) and they match 1.54. Is there something I'm missing?

My ellipses work, however. Any advice on how to get my em-dash groove back?

User avatar
KB
Site Admin
Posts: 20920
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Nov 02, 2010 12:20 pm Post

rvdparis - That's a separate issue and just a difference between how 1.x and 2.0 works, I'm afraid. Scrivener 2.0 now uses the same system as all other OS X text system programs for replacing em-dashes and suchlike, so it works the same as in TextEdit and Pages etc. I agree that the double-hyphen replacement was nicer in 2.0, but it caused other problems for other languages.

Regarding ellipses... Ah, now I see the problem. This is a tricky one. Whereas smart hyphens and smart quotes can be toggled on or off in the text at will, the ellipses are part of the general "auto-correction" table in the System Prefs, so if you have the sys prefs ticked to replace three periods with ellipses, then that will indeed override Scrivener's preferences, because Scrivener has no way of knowing the difference between the ellipses replacement and other replacements in that table. And unfortunately, Apple provides no way of intercepting replacements from that table to make decisions about whether to use them on a case-by-case basis. So, the only options I have are:

1) Make this clear in a message in the Preferences panel ("note that System Preferences may override Scrivener's settings for ellipses" or suchlike).

2) Block ellipses from replacing three periods altogether. This will make it act as expected, but it will also mean that if you ever deliberately select three periods and paste an ellipses over them in scriptwriting mode, nothing will happen - the change will be refused. My guess is that this will be a rare thing to do in scriptwriting mode, though, so this may be the best solution.

Thanks,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
MimeticMouton
Posts: 9007
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Tue Nov 02, 2010 11:07 pm Post

Re: double hyphens becoming em-dashes...I'm not getting this issue at all. It takes a moment for the double hyphen to switch, but it doesn't require me hitting space bar--I can go back and insert the two hyphens anywhere and then jump the mouse away and after a second the hyphens will switch to an em-dash. So...maybe my system is magical? :shock: I have the appropriate box checked in Preferences, but otherwise I don't see anything obvious that would be making it different in the OS System Preferences. Hmm.

Running 10.6.4.
Jennifer Hughes
(MM for short)