Compile not working in 3.2 [Workaround: pg. 2]

jb
jbottinger1
Posts: 8
Joined: Thu Nov 19, 2020 4:01 am
Platform: Mac

Thu Nov 19, 2020 12:40 pm Post

I'm having the same problem, build 14343. Updated via autoupdate on Big Sur; project opens fine, Compile does absolutely nothing. Uninstalled and re-downloaded 14343 to make sure everything was copacetic (downloaded 14343 as per another post in the forums) and re-ran; same behavior.

User avatar
AmberV
Posts: 24551
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 19, 2020 12:53 pm Post

Please note that I have merged around half a dozen different threads regarding this same issue into one place, so the conversation may be a bit out of order, above. It will be easier to track bugs if the conversations aren’t all spread out though.

We are aware of an issue in the compiler: if you are editing a Format and access the font menu, you should see a crash. This will be fixed shortly.

The other one, crashing when compiling—we’ve seen reports but have yet to get a reproduction on it. If anyone can provide sample data in the form of a project that consistently crashes by just opening it, entering Compile, and clicking the compile button, that may help!
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

jb
jbottinger1
Posts: 8
Joined: Thu Nov 19, 2020 4:01 am
Platform: Mac

Thu Nov 19, 2020 12:56 pm Post

For the record, I'm on Big Sur11.0.1 and Scrivener 14343, and my project isn't *crashing*, Compile just does *absolutely nothing*, like I didn't hit the menu option at all.

I created a NEW project as a test - as the project I was trying to compile was created by older versions of Scrivener. It did the same thing: Create project, enter text in the scene so there's something TO compile, File|Compile... nothing, no response, no dialog box, no crash, the menu item might as well not even be there.

bo
bodsham
Posts: 198
Joined: Wed Jun 13, 2007 2:58 pm
Location: UK
Contact:

Thu Nov 19, 2020 12:57 pm Post

Same here. No crash. Just nothing happening if you try to Compile.

User avatar
AmberV
Posts: 24551
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 19, 2020 12:59 pm Post

Okay that’s good to know. If the button/command does nothing, that likely means an internal error happened. These are not reported by default since they can occur for reasons that aren’t really Scrivener’s fault. But if you’re experiencing problems, you can turn them on with the Show internal error alerts setting, the General: Warnings preference pane.

It’s also a good idea to run Console to the side (found in Applications/Utilities), and set the search bar in that to “scrivener”. If any debugging messages appear, that’s where they will go.

I’ll let someone on 11.0.1 know to test your checklist, I’m on 10.14.6 at the moment.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

jb
jbottinger1
Posts: 8
Joined: Thu Nov 19, 2020 4:01 am
Platform: Mac

Thu Nov 19, 2020 1:05 pm Post

Ah ha! Done, bug report sent.If you'd like a sample project for which this occurs - well, like I said, I created a project in 3.2 and just typed "text here" in the first scene, but I can send the project as well if that would help.

The actual error is:

Exception Reason: Invalid parameter not satisfying: index < [_itemArray count]

... which ... following the trace, looks like a font issue somewhere (I sent the full stack trace in the bug report, it looks like it's trying to do an index of font and crashes somewhere NEAR there) but I didn't select any fonts when creating the test project (and don't have any special fonts in the project I'm working on either, as it's a draft.)
Last edited by jbottinger1 on Thu Nov 19, 2020 1:10 pm, edited 1 time in total.

User avatar
AmberV
Posts: 24551
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 19, 2020 1:06 pm Post

jbottinger1 wrote:Ah ha! Done, bug report sent.


Thanks!

Oh, and other routine troubleshooting thing to do: reset your preferences.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

jb
jbottinger1
Posts: 8
Joined: Thu Nov 19, 2020 4:01 am
Platform: Mac

Thu Nov 19, 2020 1:18 pm Post

I just tried the reset preferences dance - removed the plist file, restarted the Mac, restarted Scrivener, opened project, set show internal errors on in Preferences; selected File|Compile. Same error.

User avatar
AmberV
Posts: 24551
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 19, 2020 1:18 pm Post

Ah, I found something that looks promising, it may have to do with having set a global font override in the past (if you created your test project from a template, it may have had that set as well). You could try this:

  1. In Finder, right-click on the test project that you created, and select “Show Package Contents”.
  2. Drill down into the Settings folder, and delete the ‘compile.xml’ file.
  3. Now restart Scrivener, load the project, and try compiling.

That unfortunately wipes out all compile settings, as you would imagine. So if that is not something you could afford to do in a live project, there is a more surgical approach that would involve editing the XML file to remove the font setting.

If you’re comfortable doing so, open the .xml file in a plain-text editor (TextEdit will work if that’s all you have), and search for “<Font>”. You’re looking for instances that directly follow a “<Format ID=”Something“>” line. Delete the whole line containing the Font declaration, for each format that has one.

Obviously, I’d strongly recommend setting aside a backup copy of your project before doing this.

Or... if you can, just wait until the fix is out. We'll have this fixed soon since it is obviously going to impact fair number of users.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

jb
jbottinger1
Posts: 8
Joined: Thu Nov 19, 2020 4:01 am
Platform: Mac

Thu Nov 19, 2020 1:24 pm Post

*BANG!* That fixed it. Removed compile.xml, hit File|Compile, selected my options again (no big deal AT ALL there, obv) and... woohoo! Export into .docx successful.

Thank you!

User avatar
AmberV
Posts: 24551
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 19, 2020 1:28 pm Post

Excellent! Thanks for the confirmation.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

bo
bodsham
Posts: 198
Joined: Wed Jun 13, 2007 2:58 pm
Location: UK
Contact:

Thu Nov 19, 2020 2:16 pm Post

Do I assume this rather complex solution fixes the crashing problem not the fact Compile does nothing for some of us? I just tried creating a blank file from scratch from the standard Scriv fiction template. It does nothing when I hit Compile.

User avatar
AmberV
Posts: 24551
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 19, 2020 2:18 pm Post

This fixes the problem you describe, but as noted, some of the templates may have this compile setting that causes issues. It's usually safest to do a clean slate test with Blank, which is a project in its purest form, with very little assumption made to its configuration.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

bo
bodsham
Posts: 198
Joined: Wed Jun 13, 2007 2:58 pm
Location: UK
Contact:

Thu Nov 19, 2020 2:44 pm Post

Yes deleted compile.xml kind of worked though what effect it has on a live file of 60k words I've no idea. I did notice that if I compiled to print it worked fine but then when I went back and tried to compile for docx (I chose print by accident not because I needed it) everything was back to scratch, Compile doing nothing and I had to delete the compile.xml file yet again.

on
onnie
Posts: 4
Joined: Thu Nov 19, 2020 11:26 am
Platform: Mac

Thu Nov 19, 2020 2:45 pm Post

Deleting Compile.xml works for me.
Thanks