Bug: "Import and Split" does not correctly apply formatting settings

Te
TeaDrivenDev
Posts: 19
Joined: Thu May 28, 2020 3:01 am
Platform: Windows

Thu May 28, 2020 3:31 am Post

When using "Import and Split" to import a Markdown file, the formatting settings specified in the Options dialog are not correctly applied to the created documents.

- Text alignment, line height, font color and highlighting are not applied at all.
- Text decorations are applied visually, but when moving around in the editor, the respective toolbar buttons are not shown in "active" state. After closing and reopening the project, those text decorations are not actually applied in the respective documents.

- Font type and size are applied correctly.
- Text formatting is correctly applied when creating a new document from within Scrivener.

Scrivener version: 2.9.9.6 (937253) 64-bit (I first observed this in 2.9.9.5 a few days ago)
Windows version: Windows 10 1909 Build 18363.836

Te
TeaDrivenDev
Posts: 19
Joined: Thu May 28, 2020 3:01 am
Platform: Windows

Wed Jun 17, 2020 3:45 am Post

This still occurs in 2.9.9.7.

Te
TeaDrivenDev
Posts: 19
Joined: Thu May 28, 2020 3:01 am
Platform: Windows

Tue Jul 14, 2020 3:59 am Post

This still occurs in 2.9.9.8.

Te
TeaDrivenDev
Posts: 19
Joined: Thu May 28, 2020 3:01 am
Platform: Windows

Wed Oct 14, 2020 11:11 pm Post

This still occurs in 2.9.9.11.

Te
TeaDrivenDev
Posts: 19
Joined: Thu May 28, 2020 3:01 am
Platform: Windows

Thu Dec 03, 2020 12:46 am Post

This still occurs in 2.9.9.12.

Te
TeaDrivenDev
Posts: 19
Joined: Thu May 28, 2020 3:01 am
Platform: Windows

Wed Jan 06, 2021 12:22 am Post

This issue persists in 2.9.9.14.

ji
jillian.alberts
Posts: 16
Joined: Thu Apr 07, 2016 9:50 pm
Platform: Linux + Windows

Fri Jan 08, 2021 1:57 am Post

I have also encountered this in my use of the Scrivener 3 beta version. (It also happens with a simple "import" of a ".md" file with no "split".) The contents of the imported file show up in a different font than the rest of my project (i.e. different from the project's default formatting settings).

It's not a HUGE showstopping issue or anything, but it is annoying.

The program would feel more polished if imported ".md" files showed up in the project's default style, as if I had just typed it in myself, rather than using a default formatting other than what I had already specified in the options. (Perhaps it's using the project's original default formatting settings -- even though I've changed them?)

I know the devs have a lot on their plate, but (unless there's a good reason for it or something that I'm missing) hopefully this can be addressed at some point.

A workaround: choose to use "different formatting" in "Project Settings" for imported files, and then set that "different" style to match the current project's default style... but that's not a very "polished" solution.

Jill