Default Text Color in Dark Themes Too Dark for Theme?

Ki
KimAleksander
Posts: 13
Joined: Tue Dec 19, 2017 11:41 am
Platform: Mac + Windows

Thu Nov 21, 2019 7:10 am Post

Hi there,

This is probably a dumb question, but I searched for an answer here, and couldn't find one, so I'm posting it here.

In v.3 beta 29, in a new project, using Novel Format, the default text when creating a new scene under a chapter is white. The same goes for notes, and a few other things.

Templates, however, vary in color. For example, Character Sketch has a black header, with blue sub-titles, and the body text is black. Front Matter => Manuscript Format => Title Page is also dark on dark.

When I open an existing v.3 project created on a Mac in Windows beta 29, all of the existing body text is black (or close to it), and when using a dark theme, the text is too dark to read easily.

So my questions are:

1) Is this expected behaviour and, if so, is it expected that we must manually change all of the dark text manually for better reading in dark themes?

2) Will templates eventually be updated for both dark and light modes?

3) What are some of the suggested ideas for "converting" text colors from existing projects? For example, is it better to create a new template and paste old content (from existing files) into new sections, or is it better to "fix" the colours in place in the existing (old) project? Otherwise asked, is one approach that is better for "resetting" font colors for old projects in new dark themes?

Ki
KimAleksander
Posts: 13
Joined: Tue Dec 19, 2017 11:41 am
Platform: Mac + Windows

Tue Nov 26, 2019 8:24 am Post

Answering myself here: I wound up just manually fixing everything in the existing manuscript.

br
brookter
Posts: 2301
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Tue Nov 26, 2019 8:45 am Post

There was a problem reported earlier in the beta about the conversion between Mac and Windows projects, where the default text colour is interpreted differently by the two platforms (to do with the RTF format) and this causes a problem in dark themes. As far as I remember, the workaround was Documents > Convert > Text to Default Formatting. I thought the actual problem had been fixed, but I don't use Dark Mode, so can't tell.

The workaround is buried in a long, detailed forum post with lots of other details, so I'd read it carefully before trying it.

viewtopic.php?f=57&t=57741&p=295037&hilit=text+colour+rtf#p295037

sh
shinykari
Posts: 3
Joined: Wed Jan 31, 2018 5:15 pm
Platform: Mac + Windows

Mon Dec 02, 2019 4:51 pm Post

This issue still persists, as of the newest beta (downloaded today 12/2). Document text on my Mac (synced via Dropbox) is white; when I open it on my Windows machine, it's black.

I've been manually changing it back to "no color" (i.e. white) but occasionally, if I hit just the right/wrong point in the document, it'll go back to black.

ch
charlie.stross
Posts: 85
Joined: Thu Jan 31, 2008 7:46 pm
Platform: Mac
Location: Edinburgh, UK
Contact:

Mon Dec 02, 2019 5:08 pm Post

brookter wrote:There was a problem reported earlier in the beta about the conversion between Mac and Windows projects, where the default text colour is interpreted differently by the two platforms (to do with the RTF format) and this causes a problem in dark themes. As far as I remember, the workaround was Documents > Convert > Text to Default Formatting.


I just ran into this problem and found this thread (in a search for a fix).

Is it just me, or in the current beta (beta 30) does the UI sometimes swallow the last keystroke? I'm using <alt>D-C-D to get to "Text to Default Formatting" with a bunch of scrivenings selected by title in the binder, and sometimes it works (displays the pop-up box of options, then applies the changes you request), and at other times it fails until I re-select a single scrivening and repeat. I was wondering if I was typing too fast and Qt was losing keystrokes, but ...?

br
brookter
Posts: 2301
Joined: Wed Mar 18, 2009 12:22 pm
Platform: Mac

Mon Dec 02, 2019 5:56 pm Post

I can't say I've noticed that recently -- there used to be a problem with shortcuts not working with some menu items (you had to use the mouse for the final selection and even then that didn't work) but I've not come across it in the recent betas.

I've just tested it in b30 and I can't get it to fail in the way you're noticing, sorry.

EDIT:

Yes, i can reproduce it! It seems to be when you try to select scrivenings which combine folders and child documents. If they're all at one level, it works. If there are parents and children, it doesn't. And it doesn't work using mouse and menu either. Is that what what you find?