(Beta 25) - editing to add any character/word in editor overwrites succeeding characters/words.

cl
clownscape
Posts: 2
Joined: Fri Oct 11, 2019 4:22 am
Platform: Windows

Fri Oct 11, 2019 4:36 am Post

If I try to add a word or character between an already present text, it keeps overwriting the subsequent character present in the sentence sequence, rather than moving the subsequent characters and adding the new characters between the words and characters present (as is the basic function of any word editor). This is a new bug that has cropped up with the Beta 25 update and completely breaks the editing process.

I recommend looking into it on an URGENT basis as it breaks the software completely and makes it unusable.

User avatar
tiho_d
Posts: 859
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Fri Oct 11, 2019 5:40 am Post

Toggle the Insert key. This is a new fix in the new build.

cl
clownscape
Posts: 2
Joined: Fri Oct 11, 2019 4:22 am
Platform: Windows

Fri Oct 11, 2019 5:45 am Post

tiho_d wrote:Toggle the Insert key. This is a new fix in the new build.

Thanks! That solved it. Was this documented somewhere and I missed it?

User avatar
tiho_d
Posts: 859
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Fri Oct 11, 2019 5:56 am Post

This was a bug reported in Beta 24(Insert key does not toggle the overwrite mode) and fixed in Beta 25. If you do not need the overwrite mode at all, you can completely disable it in the Options and always work in insert style mode no matter of the Insert key pressed state.

en
enteleos
Posts: 7
Joined: Wed Dec 12, 2018 8:00 pm
Platform: Windows

Fri Oct 11, 2019 7:30 pm Post

Upon installing Beta 25 and opening my project, I was automatically in overwrite mode. I have no Insert key on my keyboard, and was at a loss to figure out how to turn it off. Thinking somehow I had accidentally toggled it on somehow, I double checked in gmail and Word and confirmed those programs still were in insert style mode.

It seems as though the default setting of the new build is to have overwrite mode toggled ON. This can create a problem for someone like me with no Insert key. I had to go into Options as detailed above and turn overwrite off entirely.

Might want to set the next build to default overwrite = OFF.

je
jeepea
Posts: 27
Joined: Tue Jan 18, 2011 5:13 am
Platform: Windows

Fri Oct 11, 2019 7:49 pm Post

Edit: The post above appeared as I was writing my own version of the same problem.

After I downloaded and installed Beta 25 (after uninstalling Beta 24), I discovered that the editor had changed to overwrite mode rather than insert. I found this thread and tried to follow the suggestion of using the Insert key to toggle this behavior and discovered three things: 1) My laptop does not have an Insert key. 2) Text processing tasks in other apps had not changed to Overwrite. 3) Text boxes within scrivener were still in Insert mode, it was only the editor that was in overwrite mode.

I found the Option to disable the use of the insert key in the Editor options and this did the trick for me as far as turning off overwrite mode. I don't understand why the editor would default to overwrite in the first place and wonder if this might be unintended. I see this as a potential problem for other users as I know mine isn't the only modern laptop that doesn't have an insert key.

Gina

le
lehtiniemi
Posts: 27
Joined: Mon May 21, 2018 12:52 pm
Platform: Mac + Windows

Fri Oct 11, 2019 8:16 pm Post

Same here. I have a laptop where there’s an insert key but getting the default behavior of inserting words would require holding down Fn+DEL (to activate insert) while I write. I also suggest it’s either of or maybe the default behavior/state of the key is incorrect. On my kind of laptop (Surface Book 2) I would expect that if I hold insert down, then I would activate overwriting (the less common feature). Currently it’s the opposite and normal working is difficult. (Before I switched off this feature in options)

Iv
IvyNelson
Posts: 23
Joined: Wed Dec 06, 2017 10:59 pm
Platform: Windows

Fri Oct 11, 2019 8:22 pm Post

I have tried every combination to try and toggle my insert key and it's not working. I'm on a Windows 10 HP computer and my ins key is on the 0 key of the num key pad. I've tried fn/ins I've tried ctrl/ins, shift/ins, alt/ins shift/alt/ins ctrl/shift/ins, ctrl/alt/ins., ctrl/shift/alt/ins

basically every combo and I cannot get it to toggle out of overwrite mode. If anyone has any suggestions for me that would be awesome. Thanks in advance.

User avatar
krastev
Posts: 382
Joined: Fri Feb 05, 2016 5:21 am
Platform: Windows
Contact:

Fri Oct 11, 2019 8:26 pm Post

This is bugging me too. This overwrite mode startled me, and I experienced five seconds of terror, not knowing what's going on. I have never ever used the insert key in my life, and mind you, I've been working with computers for over 35 years. :mrgreen:

Then I read @tiho_d's post and realized this key exists. :mrgreen: :mrgreen: :mrgreen:

Fortunately for me, I have it on my keyboard, :mrgreen: but I can understand the pain of those who don't.
Krastev
Windows 10 Home 64-bit
Scrivener for Windows Version 1.9.13.0
Testing Scrivener Beta for Windows

Iv
IvyNelson
Posts: 23
Joined: Wed Dec 06, 2017 10:59 pm
Platform: Windows

Fri Oct 11, 2019 8:27 pm Post

Update: I missed the commenter above mentioning the disabling of the use insert key option in Editor options. That has worked.

User avatar
krastev
Posts: 382
Joined: Fri Feb 05, 2016 5:21 am
Platform: Windows
Contact:

Fri Oct 11, 2019 8:34 pm Post

IvyNelson wrote:Update: I missed the commenter above mentioning the disabling of the use insert key option in Editor options. That has worked.


For those who are looking for the option, it can be found under:

Options —> Editing —> Options (tab) —> Use the Insert key to control overtype mode (checkbox)

Regards,
M
Krastev
Windows 10 Home 64-bit
Scrivener for Windows Version 1.9.13.0
Testing Scrivener Beta for Windows

To
TooOldForThis
Posts: 61
Joined: Tue Sep 04, 2018 6:11 pm
Platform: Windows

Fri Oct 11, 2019 9:05 pm Post

In all other applications where text can be edited, the keyboard is always in Insert mode. As of Beta 25, Scrivener defaults to Overwrite mode when it starts up. Setting the keyboard to Insert mode in one project does not carry over to another project when it is opened in the same session. It will always open with Overwrite as the default mode. The default mode should be Insert. Hitting the Insert button, if we have one, is a nuisance since we'll never remember because it only needs to be done in Scrivener. It would be great if you would flip that switch.

User avatar
krastev
Posts: 382
Joined: Fri Feb 05, 2016 5:21 am
Platform: Windows
Contact:

Fri Oct 11, 2019 9:36 pm Post

TooOldForThis wrote:In all other applications where text can be edited, the keyboard is always in Insert mode. As of Beta 25, Scrivener defaults to Overwrite mode when it starts up. Setting the keyboard to Insert mode in one project does not carry over to another project when it is opened in the same session. It will always open with Overwrite as the default mode. The default mode should be Insert. Hitting the Insert button, if we have one, is a nuisance since we'll never remember because it only needs to be done in Scrivener. It would be great if you would flip that switch.


I haven't noticed but you are right. And that's a colossal annoyance. I know of no other Windows software where overwrite is the default mode.

We need this fixed.

Regards,
M
Krastev
Windows 10 Home 64-bit
Scrivener for Windows Version 1.9.13.0
Testing Scrivener Beta for Windows

an
anja.zamari
Posts: 14
Joined: Mon Mar 25, 2019 10:28 am
Platform: Windows

Sat Oct 12, 2019 3:13 am Post

krastev wrote:
TooOldForThis wrote:In all other applications where text can be edited, the keyboard is always in Insert mode. As of Beta 25, Scrivener defaults to Overwrite mode when it starts up. Setting the keyboard to Insert mode in one project does not carry over to another project when it is opened in the same session. It will always open with Overwrite as the default mode. The default mode should be Insert. Hitting the Insert button, if we have one, is a nuisance since we'll never remember because it only needs to be done in Scrivener. It would be great if you would flip that switch.


I haven't noticed but you are right. And that's a colossal annoyance. I know of no other Windows software where overwrite is the default mode.

We need this fixed.

Regards,
M


Totally agreed.

I genuinely thought this was another bug. Tried looking for the insert key on my surface book. Realised I don't have it. Got annoyed and started working in MS Word instead.

Sorry, TiHo, but yes, this definitely should not be the default setting.

User avatar
Scribblette
Posts: 20
Joined: Fri Jul 26, 2019 10:49 pm
Platform: Windows

Sat Oct 12, 2019 5:38 am Post

Agreed. I love Scrivener and have noticed bugs here and there which are reported, but this is the first feature where I'm like a bad meme NOOOO.

I know how to use the Insert key just fine and this STILL freaked me out both times it happened. lol.

Every other app starts with Insert mode ON rather than Overwrite mode. Scrivener is already unique and special and fantastic and the odd one out. It doesn't need to do random opposites to be fancy. You're good enough.

 

 

cron