[LH4078] Two projects compile MMD differently with same compile settings

sq
squarn
Posts: 8
Joined: Fri Nov 23, 2018 5:52 am
Platform: Mac + Windows

Tue Oct 01, 2019 7:13 am Post

I'm at a loss. I'm trying to compile a project written in MMD to html (<em> tags being the thing I'm ultimately concerned about). However, a project created a year ago compiles plain MMD with no inline styling whatsoever, while a new test project I created to test compiles the exact same text perfectly.

E.g.
Doc1: *This is an example* > This is an example
Doc2: *This is an example* > This is an example.

I held alt to reset compile settings in the first project, I don't know if that changed anything. Both were compiled using Default - MMD > Web Page .html.

I have no idea what might be causing the main project to drop all styling when it compiles. Do I have to copy and paste all of my text into a new project? Any ideas would be much appreciated.

User avatar
devinganger
Posts: 2033
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Tue Oct 01, 2019 8:55 am Post

In both of your projects, what is the status of the following check box?

compiletommd.jpg
compiletommd.jpg (89.12 KiB) Viewed 420 times
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Life has a way of moving you past wants and hopes

sq
squarn
Posts: 8
Joined: Fri Nov 23, 2018 5:52 am
Platform: Mac + Windows

Tue Oct 01, 2019 9:22 am Post

devinganger wrote:In both of your projects, what is the status of the following check box?

compiletommd.jpg


It's unchecked in both of them.

User avatar
rdale
Posts: 2014
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Tue Oct 01, 2019 2:55 pm Post

What about section layouts? Have you assigned the same compile layouts to the documents in both projects that contain *emphasized text*?

Are you using the same compile preset, with the same output type selected?

In the main compile window, do you have any of the other options (on the right) set differently?

What happens when you copy the document giving you problems into the new project and then compile?
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

sq
squarn
Posts: 8
Joined: Fri Nov 23, 2018 5:52 am
Platform: Mac + Windows

Wed Oct 02, 2019 5:49 am Post

rdale wrote:What about section layouts? Have you assigned the same compile layouts to the documents in both projects that contain *emphasized text*?

Are you using the same compile preset, with the same output type selected?

In the main compile window, do you have any of the other options (on the right) set differently?

What happens when you copy the document giving you problems into the new project and then compile?


They do have slightly different section layouts. The problematic project has Section types "Group" and "Text" while the working project just has "Section." I looked into the settings of both and neither list emphasis or any other styles under the "Styles" section. All settings selected are default as far as I know.

Yes, same compile preset.

No.

When I copy it into a new project, it compiles correctly, so something is off. Is there a way to completely reset section types and compile settings?

rw
rwfranz
Posts: 925
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Wed Oct 02, 2019 7:57 am Post

squarn wrote:When I copy it into a new project, it compiles correctly, so something is off. Is there a way to completely reset section types and compile settings?


Easiest way to reset all that is to copy everything into a new project created with the new Beta. I think.
Just another user.

sq
squarn
Posts: 8
Joined: Fri Nov 23, 2018 5:52 am
Platform: Mac + Windows

Wed Oct 02, 2019 9:57 am Post

rwfranz wrote:
squarn wrote:When I copy it into a new project, it compiles correctly, so something is off. Is there a way to completely reset section types and compile settings?


Easiest way to reset all that is to copy everything into a new project created with the new Beta. I think.


Could it be an issue with the project not being created in a Windows-3-Beta version of Scriv? I'll probably do that.

User avatar
AmberV
Posts: 24272
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Oct 02, 2019 11:37 am Post

Migrating to a whole new project could entail a lot of extra work for a simple reset; depends on how many features you use—collections, metadata, etc. If one really wants to reset their compile settings, removing the “compile.xml” file from the Settings subfolder in the project package is all you need to do.

But, seeing as how this is a beta forum and all, it would be nice to figure out why this happening in one project but not the other.

Something you could try:

  1. Create a new blank project.
  2. Copy and paste some text into it from the problematic project.
  3. Close it, and then copy the compile.xml file into the test project’s Settings subfolder.
  4. Open it and compile.

Does the problem migrate to the new project? If so, could you send me a copy of the .xml file? (Feel free to use PM if you don’t want to post it publicly, it may have your name in it.)
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

User avatar
rdale
Posts: 2014
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Wed Oct 02, 2019 1:55 pm Post

squarn wrote:
rdale wrote:What about section layouts? Have you assigned the same compile layouts to the documents in both projects that contain *emphasized text*?

Are you using the same compile preset, with the same output type selected?

In the main compile window, do you have any of the other options (on the right) set differently?

What happens when you copy the document giving you problems into the new project and then compile?


They do have slightly different section layouts. The problematic project has Section types "Group" and "Text" while the working project just has "Section." I looked into the settings of both and neither list emphasis or any other styles under the "Styles" section. All settings selected are default as far as I know.

[...]

When I copy it into a new project, it compiles correctly, so something is off. Is there a way to completely reset section types and compile settings?


To clarify terminology, the "Section Type" is what you see if you load up the outliner and add that column, and also when you bring up the compile window and see what documents are to be included in the compilation.

Section layouts are what you match up to these section types, so that Scrivener knows how to lay out a "Section", "Group", or "Text".

I think this may be zeroing in on what the issue is.

What compile format are you using (when you bring up the compile window, it's the selection on the left), and if the formats are divided into two groups (as they will be if the compile format is part of the project itself instead of being available globally), what group is it in?

In the center of the compile window, what section layouts are assigned to which section types?

By the way, if you aren't super familiar with how to compile in Scrivener 3, these videos (for the Mac, but it's very very similar) should give you a good primer, and also get you familiar with the terms: https://www.literatureandlatte.com/lear ... t?os=macOS
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

sq
squarn
Posts: 8
Joined: Fri Nov 23, 2018 5:52 am
Platform: Mac + Windows

Fri Oct 04, 2019 8:04 am Post

AmberV wrote:Migrating to a whole new project could entail a lot of extra work for a simple reset; depends on how many features you use—collections, metadata, etc. If one really wants to reset their compile settings, removing the “compile.xml” file from the Settings subfolder in the project package is all you need to do.

But, seeing as how this is a beta forum and all, it would be nice to figure out why this happening in one project but not the other.

Something you could try:

  1. Create a new blank project.
  2. Copy and paste some text into it from the problematic project.
  3. Close it, and then copy the compile.xml file into the test project’s Settings subfolder.
  4. Open it and compile.

Does the problem migrate to the new project? If so, could you send me a copy of the .xml file? (Feel free to use PM if you don’t want to post it publicly, it may have your name in it.)


I copied the .xml file over and got the same problematic results. PMing you the xml file now.

User avatar
AmberV
Posts: 24272
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Oct 17, 2019 12:49 pm Post

Sorry for the delay in getting back with you on this one—and thanks for sending the file. I found the bug by comparing it with a stock compile.xml file. Though hopefully at this point you’ve reset the compile settings and it isn’t getting in your way, for the sake of curiosity, the problem is that the two conversion options for rich text formats, that relate to converting MMD to RTF were ticked. You cannot see these options when using Markdown outputs, because they are supposed to be irrelevant (after all, why would we be converting Markdown to rich text for the purposes of making a Markdown file?). However they are active, and so my guess is that what is happening is they are taking your Markdown and converting it to RTF, and then passing the RTF back to the Markdown output engine, which strips all formatting by virtue of turning the editor content into plain-text, causing any trace of the original Markdown formatting to be erased.

So it’s a silly bug, and hopefully easy to fix.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles