Undeclared prefix: 'ibooks'. (ERROR)

Ro
RorydEon
Posts: 12
Joined: Wed Jul 20, 2016 2:21 pm
Platform: Mac + iOS

Wed Aug 29, 2018 1:38 pm Post

ePubs (3 )don't validate with this error:
• Undeclared prefix: 'ibooks'. (ERROR)
What can I do to fix this?

User avatar
KB
Site Admin
Posts: 20827
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Aug 29, 2018 3:02 pm Post

This is caused by some HTML Scrivener adds so that iBooks opens the ePub at the start page. Apple's documentation suggests adding it, but it turns out that it does indeed cause ePub validation to fail elsewhere. I've fixed this for the next update. In the meantime, you can tick the option to optimise for Kindle export as a workaround, which will avoid adding this piece of HTML.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

User avatar
AmberV
Posts: 24325
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Aug 29, 2018 3:24 pm Post

Or you can enable the Omit “landmark” guides setting, in the Table of Contents compile option tab, which would I think more surgically remove the invalid element without potentially changing other aspects of the output?
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ro
RorydEon
Posts: 12
Joined: Wed Jul 20, 2016 2:21 pm
Platform: Mac + iOS

Wed Aug 29, 2018 3:54 pm Post

K, thanks for this.
As a workaround, I have been unzipping the ePub and deleting the 'iBooks' line and re-zipping.
Thanks, I appreciate your quick response.
Rory

User avatar
AmberV
Posts: 24325
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed Aug 29, 2018 4:06 pm Post

If you're comfortable removing the line yourself, that will be the best all around approach, as the new landmark system is preferred to the older "guide" system, which Scrivener falls back to using when either of the above settings are enabled.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

Ro
RorydEon
Posts: 12
Joined: Wed Jul 20, 2016 2:21 pm
Platform: Mac + iOS

Wed Aug 29, 2018 4:20 pm Post

Thanks again.
I'll continue to remove the line until the next update.
Rory

ra
randybisig
Posts: 16
Joined: Sat Jan 07, 2017 10:17 pm
Platform: Mac + iOS

Fri Aug 31, 2018 1:42 am Post

AmberV wrote:Or you can enable the Omit “landmark” guides setting, in the Table of Contents compile option tab, which would I think more surgically remove the invalid element without potentially changing other aspects of the output?


Results: Congratulations! No problems were found.

Amber,

Had a bit trying to find the option, but enabling the setting fixed the issue for me.

Thanks to everyone!

wr
writergal
Posts: 61
Joined: Tue Jun 12, 2007 8:37 pm
Platform: Mac
Contact:

Mon May 06, 2019 9:22 pm Post

Hi, I'm having this issue too.

But I don't understand the solutions given here. Can someone simply a tad? I don't know what "removing the line" means. And I can't find the "omit landmark guides" setting in the Table of Contents compile option tab. Any help someone could give would be much appreciated.

User avatar
AmberV
Posts: 24325
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Wed May 08, 2019 10:06 am Post

It is the fifth checkbox from the top, or the last checkbox in the list of settings, in the aforementioned compile tab, right above “Table of contents title” and right below “Bold top-level items”.

Make sure your copy of Scrivener is up to date, that option was added after 3.0 was released, I think.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

wr
writergal
Posts: 61
Joined: Tue Jun 12, 2007 8:37 pm
Platform: Mac
Contact:

Sat May 25, 2019 5:44 pm Post

Thanks for your help! I found the right spot and have checked the appropriate box. I'll let you know if it works!