Accented characters don't work on Wine (Linux)

aa
aalonso
Posts: 3
Joined: Fri Aug 19, 2016 2:14 pm
Platform: Linux

Fri Aug 19, 2016 2:20 pm Post

Hi there,
I've installed Scrivener on Linux using Wine / Crossover. It works apparently fine, except for one thing:
** I can't use accented characters (like á é í ó ú ã õ ê).
I can type only 1 accented character (let's say á), then, when I try to type other characters (like é, ó etc.), Scrivener keeps putting the first accented character (á), even if I'm typing accent+e, accent+o etc.
Any tips on how to fix that?
Thanks,
AA.

Li
Linus
Posts: 118
Joined: Thu Jan 07, 2016 7:47 pm
Platform: Linux + Windows
Location: Germany

Fri Aug 19, 2016 11:03 pm Post

Only because of your post I realised that I had the same problem. I write in German, so there are only rare occasions where I have to use accents.

This link helped me:
http://askubuntu.com/questions/360696/keyboard-not-working-100-after-ubuntu-13-10-upgrade

In my case I set Keyboard Input Method to IBUS, restarted and everything was fine, just like this: áéíóúÁÉÍÓÚ àèìòùÀÈÌÒÙ.

I am using Linux Mint but any distro should have a similar dialogue in System Settings.

Hope that helps!

aa
aalonso
Posts: 3
Joined: Fri Aug 19, 2016 2:14 pm
Platform: Linux

Sat Aug 20, 2016 5:25 am Post

Linus wrote:Only because of your post I realised that I had the same problem. I write in German, so there are only rare occasions where I have to use accents.

This link helped me:
http://askubuntu.com/questions/360696/keyboard-not-working-100-after-ubuntu-13-10-upgrade

In my case I set Keyboard Input Method to IBUS, restarted and everything was fine, just like this: áéíóúÁÉÍÓÚ àèìòùÀÈÌÒÙ.

I am using Linux Mint but any distro should have a similar dialogue in System Settings.

Hope that helps!


Thanks for your message. I tried the ibus system and still get the same behavior...
I'll try to dig a little bit more. Too bad that they dropped the Linux version...
Thanks once more,
AA

ca
caiohungria
Posts: 4
Joined: Tue Sep 13, 2016 10:03 pm
Platform: Linux

Wed Sep 21, 2016 9:55 pm Post

Open terminal and type: ibus-setup
Switch to Advanced tab and uncheck "Global input method settings".
Restart system, open Scrivener and have fun.

Si
Sidney76
Posts: 2
Joined: Sat Nov 12, 2016 8:32 pm
Platform: Windows

Sat Nov 12, 2016 8:36 pm Post

Hello Linus,
I am considering getting Scrivener. I write a lot in both German and English. Does Scrivener have its own German language setting (the way most word processors now do)?
I use Windows 7 as an operating system.
Thank you.
Sidney

Li
Linus
Posts: 118
Joined: Thu Jan 07, 2016 7:47 pm
Platform: Linux + Windows
Location: Germany

Sun Nov 13, 2016 8:58 am Post

Sure, under Tools>Options>Corrections you can select - or, if not yet available, first download - a German dictionary (see manual B.6 Corrections). However, you cannot have a multi-language project. So the dictionary is applied evenly to all documents in a project. Therefore also, unlike in Word, you cannot have e.g. parts of a document use one language and other parts another language. So, if you have a project with German and English texts in it, you would have to switch spelling settings back and forth to check documents or document parts in different languages.

Si
Sidney76
Posts: 2
Joined: Sat Nov 12, 2016 8:32 pm
Platform: Windows

Mon Nov 14, 2016 3:46 am Post

Great. Thanks.

gi
gijsh
Posts: 2
Joined: Wed Feb 27, 2019 7:21 am
Platform: Mac + Windows

Wed Feb 27, 2019 7:27 am Post

I use Scrivener for Windows under wine (from winehq, OS=Linux Mint 18.3). I experienced the same dead-key issues mentioned above. After installing and activating (in startup applications) ibus Scrivener worked OK: é,á etc.
....
And then, after a while, only the first accented char I use in a session showed up, e.g. é when I type á afterwards. No idea how this came about.

cl
clombard
Posts: 4
Joined: Wed Sep 12, 2018 2:37 pm
Platform: Linux + Windows

Fri Nov 15, 2019 5:53 pm Post

I have the same problem with accented characters. Using Scrivener under Wine with ArchLinux. I've tried ibus, but it doesn't solve the problem.

Has anyone been able to solve it?

Currently I am able to reset what character appears by typing one with the opposite case, e.g. if it's currently ê, type a capital letter with an accent, then type the one you actually want.

an
andrewbond
Posts: 18
Joined: Sat Jul 05, 2014 2:31 am
Platform: Linux

Mon Dec 16, 2019 4:47 pm Post

I use Mint (Linux Mint 19.2 Cinnamon) and run Scrivener under Crossover. I have loaded multiple "keyboards" (System settings | Keyboards) and do not have any problems.

It's not IBUS, but it works.

Be
Benjamin Rittgers
Posts: 8
Joined: Sun Jul 07, 2019 8:25 am
Platform: Linux
Location: Iowa - USA
Contact:

Mon Jan 06, 2020 12:26 pm Post

I usually use the Windows version under wine and don't have this issue. But I enter accented characters with the right alt key. Will that work or do you have to use compose?

cl
clombard
Posts: 4
Joined: Wed Sep 12, 2018 2:37 pm
Platform: Linux + Windows

Mon Jan 06, 2020 12:51 pm Post

Hi Benjamin,

My compose key is the right Alt key :). Could you expand on your setup?

Thanks
Cecilia

La
Lambekin
Posts: 10
Joined: Sat Jul 21, 2018 10:18 am
Platform: Windows

Thu Feb 27, 2020 9:37 am Post

I just solved this on my system, so I thought I'd post the solution here.

Ibus was installed on my computer using Kubuntu 19.10, but I still ran into the problem where Scrivener would produce the same character every time I tried typing an accent. I.e., if I first typed é, every accented character that I would subsequently try to type would come out as é.

A workaround that I used, and which I have not seen anyone else post about, was to type an accented capital in upper case if the first one was in lower case. This would then allow typing a new accented lower case character. For instance, after typing é, typing Ú would allow me to type a new accented lower case character like ï. This procedure would have to be repeated every time I needed a new accented character, though.

Earlier today I decided to have another look at how my keyboard was configured. Using KDE, I opened the 'Input Method' window which, after clicking OK, allowed me to select the 'active intelligent input bus':

Image

Apparently, 'ibus' had not been fully activated. Another OK, and a new 'ibus preferences' applet appeared in my system tray - and typing accented characters in Scrivener worked perfectly. :-)

cl
clombard
Posts: 4
Joined: Wed Sep 12, 2018 2:37 pm
Platform: Linux + Windows

Sat Feb 29, 2020 6:50 pm Post

The solution Lambekin gave doesn't work for me,unfortunately, because I'm on archlinux, which doesn't have im-config. But the fact that it could still be an activate/setup problem had me digging again.

This time when I tried running Scrivener from the command line as a test, the diacritics suddenly worked like they should. I know I tried this before (and ctrl-r confirms it) and it didn't work. Yes, there was a big Arhlinux update in the meantime. Running Scrivener from the launcher in xfce still had the diacritics problem, however

Long story short: adding XMODIFIERS="@im=ibus" to the command of the launcher did the trick. The command is now:
env XMODIFIERS="@im=ibus" WINEPREFIX="/home/cecilia/.wine" wine C:\\windows\\command\\start.exe /Unix '/home/cecilia/.wine/drive_c/Program Files (x86)/Scrivener/Scrivener.exe'

Question now is, why the difference between the launcher and the command line? Do they use different environment variables?

User avatar
devinganger
Posts: 1853
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272 (CN97au)
Contact:

Sat Feb 29, 2020 7:19 pm Post

clombard wrote:Question now is, why the difference between the launcher and the command line? Do they use different environment variables?


Yes, typically they do not share the same set of environment variables. Many launchers do not invoke your shell environment and don't get the full setup of your environment variables, so you have to explicitly declare the appropriate ones.
--
Devin L. Ganger, WA7DLG
Not a L&L employee; opinions are those of my cat
Winner "Best in Class", 2018 My First Supervillain Photo Shoot