Composition Mode dialogue boxes all black / blank

Ji
JimK
Posts: 17
Joined: Tue Oct 25, 2016 11:10 am
Platform: Mac + iOS

Tue Jul 03, 2018 1:53 pm Post

After I upgraded to the latest version of Scrivener when I am in composition mode and make a typo the box that pops up with a spelling correction is all black so you cant see the words in it (see attachment).

Also if I try and use dictionary / thesaurus that dialogue box won't open in composition mode,

Both of these work fine in non composition mode.

Thanks - (High Sierra 10.13.5 / Scrivener 3.0.3 (3032))
Attachments
bug1.jpg
shows the problem (and my bad typing!)
bug1.jpg (100.55 KiB) Viewed 1498 times

User avatar
KB
Site Admin
Posts: 20716
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Tue Jul 03, 2018 6:02 pm Post

Very strange - I cannot reproduce this at all, as it is working fine for me on both my machines. These dialogue boxes are handled by Apple code, too, which makes it even stranger.
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

Ji
JimK
Posts: 17
Joined: Tue Oct 25, 2016 11:10 am
Platform: Mac + iOS

Tue Jul 03, 2018 7:02 pm Post

Is there anything you would like me to check?

Ji
JimK
Posts: 17
Joined: Tue Oct 25, 2016 11:10 am
Platform: Mac + iOS

Wed Jul 04, 2018 1:46 pm Post

Hi This is still happening and is really difficult to work with. Any suggestions from anyone for a fix?

Ji
JimK
Posts: 17
Joined: Tue Oct 25, 2016 11:10 am
Platform: Mac + iOS

Thu Jul 05, 2018 2:32 pm Post

I've found a way to replicate the issue. If the app is in full screen mode when I switch to composition mode I get this issue, when the app is not in full screen the dialogue boxes work normally ...

User avatar
KB
Site Admin
Posts: 20716
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Wed Jul 18, 2018 6:37 pm Post

Thanks for the extra information. I can reproduce it now myself. Unfortunately there is nothing I can do to fix it as it is an Apple bug. However, you can work around it by setting Composition Mode to open in its own space as follows:

1. Go to Scrivener > Preferences...

2. Under "Behaviours", select "Composition Mode" on the left and then tick "Open composition mode in its own space" on the right.

The bug seems to be triggered by a full screen presentation space (Composition Mode) being opened over a window filling a space (full screen mode), so by having Composition Mode move to its own space, you avoid the issue.

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."