How to Remove Hyper-Link Underlines in Scrivener 3.0?

User avatar
Shunyata
Posts: 18
Joined: Wed May 20, 2015 12:27 pm
Platform: Mac
Location: Bali
Contact:

Sat Dec 02, 2017 4:48 am Post

How can we remove the underline formatting on links in version 3.0?

Sorry, if this is an obvious setting adjustment. But, I have searched through both the tutorial and the manual to no avail.

Please do Advise

Thanks

User avatar
Silverdragon
Posts: 1443
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Sat Dec 02, 2017 5:14 am Post

In the compile dialog:
Screenshot_2017-12-01_21_09_33.png
Screenshot_2017-12-01_21_09_33.png (108.91 KiB) Viewed 3536 times


Hope this helps!
  • Fiction-writer curled up on her TP hoard.
  • Mac Scrivener 3.1.5, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.2.1; iPhone 8+, iPad 6; i(Pad)OS 13.5.1
  • Website: https://silverdrag0n.wordpress.com

User avatar
Shunyata
Posts: 18
Joined: Wed May 20, 2015 12:27 pm
Platform: Mac
Location: Bali
Contact:

Sat Dec 02, 2017 5:25 am Post

Opps! I forgot to mention that I'm referring to the underline formatting in the binder/doc/ edit panel view.
Hyper-link Formatting.png
Hyper-link Formatting.png (54.21 KiB) Viewed 3534 times

Thanks for trying SIlverDragon... your time and effort is much appreciated.

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sat Dec 02, 2017 10:15 am Post

This should work …

Underline Hyperlinks.jpg
Underline Hyperlinks.jpg (98.43 KiB) Viewed 3518 times


Textual Marks Manual.jpg
Textual Marks Manual.jpg (207.61 KiB) Viewed 3509 times

User avatar
Shunyata
Posts: 18
Joined: Wed May 20, 2015 12:27 pm
Platform: Mac
Location: Bali
Contact:

Sun Dec 03, 2017 12:52 am Post

Thank You Bridey : ) That was exactly what I was looking for.

I've gone through nearly all of the tutorial videos for 3.0 now. They really are great and I do wish they had one that ran us through all of the preference settings. They are a nest of treasures.

You Made My Day!

User avatar
Bridey
Posts: 390
Joined: Wed Nov 22, 2017 2:24 pm
Platform: Mac

Sun Dec 03, 2017 9:20 am Post

Welcome.

po
poldy
Posts: 2
Joined: Wed Apr 18, 2018 2:48 pm
Platform: Mac

Wed Apr 18, 2018 3:19 pm Post

Fellow scriveners:

Here's a question (I'm new to this forum and couldn't find the way to post a new thread):

I'd like to know how I can remove all external hyperlinks (that is, those created as a result of copy-pasting texts containing hyperlinks from the web, which would link back to webpages outside Scrivener) in a given editor note. To clarify, I'm interested in removing more than one link in an editor (without having to right-click remove every single link) and not during compilation. Nor do I want to use the "Paste and Match Style" option, which successfully gets rid of the links, that's true, but messes up the rest of the formatting of the text (say, italicized words or phrases). Any thoughts?

Best,
Poldy

User avatar
KB
Site Admin
Posts: 20729
Joined: Tue Jun 13, 2006 11:23 pm
Platform: Mac
Location: Truro, Cornwall
Contact:

Fri Apr 20, 2018 6:44 pm Post

To do this, you would Select All in the editor (Cmd-A) and then use Edit > Remove Link. This will remove all links from the selected text. (Note that in the current version, this command will not be available if there are any comments in the selected text - this will be fixed in the next update.)

All the best,
Keith
"You can't waltz in here, use my toaster, and start spouting universal truths without qualification."

po
poldy
Posts: 2
Joined: Wed Apr 18, 2018 2:48 pm
Platform: Mac

Fri Apr 20, 2018 8:58 pm Post

KB wrote:To do this, you would Select All in the editor (Cmd-A) and then use Edit > Remove Link. This will remove all links from the selected text. (Note that in the current version, this command will not be available if there are any comments in the selected text - this will be fixed in the next update.)

All the best,
Keith


Thanks so much, Keith. That's it! The solution was embarrassingly simple. In retrospect, though, it was the commented elements in my texts that did it, because almost all of them contained at least one comment, which, as you clarified, made the "Edit>Remove Link" unavailable.

Best,
Poldy

ma
makfai
Posts: 37
Joined: Tue Oct 01, 2013 11:28 am
Platform: Win + iOS

Mon Nov 25, 2019 2:32 pm Post

How do you remove hyperlinks on an iPad?
Using iPADOS and sometimes Windows.

User avatar
xiamenese
Posts: 4324
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Mon Nov 25, 2019 6:18 pm Post

makfai wrote:How do you remove hyperlinks on an iPad?

This should be posted in the iOS forum.
The Scrivenato sometimes known as Mr X.
iMac 27" (late 2015) 10.15.4, 24GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 16GB RAM, 2TB SSID
2017 iPad, iPadOS 13.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

ma
makfai
Posts: 37
Joined: Tue Oct 01, 2013 11:28 am
Platform: Win + iOS

Mon Nov 25, 2019 6:27 pm Post

I already did that - after I realised that I was in the wrong forum. A nice person gave me a polite and extremely helpful answer.
Using iPADOS and sometimes Windows.

User avatar
ianhart
Posts: 36
Joined: Sat Feb 12, 2011 9:44 pm
Platform: Mac
Location: Canberra, Australia
Contact:

Mon Dec 16, 2019 3:17 am Post

KB wrote:To do this, you would Select All in the editor (Cmd-A) and then use Edit > Remove Link. This will remove all links from the selected text. (Note that in the current version, this command will not be available if there are any comments in the selected text - this will be fixed in the next update.)

All the best,
Keith


What I'm actually doing is typing a fictitious email address in my text, which I do not want to appear as a real hyperlink. If I select it and go to Edit/Remove hyperlink, the link is removed ... until I type something else, then it comes back again. I think this is a glitch.
Ian
There's holes in the sky where the rain gets in
But they're ever so small. That's why rain's so thin.
- Spike Milligan

ImageImage

sc
scshrugged
Posts: 500
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Tue Dec 17, 2019 3:35 pm Post

ianhart wrote:
KB wrote:To do this, you would Select All in the editor (Cmd-A) and then use Edit > Remove Link. This will remove all links from the selected text. (Note that in the current version, this command will not be available if there are any comments in the selected text - this will be fixed in the next update.)

All the best,
Keith


What I'm actually doing is typing a fictitious email address in my text, which I do not want to appear as a real hyperlink. If I select it and go to Edit/Remove hyperlink, the link is removed ... until I type something else, then it comes back again. I think this is a glitch.


I can reproduce this using macOS 10.14.6 and Scrivener 3.1.5. The behavior was/is the same in 3.1.4, don’t know about prior versions.

After using Edit > Remove Link on a selection, when one types in the line from which the link was removed, the address becomes an active link again. Typing in any other line before typing in the affected line has no bearing on the issue.

Toggling the option off at Preferences > Corrections > Data-Detection > Automatically detect web addresses can be used as a workaround before or after using Edit > Remove Link, before typing in the affected line.

The option can be toggled as needed in process, or left off if not needed for the project/session.



[I'll file a bug report––https://www.literatureandlatte.com/forum/viewforum.php?f=3–– in the next couple of days if not addressed here, if there isn't one already filed.]
I'm a Scrivener user, not an L&L employee.

sc
scshrugged
Posts: 500
Joined: Wed Feb 10, 2016 6:55 pm
Platform: Mac + iOS

Thu Dec 19, 2019 2:33 pm Post

scshrugged wrote:
ianhart wrote:
KB wrote:To do this, you would Select All in the editor (Cmd-A) and then use Edit > Remove Link. This will remove all links from the selected text. (Note that in the current version, this command will not be available if there are any comments in the selected text - this will be fixed in the next update.)

All the best,
Keith


What I'm actually doing is typing a fictitious email address in my text, which I do not want to appear as a real hyperlink. If I select it and go to Edit/Remove hyperlink, the link is removed ... until I type something else, then it comes back again. I think this is a glitch.


I can reproduce this using macOS 10.14.6 and Scrivener 3.1.5. The behavior was/is the same in 3.1.4, don’t know about prior versions.

After using Edit > Remove Link on a selection, when one types in the line from which the link was removed, the address becomes an active link again. Typing in any other line before typing in the affected line has no bearing on the issue.

Toggling the option off at Preferences > Corrections > Data-Detection > Automatically detect web addresses can be used as a workaround before or after using Edit > Remove Link, before typing in the affected line.

The option can be toggled as needed in process, or left off if not needed for the project/session.



[I'll file a bug report––https://www.literatureandlatte.com/forum/viewforum.php?f=3–– in the next couple of days if not addressed here, if there isn't one already filed.]


An update on this after further testing using Preview, macOS 10.14.6 and Scriv 3.1.5:

Even after toggling the Automatically detect web addresses preference to off whenever in the process, at Compile (at least to PDF) the edited links print as active, but not colored or underlined. This is with Remove all hyperlinks not selected at Compile Options. With it selected, each link prints as active, not colored or underlined.

By "whenever in the process", I mean whether it's used as a workaround for the Edit > Remove Link glitch in the Editor as written in my previous post, or if it's been toggled off as a longterm desire for a session/project.
I'm a Scrivener user, not an L&L employee.

 

 

cron