First runs of 3 won't load under High Sierra

Posts: 68
Joined: Tue Aug 26, 2014 9:53 pm
Platform: Mac

Tue Dec 05, 2017 3:31 am Post

Should I prefer one over the other? I don't need to keep two copies.

Posts: 68
Joined: Tue Aug 26, 2014 9:53 pm
Platform: Mac

Thu Dec 21, 2017 6:12 am Post

I'm now traveling for Christmas with my Macbook Air. It has worked on the Air, but tonight I tried to run it and had the same things happen.
Process: Scrivener [37905]
Path: /Applications/
Identifier: com.literatureandlatte.scrivener3
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Scrivener [37905]
User ID: 502

Date/Time: 2017-12-20 23:01:13.186 -0700
OS Version: Mac OS X 10.13.3 (17D20a)
Report Version: 12
Anonymous UUID: A2BD0C6B-175B-12F9-A745-0E2DFD9EB6EF

Sleep/Wake UUID: E1EE12B1-4809-478F-A51A-6F22AD10B7DC

Time Awake Since Boot: 76000 seconds
Time Since Wake: 4000 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (Code Signature Invalid)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: Namespace CODESIGNING, Code 0x1

kernel messages:

VM Regions Near 0 (cr2):
__TEXT 000000010a8e5000-000000010adb2000 [ 4916K] r-x/rwx SM=COW

Thread 0 Crashed:
0 ??? 0x000000010cbd619c _dyld_start + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x0000000000000000 rcx: 0x0000000000000000 rdx: 0x0000000000000000
rdi: 0x0000000000000000 rsi: 0x0000000000000000 rbp: 0x0000000000000000 rsp: 0x00007ffee531ac18
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x0000000000000000 r11: 0x0000000000000000
r12: 0x0000000000000000 r13: 0x0000000000000000 r14: 0x0000000000000000 r15: 0x0000000000000000
rip: 0x000000010cbd619c rfl: 0x0000000000000200 cr2: 0x0000000000000000

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 0

Binary Images:
0x10a8e5000 - 0x10adb1fff +??? (0) <4B1A646E-4EB6-361F-8E02-820D937271FE> (null)
0x10cbd5000 - 0x10cc1f98f +??? (519.2.2) <6695F30B-4E88-3C0B-9867-7D738C44A3E6> (null)

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 2
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 94902
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=5496K resident=0K(0%) swapped_out_or_unallocated=5496K(100%)
Writable regions: Total=8408K written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=8408K(100%)

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Stack 8192K 2
__DATA 1192K 5
__TEXT 5216K 3
shared memory 8K 3
=========== ======= =======
TOTAL 70.5M 12

Model: MacBookAir4,2, BootROM MBA41.007B.B00, 2 processors, Intel Core i5, 1.7 GHz, 4 GB, SMC 1.73f66
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xE9), Broadcom BCM43xx 1.0 (
Bluetooth: Version 6.0.2f2, 3 services, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: OWC Aura SSD, 240.06 GB
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Internal Memory Card Reader
USB Device: USB 2.0 Bus
USB Device: FaceTime Camera (Built-in)
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Air, Apple Inc., 8.1

I've deleted it, downloaded the .zip file version from earlier in the thread, and that has installed and registered ok.

User avatar
Posts: 6574
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Dec 21, 2017 7:50 am Post

Note that this fix is also incorporated in Scrivener 3.0.1, released today. It includes a few other important bug fixes as well, and can be downloaded from the site or via Scrivener's automatic upgrade tool.

Scrivener Support Team