Compile Creates One Long Run-On Paragraph

ja
jackm1
Posts: 1
Joined: Wed Dec 06, 2017 1:03 pm
Platform: Mac

Wed Dec 06, 2017 1:11 pm Post

I think I've messed up the compile settings somehow. No matter what I do, all text appears as a single run-on paragraph. this applies to any text. I have tried different settings with no results. This never happened with v2.

Any help is much appreciated.

News. If I select the convert MultiMarkdown to rich text in text and notes, all the paragraph marks vanish. Is there a way to fix this?

Scrivener 2 had a compile option to convert markdown to italics and bold. I don't see that option anymore. Have I missed something?

Br
BrianJJarrett
Posts: 3
Joined: Thu Dec 07, 2017 1:30 am
Platform: Mac

Thu Dec 07, 2017 1:58 am Post

I'm having the same problem. Paragraphs are now run-on sentences after compilation (both mobi & epub 2 & 3). All paragraph breaks are gone.

Also unformatted/as-is documents (like front/back matter) are not obeying the formatting used in the editor. Instead of compling centered, the text is left-justified and loses return characters.

This happens on imported/converted V2 files as well as brand new files built directly from the default "Novel" template.

My imported Scrivener files are nothing fancy; an old V2 template...just simple folder chapters and text scenes. My converted files do appear to have mapped to the new format properly, but they still won't compile correctly.

I've gone through the tutorial and followed all the instructions and yet I still cannot get an ebook to compile properly with any of my attempts. That said, at least multimarkdown italics work. :)

I like the new compile approach, but unfortunately if I can't compile an ebook then there's little choice left for me than to revert back to V2 and call it a day. I'm currently running V2 side-by-side with V3, so it's not keeping me from writing. It's just disappointing because I was really excited about V3. :cry:

Br
BrianJJarrett
Posts: 3
Joined: Thu Dec 07, 2017 1:30 am
Platform: Mac

Thu Dec 07, 2017 2:04 am Post

UPDATE: If I turn off "Convert Multimarkdown to rich text in notes and text" during compile, my formatting issues go away! I lose my markdown italics, of course, but it's a step in the right direction.

Hope this update helps. Fingers crossed that this gets fixed and then I can move over to V3 after all!

User avatar
kewms
Posts: 5388
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Dec 07, 2017 3:45 am Post

The disappearing paragraph marks are a side effect of the Markdown conversion, which is more aggressive in Scrivener 3. The solution is to use a Replacement to replace single paragraph marks with doubles: the Markdown conversion will only remove one of them.

Katherine
Scrivener Support Team

Br
BrianJJarrett
Posts: 3
Joined: Thu Dec 07, 2017 1:30 am
Platform: Mac

Fri Dec 08, 2017 11:38 am Post

Hi Katherine,

Thanks so much for the quick reply. I tested your proposed solution and it does work.

It's unfortunate that Multimarkdown behavior changed from V2 to V3 because it had recently become useful to me. That said, I only used Multimarkdown to preserve italics when copying to/from grammar checking software that wouldn't retain my native rtf formatting, so I'm not sure it's worth adding extra new lines throughout to the manuscript to continue marking down italics. I can just manually replicate the behavior for what little italics formatting I use as a work around.

In the end, the new features of V3 outweigh a wee bit of formatting problems, so I'm officially switched over to Scrivener 3. :D

Thanks again for your help.

Brian

Pe
PeterCHayward
Posts: 7
Joined: Mon Feb 08, 2016 9:49 pm
Platform: Mac

Fri Mar 29, 2019 4:48 pm Post

kewms wrote:The disappearing paragraph marks are a side effect of the Markdown conversion, which is more aggressive in Scrivener 3. The solution is to use a Replacement to replace single paragraph marks with doubles: the Markdown conversion will only remove one of them.

Katherine


I cannot get this solution to work! It looks like it converts to Markdown and then replaces the single paragraph marks with doubles. Is there a way to change the order of events?

Can someone who got this working share screenshots of EXACTLY what they did, perhaps?

User avatar
rdale
Posts: 1735
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Mar 29, 2019 5:31 pm Post

Are you sure you got a single paragraph character in the "replace" column, and two in the "with" column? How did you enter those characters? Did you turn on/off any of the other replacements options on that line?

FYI, the replacements do go before it converts to MMD. It has to work that way for many of my custom compiles to work.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

User avatar
Silverdragon
Posts: 1156
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Fri Mar 29, 2019 6:18 pm Post

I gave up on "Convert Multimarkdown to Rich Text in notes and text" for just this reason. My experience is also that the substitution of two returns for one happens after the multimarkdown conversion has taken place, no matter whether I do so in the overall compile options, or within the compile format itself. The only solution I've found is to use double returns in the editor.
So you know where I'm coming from:
  • I write fiction.
  • I'm not an L&L employee.
  • Mac Scrivener 3.1.4, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.2; iPhone 8+, iPad 6; i(Pad)OS 13.2.3
  • Website: https://silverdrag0n.wordpress.com

User avatar
rdale
Posts: 1735
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Fri Mar 29, 2019 9:38 pm Post

Really? I guess because I went a different route for that problem, I didn't experience the MMD conversion being prior to the replacements tab kicking in...

What I did for myself, due to the adoption of styles, was to leave standard paragraphs unstyled. Then in a custom compile setting, I created a "body" paragraph style. Not in the main project; it's not useful there...

I set the Body style to be "pure markdown", and added a newline suffix for paragraphs.

With that "Body" style in the compile settings, I went to the section layouts I used for my main text. I then changed the text for that section layout to use the Body style.

Any text styled with some other style is ignored by the layout formatting. For instance, my lists have a style meant solely for making them look nice in scrivener; the Body style isn't applied to that text.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

User avatar
Silverdragon
Posts: 1156
Joined: Mon Jul 29, 2013 2:52 pm
Platform: Mac + iOS
Location: Tarzana, California, USA
Contact:

Fri Mar 29, 2019 10:23 pm Post

Thank you, RDale. That is a different approach from using the Replacements tabs, and one that would not have occurred to me.

However, now that I've rebuilt my writing life to avoid converting multimarkdown to rich text :D turning it around would be a pain in the anatomy. I hope the OP finds your method helpful!
So you know where I'm coming from:
  • I write fiction.
  • I'm not an L&L employee.
  • Mac Scrivener 3.1.4, MacBook Air 11, MacOS 10.14.6 (Mojave)
  • IOS Scrivener 1.2; iPhone 8+, iPad 6; i(Pad)OS 13.2.3
  • Website: https://silverdrag0n.wordpress.com

Pe
PeterCHayward
Posts: 7
Joined: Mon Feb 08, 2016 9:49 pm
Platform: Mac

Wed Apr 03, 2019 6:43 pm Post

rdale wrote:Really? I guess because I went a different route for that problem, I didn't experience the MMD conversion being prior to the replacements tab kicking in...

What I did for myself, due to the adoption of styles, was to leave standard paragraphs unstyled. Then in a custom compile setting, I created a "body" paragraph style. Not in the main project; it's not useful there...

I set the Body style to be "pure markdown", and added a newline suffix for paragraphs.

With that "Body" style in the compile settings, I went to the section layouts I used for my main text. I then changed the text for that section layout to use the Body style.

Any text styled with some other style is ignored by the layout formatting. For instance, my lists have a style meant solely for making them look nice in scrivener; the Body style isn't applied to that text.


I don't think I'm Scrivener-savvy enough to understand what this means! Is there any chance you could share some screenshots? It sounds like exactly what I'm looking for, I just don't know how to execute it.

User avatar
rdale
Posts: 1735
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Thu Apr 04, 2019 1:02 pm Post

It may take me a bit to get around to this; I have a trip coming up this weekend, and compiling screenshots and annotating them takes time that I'm rather short on.

If you haven't already, look into the videos on the compile system, paying special attention to the customization video (the 4th one) here: https://www.literatureandlatte.com/lear ... ategory=43

Being familiar with how you start creating your own custom compile settings is the first step. You may find that your particular mix of Scrivener Styles + MMD formatting may require other tweaks, so familiarizing yourself with compile customization will server you well. Also, are you familiar with the compile setup for version 2, or is Scrivener 3 your first Scrivener? I ask because once you get into the customization of compile, a version 2 user is on more familiar-looking territory.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

Jo
JoRo
Posts: 828
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Thu Apr 04, 2019 2:50 pm Post

kewms wrote:The disappearing paragraph marks are a side effect of the Markdown conversion, which is more aggressive in Scrivener 3. The solution is to use a Replacement to replace single paragraph marks with doubles: the Markdown conversion will only remove one of them.

Katherine


Hi, Katherine.

This no longer seems to work in the current version of Scrivener. Do you know if this a deliberate change, or if there is a way to make it work with the newest build?

Thanks in advance.

Slàinte mhòr.

User avatar
kewms
Posts: 5388
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Thu Apr 04, 2019 4:39 pm Post

See rdale's discussion, above, of the quirks of this method. -- Katherine
Scrivener Support Team

Jo
JoRo
Posts: 828
Joined: Sat May 26, 2018 6:40 am
Platform: Mac

Fri Apr 05, 2019 7:01 am Post

Thanks, Katherine. I was hoping there is a way to get the simple replacements to work. Robert's solution is somewhat different.

Robert, appreciate you're unlikely to have time to read and reply for a while, but if you ever do, in the sample file attached, Scenes compile as Section Text, styled by a format called Body. I have added paragraph returns in the "Paragraph prefix/suffix" boxes, which are clear in the "Assign Section Layouts" window of compile. However, irrespective of the number of returns I use, I cannot get replacements to convert single returns in the editor into distinct paragraphs in RTF, Word, etc. What am I missing?

Thanks in advance.

Slàinte mhòr.

MMD.zip
(82.94 KiB) Downloaded 32 times