Formatting issues when importing documents

St
Stellaria
Posts: 2
Joined: Wed Oct 08, 2014 6:55 pm
Platform: Windows

Wed Oct 08, 2014 7:24 pm Post

When I import documents created in MS Word (Office 365 version) to my Scrivener project, for some odd reason the files get imported with a very wide margin on the right (6.5 inches). I tried saving the MS document as .rtf file prior to importing and it still does the same thing. Pasting the text from the clipboard does the same thing. The margins in word are set at normal (1"), so why does it do 6.5" margin when I import? Thanks.

User avatar
MimeticMouton
Posts: 8680
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Oct 15, 2014 5:44 am Post

What you're seeing is the right-indent. In Word it's just wrapping at the right margin, but however Word is handling this in the RTF, it ends up coming into Scrivener as a set indent. The simplest way to fix it and any other ruler formatting is to selected the imported document and choose Documents > Convert > Formatting to Default Text Style. You can set your default formatting first in the Editor tab of Tools > Options... using the format bar and ruler to adjust the sample text and the blue A button to access the font options. The new defaults will apply to all new documents you create (in any project) and to any you run the Convert command on.

Within Scrivener's editor, you can adjust the indents for a selected paragraph by dragging the markers on the ruler (Format > Ruler).
Jennifer Hughes
(MM for short)

User avatar
EmmaD
Posts: 8
Joined: Sat Jun 02, 2012 4:20 pm
Platform: Windows
Contact:

Sun Oct 04, 2015 3:28 pm Post

I have this problem too: if I copy-and-paste a chunk of a Word (OFfice 365) document then

a) the word-wrap doesn't carry over, so correcting the "right indent" doesn't make any difference: I have to delete all the line-endings manually, so Scrivener can do the wrapping

b) Scrivener won't allow me to change the properties of a paragraph, for example, when I want a first-line indent. I have tried every way I know via "Format > Text > Spacing" (selecting the whole section; or doing paragraph by paragraph; or avoiding selecting the beginning and end of a paragraph.) But the section remains un-indented, even when the dialogue is showing, for example, 1.27 cm in the "first line" box.

c) if I copy-and-paste via Notepad, it strips out all formatting and then I do get the default Scrivener formatting that I've set up. But that only works if I've remembered the problem before I started. If I've forgotten, and first tried to copy-and-paste straight from the Word document into the Scrivener document, then even if I cut that one and re-paste via Notepad, the old, wrap-resistant, editing-resistant formatting seems to linger. I can cut this messed-up Scrivener document if it's a standalone with this text, but not if I'm pasting into a document which has other text in it.

d) stripping out all formatting is sometimes a disaster, as my original text has italics and other formatting stuff which I have to preserve: putting those back in fully and accurately is a pain.

I'm usually not bringing in whole documents, but lots of bits from different Word documents, so doing it as an import and convert of a file doesn't work.

This problem is driving me nearly mad. I've even found myself advising friends and students that it's a real drawback for using Scrivener for projects which involve taking text from elsewhere. That's a shame, as I'm a huge fan of Scrivener and up until now have always preached how endlessly adaptable it is to any long-form project. Not any more.

Ah
Ahab
Posts: 758
Joined: Sun Oct 01, 2006 8:00 pm
Location: Maine

Sun Oct 04, 2015 6:37 pm Post

Can't you just paste in the text using Edit, Paste and Match Style? For me, that turns everything into a replica of the previous paragraphs in the document.

User avatar
xiamenese
Posts: 3961
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Sun Oct 04, 2015 9:24 pm Post

Ahab wrote:Can't you just paste in the text using Edit, Paste and Match Style? For me, that turns everything into a replica of the previous paragraphs in the document.

But that will lose any italics and bold, which the OP wants to keep.

The answer is to import it and then use ' Document > Convert > Convert Formatting to Default Text Style' which will preserve the italics and bolds. Just create a shortcut for it — I assume you can in Windows — and it's dead easy/

HTH

Mr X
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.14.5, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.3.1, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

St
Stacey Ng
Posts: 11
Joined: Wed Dec 19, 2018 12:28 pm
Platform: Windows

Fri Apr 26, 2019 6:11 pm Post

Hi,

I have a similar issue here with a very wide margin in my imported doc which is very frustrating. I am using Scrivener Mac version, so some of the above instructions don't apply. How can I ensure that the format is exactly the same as in original doc?

Many thanks,
Stacey

St
Stacey Ng
Posts: 11
Joined: Wed Dec 19, 2018 12:28 pm
Platform: Windows

Fri Apr 26, 2019 6:13 pm Post

There is also another question which is while I type in a new section, it is already indented and does not start on the far edge of the page. Is there a way to sort this out too?

Cheers!

User avatar
xiamenese
Posts: 3961
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Fri Apr 26, 2019 6:57 pm Post

Stacey Ng wrote:Hi,

I have a similar issue here with a very wide margin in my imported doc which is very frustrating. I am using Scrivener Mac version, so some of the above instructions don't apply. How can I ensure that the format is exactly the same as in original doc?

Many thanks,
Stacey

Stacey, welcome. According to the information on the left, you are on Windows … I think you've moved across to the Mac, though.

Can you explain what you mean by a "very wide margin" in your imported doc. A screenshot would help.

Stacey Ng wrote:There is also another question which is while I type in a new section, it is already indented and does not start on the far edge of the page. Is there a way to sort this out too?

Obviously, the default text style set in Scrivener has a first-line indent—I presume that's what you mean by "does not start on the far edge of the page"—so you will need to change that in Scrivener > Preferences… > Editing : Formatting pane. If you are only concerned about first paragraphs not having an indent, my advice is to try to ignore it as that is easily set in the Compile dialog when you reach that point.

And just as a point of reference, I see you have six posts, which suggests you are new to Scrivener. If so, without any intention to be patronising, have you done the interactive tutorial you find under the Help menu or on the start-up screen? If not, I sincerely recommend you do so. Otherwise keep posting (in the Mac forum? ;) ) and people will try to help.

:)

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.14.5, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.3.1, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

St
Stacey Ng
Posts: 11
Joined: Wed Dec 19, 2018 12:28 pm
Platform: Windows

Fri Apr 26, 2019 8:17 pm Post

Hi,

Thanks I managed to find the solution. I meant wide margins, it appears you can do this on Appearance.

Yes I am using Mac, I bought this version today but doesn't seem to register on my profile. I wasn't aware there was windows and Mac forums. Sure I will have a look at the tutorial videos.

Stacey

User avatar
xiamenese
Posts: 3961
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Sat Apr 27, 2019 12:09 pm Post

Stacey Ng wrote:Hi,

Thanks I managed to find the solution. I meant wide margins, it appears you can do this on Appearance.

Yes I am using Mac, I bought this version today but doesn't seem to register on my profile. I wasn't aware there was windows and Mac forums. Sure I will have a look at the tutorial videos.

Stacey

Hi! It wasn't the tutorial videos that I meant, it's the interactive tutorial, which is basically a Scrivener project that you work through, which introduces you to how it all works. To do it at one go would take an hour or so, but you don't have to do it all in one go … mind you, I suppose I ought to do it, as I started using Scrivener round the time when KB launched v. 1.0 back at the end of 2006, when there was no tutorial, so I have just learned as Scrivener developed! So there's still lots I don't know, 'cos I've never had a need for those features. But one thing I've noticed on these forums is that new users who haven't done the tutorial don't use the Scrivener terms for features, so forumites who wish to help need to ask "What do you mean by …?"

:)

Mark
The Scrivenato sometimes known as Mr X.
rMBP 13" (early 2015) 10.14.5, 8GB RAM, 512GB SSID
MBP17" (late 2011) 10.13.6, 8GB RAM, 512GB SSID
2017 iPad, iOS 12.3.1, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …