Problems with RC19 in-app updater?

Co
Collider
Posts: 92
Joined: Mon Jul 28, 2014 2:52 pm
Platform: Windows

Sat Feb 27, 2021 11:20 am Post

I ran into some difficulty updating to RC19 from within Scrivener itself -- the installer downloaded just fine, and closed Scrivener to update as per usual when prompted, but once Scrivener was closed the installer did not run. Thinking it might be an issue with my antivirus (per various other threads noting AV interference with the beta), I disabled my AV -- the installer then ran as usual, but the updated Scrivener gave a Windows error when I tried to run it and refused to open at all.

Downloading and installing the new beta manually from the forum worked just fine, so this isn't a 'game-breaking' bug, but I thought I ought to mention it since there have been noted troubles with the in-app updater before.

Ma
Mark Lamb
Posts: 7
Joined: Tue Feb 23, 2021 8:10 pm
Platform: Windows

Sat Feb 27, 2021 11:43 am Post

Agreed. See my earlier post on this and the solution I used.

sb
sbradabang
Posts: 60
Joined: Thu Aug 01, 2019 2:31 pm
Platform: Windows

Sat Feb 27, 2021 11:46 am Post

Same here. After in-app update it gave me Windows error 0xc000007b, as though .NET framework got corrupted. I downloaded the installer and launched it, without uninstalling previous version, and it went well.

Tw
Twolane
Posts: 278
Joined: Sat May 12, 2012 7:39 pm
Platform: Windows

Sat Feb 27, 2021 12:33 pm Post

Downloading the x64 version and installing overtop existing didn't work for me. Same error occurs.

Re-installed into a new Program Files directory worked for me.
Last edited by Twolane on Sat Feb 27, 2021 12:38 pm, edited 1 time in total.

sb
sbradabang
Posts: 60
Joined: Thu Aug 01, 2019 2:31 pm
Platform: Windows

Sat Feb 27, 2021 12:37 pm Post

Twolane wrote:Downloading the x64 version and installing overtop existing didn't work for me. Same error occurs.


Sometimes it works; if it doesn't you have to uninstall it manually and reinstall it.

Do
Dorothea
Posts: 151
Joined: Mon Jan 29, 2018 4:37 pm
Platform: Windows

Sat Feb 27, 2021 5:41 pm Post

the 64-bit-installer from the website didn't work for e either.
but the 32-bit-insaller. I got a warning, but then it worked nonetheless.

ma
magicmermaid
Posts: 5
Joined: Sun Jan 12, 2020 11:27 pm
Platform: Windows

Sat Feb 27, 2021 5:43 pm Post

I have the same problem!!!! My paper is due and it is stuck in Scrivener! This is a problem. I am in graduate school and the deadline looms!!! Please Please Please resolve this!
Attachments
SCRIVNER UPDATE PROBLEM_Windows.png
SCRIVNER UPDATE PROBLEM_Windows.png (25.83 KiB) Viewed 327 times

ma
magicmermaid
Posts: 5
Joined: Sun Jan 12, 2020 11:27 pm
Platform: Windows

Sat Feb 27, 2021 6:06 pm Post

magicmermaid wrote:I have the same problem!!!! My paper is due and it is stuck in Scrivener! This is a problem. I am in graduate school and the deadline looms!!! Please Please Please resolve this!


Uninstalling and Reinstalling worked!
Thank you for posting the solution. :)

User avatar
MimeticMouton
Posts: 9042
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Feb 27, 2021 6:50 pm Post

The autoupdate process has been fixed now as well.
Jennifer Hughes
(MM for short)

MG
MG Martin
Posts: 11
Joined: Fri Jan 31, 2020 11:50 pm
Platform: Mac, Win + Linux

Sat Feb 27, 2021 7:53 pm Post

The in-app installer worked fine for me. I'm running Win 10 Home 2004 version with all the updates (blah)

User avatar
devinganger
Posts: 2649
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272
Contact:

Sat Feb 27, 2021 8:42 pm Post

MG Martin wrote:The in-app installer worked fine for me. I'm running Win 10 Home 2004 version with all the updates (blah)


You, like me, probably ran the auto-updater *after* L&L sorted out the swapped files.
--
Devin L. Ganger
Not a L&L employee; opinions are those of my cat
Life has a way of moving you past wants and hopes -- Kevin Flynn

Ru
RuffPub
Posts: 154
Joined: Fri Oct 09, 2020 1:51 am
Platform: Mac + Windows

Sat Feb 27, 2021 8:57 pm Post

devinganger wrote:
MG Martin wrote:The in-app installer worked fine for me. I'm running Win 10 Home 2004 version with all the updates (blah)


You, like me, probably ran the auto-updater *after* L&L sorted out the swapped files.


This is one of those occasions where being too lazy to get out of bed and go downstairs and boot Win saved me the hassle. :)