[SOLVED] Please, test “Check for Updates” in RC17

Si
SimWriter
Posts: 24
Joined: Tue Nov 28, 2017 12:00 pm
Platform: Windows

Wed Feb 10, 2021 3:08 pm Post

For Tiho, The latest crash was at 15:03. Scrivener started with Automatically Check for Updated enabled. Closed after about 12 seconds.

Unable to add the logs/dumps to this message - I get invalid file extension errors. Emailling them to you.

Simon

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Wed Feb 10, 2021 3:58 pm Post

I installed over the RC16 version. When I checked for updates it quit, like it had been previously. I will be doing an uninstall/reinstall later to see if that helps.

Sorry, in the middle of my work day, so I can't dedicate tons of time yet ;)

ph
philjaq
Posts: 149
Joined: Tue Dec 22, 2015 7:07 pm
Platform: Linux + Windows

Wed Feb 10, 2021 4:33 pm Post

pcgeekesq wrote:Tested, worked fine.

+1

User avatar
krastev
Posts: 591
Joined: Fri Feb 05, 2016 5:21 am
Platform: Windows
Contact:

Wed Feb 10, 2021 4:45 pm Post

Works fine for me.
Krastev
Windows 10 Home 64-bit
Scrivener for Windows Version 1.9.16.0
Testing Scrivener Beta for Windows

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Wed Feb 10, 2021 5:14 pm Post

I did an uninstall/reinstall and it's stopping before I get too far. Maybe a bit longer than the last versions where it was first noticed.

That said, I'm going to do another unisntall and use CCleaner to clean up any extra stuff first. Just in case there is a setting somewhere that is causing problems.

User avatar
tiho_d
Posts: 1542
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Feb 10, 2021 5:25 pm Post

I hope none of you experiencing the crash in a virtual machine. If you use a virtual machine "rwfranz" found a fix for his crashing virtual machine:

rwfrantz wrote:"Turning off "nested paging" in the Virtual Machine appears to stop it."
From this thread: viewtopic.php?f=57&t=65181

User avatar
tiho_d
Posts: 1542
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Feb 10, 2021 5:27 pm Post

@the guys having the crash: The very important info is probably your network configuration. Is there anything unusual? What kind of network and Internet connection do you use?

Si
SimWriter
Posts: 24
Joined: Tue Nov 28, 2017 12:00 pm
Platform: Windows

Wed Feb 10, 2021 6:00 pm Post

Tiho

You're going to have to be more specific about the network information you need. As far as I know there is nothing unusual about my connection. My Isp is Zen Internet and I only use an ethernet connection to my router.

In software terms, I guess these security programs could have a bearing: Malwarebytes and F-Secure Internet Security. The only other oddity is that I have NORDVPN installed but that shouldn't come into play.

Scrivener is installed on my C:Drive so ther shouldn't be an issue with the networked drives I use for data storage.

Let me know what, if any, specific Network information you need.

Simon

User avatar
Jestar
Posts: 411
Joined: Sun Feb 19, 2017 6:51 pm
Platform: Mac + Windows

Wed Feb 10, 2021 6:52 pm Post

Still works properly for me. Then again, I never had the problem.
Win 10 Ent. 64-Bit 20H2
Intel Core i7-2600 @ 3,4 GHz (Quadcore) 32 GB RAM
Samsung SSD 860 EVO 500GB
NVIDIA Quadro K600
Scrivener Version: Version: 1.9.16.0 - 14 Nov 2019 & Version: 3.0.0.0 (1238528) 64-bit - 23 Mar 2021

User avatar
devinganger
Posts: 2654
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272
Contact:

Wed Feb 10, 2021 9:56 pm Post

SimWriter wrote:In software terms, I guess these security programs could have a bearing: Malwarebytes and F-Secure Internet Security. The only other oddity is that I have NORDVPN installed but that shouldn't come into play.


It's probably a good idea to disable all of your additional software that could be affecting your network connection (VPN, firewall, Internet security, etc.) and give it a try again after letting the connection settle down. If you get the crash, you've eliminated those programs as being part of the issue.

If you don't get the crash, then turn them all back on one at a time.

From my professional experience, F-Secure is the most likely candidate to cause interference, followed by your VPN. Both of those types of software can place transparent proxies in the network path that can have all sorts of unintended side effects, and Internet security suites are notorious for hooking into the network stack and other active processes in undocumented ways.
--
Devin L. Ganger
Not a L&L employee; opinions are those of my cat
Life has a way of moving you past wants and hopes -- Kevin Flynn

An
AndrewHarvey
Posts: 73
Joined: Sun Apr 20, 2014 1:14 am
Platform: Windows

Thu Feb 11, 2021 3:12 am Post

No problems on my computer

A Lenovo All-in-one, Windows 10 64 bit Professional , 20H2 19042.804

No VPN, and I'm using Avast Premium Security
Writer and Publisher of SF & Fantasy
Platforms: Windows and Android
http://www.haguepublishing.com
http://www.andrewjharvey.com

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Thu Feb 11, 2021 4:17 am Post

After another uninstall and cleaning things up with CCleaner, it's still quitting. That stinks. Guess it's time to turn the updates back off.

User avatar
kalidasa
Posts: 35
Joined: Mon Nov 01, 2010 11:19 pm
Platform: Windows
Location: Wollongong, NSW, Australia
Contact:

Thu Feb 11, 2021 5:21 am Post

Working as intended for me. Running the 64-bit version in Windows 10 on a Lenovo IdeaPad S540.

Ru
RuffPub
Posts: 154
Joined: Fri Oct 09, 2020 1:51 am
Platform: Mac + Windows

Thu Feb 11, 2021 6:57 am Post

Crashing here. Crashed at 15, worked fine at 16, crashing 17. One crash even took Windows down.

Win 10 running under Parallels in MBP.

Si
SimWriter
Posts: 24
Joined: Tue Nov 28, 2017 12:00 pm
Platform: Windows

Thu Feb 11, 2021 10:16 am Post

Devin,

I have tried turning security features off previously without it making any difference. I'm not sure I tried without NORDVPN, though. So, I will try again at some point today. I think need to be in the mood.

But that still raises some questions:

1. What made this start happening? My security set up hasn't changed in a couple of years.It only started around RC13 back in the Autumn.

2. I can understand a security app blocking a connection but I'm struggling to see why that should crash Scrivener

3. None of the other many programs I use have a problem.

I'll let people know how I get on with the security turn off.

Have a good day

Simon