RC12 bad_alloc error when attempting to change font using pull down menu.

User avatar
Posts: 46
Joined: Sat Jul 05, 2014 2:31 am
Platform: Linux
Location: Everett, WA

Tue Dec 01, 2020 6:10 am Post

This error [std::bad_alloc bad array new length] now pops up when I try to change the font of a selected portion of text in the editor using the pull-down menu. When I then go through Format | Font | Show Fonts menu or using F4 I am able to without issue.

Since I don't have a box to test this under Windows, I do not know if this is repeatable or is only an issue running on Linux under Codeweaver's CrossOver. I have not experienced this error in any of the previous Beta versions.
Select Font.png
Select Font.png (29.17 KiB) Viewed 113 times
Error.png (9.08 KiB) Viewed 113 times
Fedora 33
CrossOver Version 20.0.4
Scrivener Version: 64-bit

User avatar
Posts: 4695
Joined: Mon Jan 29, 2007 1:32 am
Platform: Mac
Location: London or Exeter, UK.

Tue Dec 01, 2020 1:38 pm Post

I've just had a look using RC12 under CrossOver 2.0.2 on Mac. I can change the font on a stretch of text but only in single document mode; if I'm in Scrivenings mode, neither the dropdown nor accessing the fonts panel on the Mac works at all, but I don't get a "Bad alloc" warning.

I haven't tried F4 … given that the F-keys have Mac-specific bindings, I've never bothered to work out how to use them otherwise in CrossOver.


The Scrivenato sometimes known as Mr X.
M1 MacBook Air (2021), 11.2.1, 16GB RAM, !TB SSID
iMac 27" (late 2015) 10.15.7, 24GB RAM, 512GB SSID
2017 iPad, iPadOS 14.3, 128GB, Apple Pencil
Scrivener, Scapple, Nisus Writer Pro, Bookends …

User avatar
Posts: 751
Joined: Wed Sep 22, 2010 8:34 pm
Platform: Win + iOS

Tue Dec 01, 2020 2:50 pm Post

Sounded a bit serious so I tried it on Windows, very latest 10.

No problem changing a selected text's font using the dropdown menu, so this sounds like something coming on LInux, apparently through the emulation you're using?

If I've actually recognized what to duplicate -- it's early :)