[LH4635] Search function issues in RC8

ha
hannahsalvi
Posts: 3
Joined: Mon Apr 27, 2020 1:46 pm
Platform: Win + iOS

Mon Jul 13, 2020 4:09 pm Post

I've encountered two issues so far with the global search function in RC8, detailed below:

1.
Issue: After entering a search term, the first item clicked on in the Binder does not appear in the Editor. To get around this, you have to select another document in the Binder, and then click back on the document you want to open.
Reproduction:
1, Click on the Search icon in the Toolbar and enter a search term into the Search Bar
2. Click on any search result in the Binder
Expected behavior: The item should appear in the selected Editor window.
Actual behavior: Nothing happens - the Editor remains on the previously open document.

2.
Issue: After entering a search term, right clicking on any of the Search results in the Binder opens the menu for the document located two documents below the one that was clicked on
Reproduction:
1, Click on the Search icon in the Toolbar and enter a search term into the Search Bar
2. Right click a document in the Binder to bring up the context menu (for example, to Reveal in Binder)
Expected behavior: The context menu should appear for the document that was clicked on
Actual behavior: The context menu opens for the document two documents below the one selected

User avatar
krastev
Posts: 591
Joined: Fri Feb 05, 2016 5:21 am
Platform: Windows
Contact:

Mon Jul 13, 2020 6:26 pm Post

I can reproduce both issues.
Krastev
Windows 10 Home 64-bit
Scrivener for Windows Version 1.9.16.0
Testing Scrivener Beta for Windows

User avatar
LAP
Posts: 1033
Joined: Tue Sep 21, 2010 5:25 pm
Platform: Windows
Location: Sydney
Contact:

Wed Jul 15, 2020 9:28 am Post

Both have been fixed and will be available in next release - RC9. Thank you for reporting these.