Compile issues

fa
fadedwave
Posts: 73
Joined: Sun Nov 14, 2010 5:13 pm
Platform: Windows

Mon May 25, 2020 6:01 pm Post

I just tried compiling my manuscript as a docx file in the latest Scrivener beta, and am facing several problems.

1, As you'll see in the screenshot, it added # in several lines to my title page, which was based on the novel template. It also put my title page in double spacing.

2. Compile failed to put a page break after the Part number, even though this is how I have it in the settings (I started with the Manuscript (Times) default and copied it to tweak a couple settings, but this also happened when I used an unmodified version of Manuscript (Times) .

3. One of the modifications I made was to use * * * * * instead of # between text sections within a chapter, but this setting does not appear to have applied in the compile.

4. The title of my book (Utopia PR) in the header on all pages is missing a space between Utopia and PR. I checked the compile settings and there is a space.

Annotation 2020-05-25 134827.jpg
Annotation 2020-05-25 134827.jpg (71.21 KiB) Viewed 235 times


Are there some settings I have wrong that I should take a look at? Or are some/all of these bugs in the beta?
Western Redemption in Dystopian America
Read The Wanderer and the New West by Adam Bender

fa
fadedwave
Posts: 73
Joined: Sun Nov 14, 2010 5:13 pm
Platform: Windows

Mon May 25, 2020 6:10 pm Post

After playing around some more, I managed to fix the problem 1 regarding the title page. I didn't realize that I would have to create a separate section style called title page in project settings, and then assign that as "as-is" in Compile. Is there a way to make this more user-friendly? If a template is including a title page, shouldn't this all happen automatically?

Changing my style for parts to as-is also seems to work better than choosing part number. That gets me the page break.
Western Redemption in Dystopian America
Read The Wanderer and the New West by Adam Bender

rw
rwfranz
Posts: 903
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Tue May 26, 2020 11:30 am Post

fadedwave wrote:After playing around some more, I managed to fix the problem 1 regarding the title page. I didn't realize that I would have to create a separate section style called title page in project settings, and then assign that as "as-is" in Compile. Is there a way to make this more user-friendly? If a template is including a title page, shouldn't this all happen automatically?

Changing my style for parts to as-is also seems to work better than choosing part number. That gets me the page break.

You can fix all this without resorting to as-is. I think. You may want to create a new section type and section layout just for your Title Page (I certainly would), and possibly a new text style for it.

1. To get rid of those obnoxious # signs in your blank page, you need to alter a setting.
In Compile Settings (Ctrl+shift+E, or File / Compile), double click on the profile you wish to alter.
In Separators, choose the Title page layout (whatever it is), find the "Blank line separator" which by default is #.
Delete that.
If you want to have that present on all pages but the title page, then leave the other layouts alone. However, you might wish them to all disappear, in which case, choose the other layouts one at a time and do the same thing.

The Manuscript compile profile assumes double spacing everywhere. This can be altered in two ways.

a, if your Title page is EXACTLY the way you want it, then in the "Section Layouts" section of your profile, select the Layout you assigned to your title page. In my case, Title Page (you can create new layouts in Separators or in Section Layouts). At the bottom of the dialog, in the Formatting tab, should be a checkbox titled "Override text and notes formatting." It's checked by default. Uncheck that.

b, if you want compile to override most formatting, create a new Style for the text on the title page, and apply that style to the entire page. Then, in your compile profile, select Styles, and select your new style in the results.
The bottom half of the page will show your style. Over on the right side of that portion of the dialog box is a number with a drop down arrow. Click the dropdown arrow, and select 1.0x.

2. To make sure your Part has a page break after it as well as before it -- we had some trouble with this earlier in the Beta. Make sure, in Separators, that you've got those set. Make sure, in Section Layouts, that the checkbox in the Title column is checked for that layout. You may want to make sure that "Override..." box is checked (or unchecked, perhaps) in Section Layouts / Formatting (bottom of the page). This may be still buggy, and if this does not work, please report it.

3. To assign a working section separator: In the Assign Layout portion of the first Compile dialog, assign your Text sections to a section layout (I assigned my "Scene" type to Section Text). Double click your profile.
Select Separators. Select the layout (in my case, Section Text) where you want that "* * * * *" separator between text sections (I'm assuming you want them between project pieces such as documents or scenes. Otherwise, this becomes a bit more difficult). Change the "Separator between sections" and enter your custom separator. At the bottom of that dialog, it should have a button to specifiy the font for custom separators. This should work (I selected a font of 36 points to make sure I saw them, and tested this just now).

Now, if you want that separator between different text sections of single document, that's more difficult. They should be separated by at least 2 blank lines, and you'll need to create a blank line separator other than the default.

4. When I use a space, it's present. However, Scrivener uses the Abbreviated Title (click your project profile, and in the 2nd tab of the 3rd section of the dialog box, you'll see the compile metadata) in the header, and if you leave the Abbreviated Title out of the compile data, it defaults to the Project filename. That was unexpected, honestly. I expected it to default to the Title in the compile metadata. This may be a bug, or it might be intentional. Not sure.

==

Now, as to why Scrivener doesn't do all the setting stuff automagically -- it could, certainly. However, the way you want them might not be the way George or Mary or Sally wants them. So the devs created a "reasonable default" (or what's considered a reasonable default, anyway), that most publishers will accept.

Whew. Hope that helps. The Compile settings section is complex, and some settings affect other settings, and some settings (like line spacing defaults in some profiles) are not easily alterable. I think it's the least user-friendly part of Scrivener, and its functions are difficult to understand at times. Some of the most useful things are squirreled away in corners you wouldn't expect.
Just another user.

fa
fadedwave
Posts: 73
Joined: Sun Nov 14, 2010 5:13 pm
Platform: Windows

Tue May 26, 2020 1:17 pm Post

Wow, that totally worked. Thank you so much for the comprehensive walk through! Just some feedback for the developers in response to your fixes:

1. To get rid of those obnoxious # signs in your blank page, you need to alter a setting.

I feel like the default should be NOT putting # signs in blank spaces, and then if the user wants that they can turn it on. However, maybe there is a use case I'm not thinking about.


2. To make sure your Part has a page break after it as well as before it -- we had some trouble with this earlier in the Beta. Make sure, in Separators, that you've got those set. Make sure, in Section Layouts, that the checkbox in the Title column is checked for that layout. You may want to make sure that "Override..." box is checked (or unchecked, perhaps) in Section Layouts / Formatting (bottom of the page). This may be still buggy, and if this does not work, please report it.


So, I had Title unchecked in Part Number because I just wanted to call the two parts of my book "Part One" and "Part Two" without titles, anyway. So, after reading your answer, I checked title, made sure the titles of my folder were "Part One" and "Part Two," and in compile settings I removed the prefixes (since I didn't want it to say Part One Part One). If there is a way to make this process more intuitive for this specific situation (writer does not want to name parts), that would be great.

3. To assign a working section separator: In the Assign Layout portion of the first Compile dialog, assign your Text sections to a section layout (I assigned my "Scene" type to Section Text). Double click your profile.
Select Separators. Select the layout (in my case, Section Text) where you want that "* * * * *" separator between text sections (I'm assuming you want them between project pieces such as documents or scenes. Otherwise, this becomes a bit more difficult). Change the "Separator between sections" and enter your custom separator. At the bottom of that dialog, it should have a button to specifiy the font for custom separators. This should work (I selected a font of 36 points to make sure I saw them, and tested this just now).


So where I went wrong here was that I thought I only needed to change the Default Separators. I didn't realize that section text would NOT follow the defaults by default. So, I went in and checked "Use Default Separators" for Section Text, and now it's working fine.

However, Scrivener uses the Abbreviated Title (click your project profile, and in the 2nd tab of the 3rd section of the dialog box, you'll see the compile metadata) in the header, and if you leave the Abbreviated Title out of the compile data, it defaults to the Project filename. That was unexpected, honestly. I expected it to default to the Title in the compile metadata. This may be a bug, or it might be intentional. Not sure.


That does sound like a bug to me, or at least is not intuitive. My title is very short, so I didn't think and would never have thought I needed to fill in an Abbreviated Title.

Anyway, hope my experience is helpful for future updates. These were just a few cases where I think my expectations of how the program should behave didn't line up with how it was set up. Totally understand that different users may want it different ways, and it's hard to meet everyone's expectations.
Western Redemption in Dystopian America
Read The Wanderer and the New West by Adam Bender