[JH] Missing italic

Re
RevMoose
Posts: 16
Joined: Mon Mar 30, 2020 11:35 pm
Platform: Windows

Wed May 20, 2020 8:32 pm Post

Suddenly, when I compile part of my document, it fails to italic areas where it should. Any ideas? Just started happening.

User avatar
MimeticMouton
Posts: 8824
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Thu May 21, 2020 7:38 am Post

Without additional details, it's hard to say. Did you change which compile format you're using or the section layout assignments? What file format and font are you compiling to?--it's possible the font you're using in compile doesn't have an italic variant. Is the italic added in Scrivener as part of a style?--these can be overridden during compile and ignored or changed so that what you get out may differ from what you use in the editor. Are the italics part of the editor text or is the formatting meant to be added to other elements (title, title prefix, synopsis text, etc.) during the compile precess?
Jennifer Hughes
(MM for short)

Re
RevMoose
Posts: 16
Joined: Mon Mar 30, 2020 11:35 pm
Platform: Windows

Thu May 21, 2020 3:41 pm Post

Thanks for the reply. The font is "Garamond." I have used it with no problems for over 100 pages and it has compiled flawlessly. It shows up in the editor as it should.

As a relative Scrivener newbie, I am struggling with where to go with your questions. I know you don't have the time to hold my hand as I try to figure this out, but can you be a bit more detailed in your questions/suggestions.

Dan

Re
RevMoose
Posts: 16
Joined: Mon Mar 30, 2020 11:35 pm
Platform: Windows

Thu May 21, 2020 3:45 pm Post

A further question: Where would I go to start finding out if somehow the compile format is changing things. Also, why would it suddenly start after over 100 pages? Where would I go to look for changes.

Thanks,

Dan

Re
RevMoose
Posts: 16
Joined: Mon Mar 30, 2020 11:35 pm
Platform: Windows

Thu May 21, 2020 3:54 pm Post

I am working on chasing down the answers to your questions.

In the "Compile for PDF" area, the setting is "main text formatting will be based on how text appears in the editor."

rw
rwfranz
Posts: 905
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Fri May 22, 2020 5:29 pm Post

RevMoose wrote:A further question: Where would I go to start finding out if somehow the compile format is changing things. Also, why would it suddenly start after over 100 pages? Where would I go to look for changes


Sounds a bit odd, that it changed suddenly.

Is the change on a scene boundary?

However... I would look in your Compile Settings, under Section Layouts (double click your compile profile, should be right there). Is the box "Override Text and Notes Formatting" (at the bottom of the dialog box) checked? Check this for EACH section layout. I have 3 section types, and handful of layouts, and I make sure everything is set the way I want it on each section layout, even if I expect not to be using it. Make sure it's only checked where you want the Formatting to be different in Compile. I don't remember if it's checked by default or not.

Did the section type change? That is, did it change from Group to Text or to something else? You can check this in the main Scrivener panel, if you look in the 3rd inspector tab.

Did you change from structure-based types to something else right there?

I'd expect most writers wouldn't change section types mid-project, but sometimes keyboard errors happen and chaos ensues.
Just another user.

User avatar
MimeticMouton
Posts: 8824
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed May 27, 2020 8:41 am Post

Hi Dan, apologies for the late reply and the assumptions in my initial post. rwfranz already asked a bunch of helpful questions and pointed to some of these areas in the interface, but I'll add a bit more.

First, just a quick screenshot of the main compile window for clarity. As suggested above, make sure that all your documents in the righthand side have the expected section type name and that the name there matches the intended layout in the centre pane. If some of the documents in your manuscript accidentally ended up with a different section type, they may be using a different layout (and thus different formatting rules) from the others. You can click into the section type for the document in the compile list and change it if necessary.

CompileMainWindow.png
A document's section type determines which section layout it uses.
CompileMainWindow.png (164.92 KiB) Viewed 57 times

To be sure I'm understanding the problem, are you finding now that in a single PDF compile, the initial Scrivener documents include their italics as expected but the later ones do not? So e.g. the first 100 pages of the document have the expected italics but after that they're missing, though the binder documents containing that text in the project still show italics in the main editor. Or is the issue that previously your compiled documents contained the italics and now the italics are gone from the entire compiled PDF?

I gather from your comments that this is occurring to main document text, not notes text or titles or something added during compile (like the chapter numbering could be). Is the italicised text styled?--if you click into it in the editor, does the styles list on the format bar show "No Style" or "Emphasis" or something else?

EmphasisStyle.png
The selected text is using the "Emphasis" style, which applies the italic formatting.
EmphasisStyle.png (49.53 KiB) Viewed 57 times

If some of the documents compile correctly and others are missing the italic formatting, do you notice anything different between the ones that are correct and those that are not?--different binder icons, different section types, difference in any of the editor formatting?

Finally, what compile format are you using? The compile format is what's selected in the lefthand pane of the main compile window, e.g. "Default" in the screenshot above. Is this one that you have edited?
Jennifer Hughes
(MM for short)