Beta 43 - "Session Count Timeout"?

To
Tom Lewis
Posts: 21
Joined: Mon Sep 02, 2019 3:56 pm
Platform: Windows

Thu Mar 19, 2020 4:46 pm Post

I don't know if this is a bug or not, but it's something that never happened on the previous betas. When I open a project (a conversion from Scriv 1), a message flashes briefly in a small box that says "Session Count Timeout. Session Count Reset."
Great job with all the fixes on the betas! You guys are rock stars!

User avatar
tiho_d
Posts: 1497
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Thu Mar 19, 2020 7:07 pm Post

Yes, this is new. If you have a session target fixed reset time, you should see the popup message when the targets are reset upon startup. If you do not have a session target fixed time, you should never see the message upon startup.

aj
ajbadgeriii
Posts: 15
Joined: Fri Mar 22, 2019 2:30 pm
Platform: Windows

Thu Mar 19, 2020 8:00 pm Post

Hi!

I've never set session target fixed reset time, (at least that I know of). However, it get this message now. How do I turn off the settings that are causing it?

Thanks.

User avatar
tiho_d
Posts: 1497
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Fri Mar 20, 2020 11:08 am Post

Please, check Project > Project Targets > Options > "Session Target" tab. It could be that some projects have it switched on to automatic reset at 1:00am each day. You can turn off the notifications by the check box at the bottom: "Show target notifications".

To
Tom Lewis
Posts: 21
Joined: Mon Sep 02, 2019 3:56 pm
Platform: Windows

Fri Mar 20, 2020 11:26 am Post

Thanks Tiho!

User avatar
Jestar
Posts: 382
Joined: Sun Feb 19, 2017 6:51 pm
Platform: Mac + Windows

Sat Mar 21, 2020 2:38 am Post

tiho_d wrote:Please, check Project > Project Targets > Options > "Session Target" tab. It could be that some projects have it switched on to automatic reset at 1:00am each day. You can turn off the notifications by the check box at the bottom: "Show target notifications".

Thanks, Tiho! Mine had gotten set as well but I hadn't thought of it as a bug to report - maybe I was testing session targets? Anyway, that seems to have fixed it.
Win 10 Ent. 64-Bit 20H2
Intel Core i7-2600 @ 3,4 GHz (Quadcore) 32 GB RAM
Samsung SSD 860 EVO 500GB
NVIDIA Quadro K600
Scrivener Version: Version: 1.9.16.0 - 14 Nov 2019 & Version: 2.9.9.18 Beta (1204128) 64-bit - 17 Feb 2021

aj
ajbadgeriii
Posts: 15
Joined: Fri Mar 22, 2019 2:30 pm
Platform: Windows

Thu Mar 26, 2020 1:22 pm Post

tiho_d wrote:Please, check Project > Project Targets > Options > "Session Target" tab. It could be that some projects have it switched on to automatic reset at 1:00am each day. You can turn off the notifications by the check box at the bottom: "Show target notifications".


This suggested fix did the trick!

Thank you!

aj
ajbadgeriii
Posts: 15
Joined: Fri Mar 22, 2019 2:30 pm
Platform: Windows

Tue Apr 21, 2020 8:26 pm Post

Hello!

Got the latest beta version.

When I enter "Compose Mode" now in Scrivener 3 for Window, my text is surrounded by a white highlight. See attachments. This happens with text files that pre-existed before I updated to this current beta version.

Any suggestions on fixing this?

rw
rwfranz
Posts: 1019
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Tue Apr 21, 2020 9:12 pm Post

ajbadgeriii wrote:Hello!

Got the latest beta version.

When I enter "Compose Mode" now in Scrivener 3 for Window, my text is surrounded by a white highlight. See attachments. This happens with text files that pre-existed before I updated to this current beta version.

Any suggestions on fixing this?

I see no attachment? A screenshot showing this would be nice, as your description is somewhat unclear.

You can change the background of the Composition mode in File > Options (F12) > Appearance > (left side menu) compostion... > (top tab bar) Colors.
Just another user.

aj
ajbadgeriii
Posts: 15
Joined: Fri Mar 22, 2019 2:30 pm
Platform: Windows

Thu Apr 23, 2020 1:18 pm Post

Thank you for the quick response. I actually figured this out.

In COMPOSE MODE, I have to select the highlighted area. Then I must right click and select "Highlight color. FInally, I select "Remove Color," and all looks find in COMPOSE MODE.

NOTE: I've never highlighted text in COMPOSE MODE, so I was a little confused what it appeared Highlighted. But now all is well.

Thanks,

rwfranz wrote:
ajbadgeriii wrote:Hello!

Got the latest beta version.

When I enter "Compose Mode" now in Scrivener 3 for Window, my text is surrounded by a white highlight. See attachments. This happens with text files that pre-existed before I updated to this current beta version.

Any suggestions on fixing this?

I see no attachment? A screenshot showing this would be nice, as your description is somewhat unclear.

You can change the background of the Composition mode in File > Options (F12) > Appearance > (left side menu) compostion... > (top tab bar) Colors.