Compile submenu windows not displaying properly

Gr
GrumpyMusketeer
Posts: 6
Joined: Mon Dec 30, 2019 5:38 pm
Platform: Windows

Tue Dec 31, 2019 3:36 am Post

Using dark mode in 32 beta. Continuing issue from previous betas.

Steps taken:
1. Click on Compile.
2, Click on gear icon in the bottom left and select "Edit Format"

Issue:
1. The pop up sub-menu does not appear in full. Because of this, I cannot select the "Okay" or "Cancel" menus at the bottom. The only way to exit the screen is to press the "Escape" key on the keyboard.
2. The window cannot be resized to display the options at the bottom.
3. A workaround is to use two screens and drag the window from one screen to another but this is cumbersome.

Do
Dorothea
Posts: 114
Joined: Mon Jan 29, 2018 4:37 pm
Platform: Windows

Wed Jan 08, 2020 1:13 pm Post

*sigh
We have this bug since five orsix versions or so.
We already discussed it at lengths, but they just don't file it.
I've run out of ideas, how to get themcome around and acknowledge it as a bug.

To buya second screenis certainly not the solution.

rw
rwfranz
Posts: 803
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Thu Jan 09, 2020 12:22 am Post

The best I was able to do was to reduce the "Menus and Windows" font (which worked for me on my own laptop, which has a 1366x768 screen). This reduced the height of the compile window just a little. But for some people, this did not work. I'm not sure why.

Workaround the 1st: rotate your display 90 degrees, tell windows that, restart scrivener, and navigate through the screens that way. Kind of sucks as a workaround.

Workaround the 2nd: Both AMD (ATI) and Nvidia have Superresolution available. (reference https://superuser.com/questions/15140/i ... an-the-max). This means you may be able to use more resolution than you have available. This may not work with many laptops. I think Intel has something similar, but it may not work on older computers. I just enabled this, and Windows Display shows larger resolutions available than my screen normally allows. (another reference: https://github.com/Ilyaki/TerrariaSplit ... /(Optional)-Setting-up-a-virtual-super-resolution).

Do
Dorothea
Posts: 114
Joined: Mon Jan 29, 2018 4:37 pm
Platform: Windows

Sun Jan 19, 2020 10:55 am Post

Rotate the screen? *lol*
i could install it on my Windowstablet then.There the display rotates autoamtically, when I hold it accordingly ...

but at the moment - BETA 34 that is - this submenu window doesn't open at all for me.
Whether i click on "edit" or double--click on the section layout. Oh well ..
.
Anyway that's no proper behaviour and should be fixed.

User avatar
tiho_d
Posts: 975
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Sun Jan 19, 2020 2:23 pm Post

As we have discussed previously the display must support the minimum recommended screen resolution 1080 px at 100% scaling. We cannot match the full compile dialog size and settings on a tablet size screens.We might search for optimizations here, but not in the first official release.
The recommended vertical resolution is one more time 1080px at 100% scaling. If you use 150% scaling you end up with 720pts, which is not enough and we do not have the resources to deal with this at the moment. Scrivener is designed as a desktop application not for pocket size PCs/tablets which are quite popular among many. Scrivener for Mac also does not run properly on a 720pts display either.

Reducing the Scrivener menu & windows font size is probably the best workaround at the moment if you have this problem. You can also reduce the scaling of your current monitor or use a bigger monitor. You should not expect miracles buying a small monitor to fit big windows with large fonts, because your eyes hurt using small fonts. If your eyes hurt with small fonts, avoid buying low resolution and small screens.

We are aware of the issue, and this has been discussed multiple times in the forum under different threads.