Formatting error when editing with ProWritingAid

Gr
GrumpyMusketeer
Posts: 6
Joined: Mon Dec 30, 2019 5:38 pm
Platform: Windows

Tue Dec 31, 2019 3:25 am Post

Setting in Scrivener: all new paragraphs start with an indent.
Problem: Paragraph indenting is off when:
1. Opening a Scrivener File with ProWritingAid desktop app
2. Making an edit (e.g., break a paragraph into two)
3. Saving the work and going back to Scrivener

Issue: The new paragraph starts without an indent on Scrivener.

User avatar
kewms
Posts: 5708
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Tue Dec 31, 2019 4:53 am Post

I think this would be the expected behavior: if ProWriting Aid (or any other third-party editor) doesn't insert the indent, Scrivener's going to assume it's not wanted.

Katherine
Scrivener Support Team

Gr
GrumpyMusketeer
Posts: 6
Joined: Mon Dec 30, 2019 5:38 pm
Platform: Windows

Wed Jan 01, 2020 3:39 am Post

If I understand from your reply, this problem has nothing to do with Scrivener and only with ProWritingAid.

As a customer, this is annoying. I spent $120 on PWA mainly because it claimed to work "seamlessly" with Scrivener. However, there's minor but frustrating issues with things such as indenting, smart quotes, and apostrophes not recognized properly across the two softwares. And their customer support is non-existent.

If Scrivener is in no way involved with PWA, I would advise Scrivener to look at the claims they make regarding their compatibility with Scrivener. You don't want other companies selling a product priced three or four times than Scrivener with explicit, false claims of compatibility and seamlessness.

User avatar
kewms
Posts: 5708
Joined: Fri Feb 02, 2007 5:22 pm
Platform: Mac

Wed Jan 01, 2020 4:18 am Post

There is no connection between Literature & Latte and ProWriting Aid.

From our point of view, Scrivener itself is the only supported tool for making changes to Scrivener projects. Changes made by other programs are entirely the responsibility of that program.

I'm sorry you had a poor experience with their product.

Katherine
Scrivener Support Team

wo
wordjoy
Posts: 81
Joined: Mon Jun 11, 2018 3:26 am
Platform: Windows

Wed Jan 01, 2020 9:56 pm Post

I use Pro-Writing Aid
Use their feedback tools.
This may be related to what kind of line break is being inserted etc.

But Remember:
All of Pro-Writing Aid's claims are likely against released vs beta versions of Scrivner.

It is not L&L job to validate other company's claims as they do not have an official "Works with program" you as the buyer have to research. and deal with the other company

wo
wordjoy
Posts: 81
Joined: Mon Jun 11, 2018 3:26 am
Platform: Windows

Thu Jan 02, 2020 2:48 am Post

I did some tests.
It's a ProWirttingAid bug and a pretty serious one.

When pressing Enter it displays it like a NEW PARAGRAPH with larger line spacing, but saves it as a NEW LINE.
When you press Shift-Enter and it shows line a NEW LINE with a narrower line spacing, then saves it as a NEW LINE also.
When I turn on Invisibles in Scrivner and look at the saved all then line breaks as NEW LINES.

And If I save and close the file in ProWritingAid and then reopen, without ever opening in Scivner all the line spaces is the same. So it clearly saved all the line breaks the same way.

So as it relates to New Line and New Paragraph. ProWrittingAid is broken. That is why the start of paragraph indents don't show.

Gr
GrumpyMusketeer
Posts: 6
Joined: Mon Dec 30, 2019 5:38 pm
Platform: Windows

Thu Jan 02, 2020 8:44 am Post

Thanks WORDJOY for looking into the problem.

As other people might be thinking of buying PWA for the sole purpose of working with Scrivener, I will start a thread elsewhere cautioning people about such issues.

Since it appears that this is not a problem on L&L's side and definitely not a Scrivener bug, please feel free to remove the post from this forum.

wo
wordjoy
Posts: 81
Joined: Mon Jun 11, 2018 3:26 am
Platform: Windows

Thu Jan 02, 2020 5:55 pm Post

GrumpyMusketeer wrote:Thanks WORDJOY for looking into the problem.

As other people might be thinking of buying PWA for the sole purpose of working with Scrivener, I will start a thread elsewhere cautioning people about such issues.

Since it appears that this is not a problem on L&L's side and definitely not a Scrivener bug, please feel free to remove the post from this forum.



Report the bug on their site. I have. The more reports the more likely it will get fixed. That is how today's cloud-sourced testing works.

User avatar
narrsd
Posts: 701
Joined: Wed Sep 22, 2010 8:34 pm
Platform: Win + iOS

Fri Jan 03, 2020 11:11 pm Post

GrumpyMusketeer wrote:As other people might be thinking of buying PWA for the sole purpose of working with Scrivener, I will start a thread elsewhere cautioning people about such issues.


Well, as others have suggested, much the best to report to ProWritingAid Support that you and others are trying the BETA of Scrivener 3, and finding issues.

I had a look and there appear to be more than you've noticed yet.

For the time being, you can still use PWA effectively with the Scrivener beta. Just copy-paste text blocks between the two.

Your downside will be that inline formatting like italics or bold will get lost, though with thoughtful pasting (not over the top) you can reference the original and correct that.

Once PWA gets used to the upgraded file arrangements in Scrivener, then you'll get the full integration, including the handy binder-selection back. And so will all the rest of us who use PWA for its merits.

ad
adrm
Posts: 114
Joined: Sun Dec 02, 2018 11:58 am
Platform: Windows

Tue Mar 17, 2020 4:52 pm Post

For those who use ProWritingAid.

I've communicated with them about this issue for months now, and as far as I can tell, they have finally resolved the issue where PWA inserts a soft line break instead of an end of paragraph marker when you hit Enter.

In short, as of version 2.0.36 (released 16th of March) I'm no longer seeing the problem.

User avatar
narrsd
Posts: 701
Joined: Wed Sep 22, 2010 8:34 pm
Platform: Win + iOS

Tue Mar 17, 2020 6:13 pm Post

adrm wrote:In short, as of version 2.0.36 (released 16th of March) I'm no longer seeing the problem.


Thanks @adrm, great to hear that, as I'd just followed the update alert and installed.

Whatever I was talking about above with regard to binder selection, this is also working fine now also, including quiet safety where the selection isn't something ProWritingAid can open..

It feels fine, so good points to ProWritingAid for catching up to where we are - sent them a note via their Support..