Default Writing Font?

JR
JRanck
Posts: 8
Joined: Sat Dec 11, 2010 6:57 am
Platform: Windows

Thu Nov 21, 2019 2:17 pm Post

So I'm in the process of testing out the Beta as part of a switch from my aging MacBook pro to a new Surface since Apple has decided to totally destroy the "pro" aspect of their products and make them essentially unusable (but that's a different topic).

I opened my current WIP in the new beta and realized that the default writing font has been changed and the Format → Set Default Formatting → Formatting option seems to be disabled to make changes to the default font.

Bug? Feature of the Beta? Difference between the Windows and Mac version? Any suggestions?

To
TomGoodell
Posts: 141
Joined: Tue Nov 13, 2012 3:13 pm
Platform: Windows

Thu Nov 21, 2019 2:44 pm Post

When I tested this, I found that if I open a project in Scrivener, the option Format/Make Formatting Default is indeed grayed out. However, after I select some text it is no longer grayed out. After doing that, it stays active even if I have no text selected. Hopefully that will help. And perhaps it's a bug?

je
jeepea
Posts: 34
Joined: Tue Jan 18, 2011 5:13 am
Platform: Windows

Thu Nov 21, 2019 2:53 pm Post

I'm not a power user so there may be other ways to do this, but to change the default font I go to Options/Editing/Formatting. There you can change the default font and other formatting options.

User avatar
rdale
Posts: 2144
Joined: Tue Jul 14, 2015 1:07 pm
Platform: Mac, Win + iOS
Location: St. Louis, MO
Contact:

Thu Nov 21, 2019 3:43 pm Post

JRanck wrote:I opened my current WIP in the new beta and realized that the default writing font has been changed and the Format → Set Default Formatting → Formatting option seems to be disabled to make changes to the default font.

I'm not finding that menu at all... Are you talking about Format->Style->Set Default Formatting? The path I usually take to that window is Project->Project Settings->Formatting.

Either way you get to it, in the window that comes up, do you have "Use different formatting for new documents in this project" checked?

FYI, this area only affects the default for new documents in the current project, not in all projects. If you want this to be applied to all projects, you have to go to File->Options->Editing->Formatting.
FKA: robertdguthrie
AKA: R Dale Guthrie, Robert, Mr. Obscure, and "Oh, it's you again".

Online
User avatar
AmberV
Posts: 24793
Joined: Sun Jun 18, 2006 4:30 am
Platform: Mac + Linux
Location: Ourense, Galiza
Contact:

Thu Nov 21, 2019 3:56 pm Post

The trigger for whether the Format ▸ Make Formatting Default command is active is simply whether or not the cursor is in an area that contains formatted text (so, main editor, document notes, bookmarks preview area, etc.). The command contains two choices, both set background settings without having to go into settings yourself and setting them up.

You can read more about this topic in the user manual. Easiest thing to do when confronting a new feature is to look up the menu command in the appendix. Oftentimes, if the menu command is related to a larger topic, you will find cross-references. So if you really want to know where the settings are that this command impacts, you can look them up from there.
.:.
Ioa Petra'ka
“Whole sight, or all the rest is desolation.” —John Fowles

JR
JRanck
Posts: 8
Joined: Sat Dec 11, 2010 6:57 am
Platform: Windows

Fri Nov 22, 2019 12:24 am Post

So I just tried to reproduce what I would do when I learned Scrivener way back in the early Mac days. In those early versions, you could change the writing font through the whole project by setting the project default font (in the dialog that I pointed to, which does put you into the project formatting area) and then select documents → convert → text to default formatting.

However, unlike the old mac versions, the project default font formatting was disabled in an unexpected way. It appears that you have to either have something selected, or check the box that says "use different formatting for new documents in this project." Don't remember ever doing either of these before.

Hence the post. Perhaps it is working just like it is supposed to. Perhaps not. That was what I was trying to discern.

However, I can say that once you can get that project settings → formatting option set to the font you want, the "documents → convert → text to default formatting does indeed change all the text to the correct writing font.

rw
rwfranz
Posts: 1024
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Thu Nov 28, 2019 12:33 am Post

I'm seeing two different topics here.

The first, the font (and formatting) Scrivener uses by default for every new project, is set at File -> Options (shortcut key F12 to get here) -> Editing (tab) -> Formatting (subtab), and there is where you set your default font (click the Aa icon to select your font).

The second, the project's default font, is at Project -> Project Settings -> Formatting (about halfway down the left side of the dialog box). To enable project Formatting, click the checkbox: "Use different formatting..."
Then the formatting icons in the Main Text formatting graphic will ungrey.

Welcome to the Beta, anyway.
Just another user.