[LH4089] [BETA 26] Compile > Separators > Titled Section > Separators between sections do not work

ze
zeddd
Posts: 12
Joined: Sun Sep 29, 2019 3:42 pm
Platform: Mac + Windows

Wed Oct 23, 2019 6:17 am Post

My project binder is setup as follows.

Code: Select all

Chapter 1                  Chapter Heading            Chapter
   POV 1                  Section                  Titled Section
      Scene 1            Scene                     Section Text
      Scene 2            Scene                     Section Text
   POV 2                  Section                  Titled Section
      Scene 3            Scene                     Section Text
      Scene 4            Scene                     Section Text

Left column = Document title / Center column = Section Type / Right Column = Section Layout

I want to use a custom separator between the POV sections but not the scenes. The compiled document does not contain the expected separators.

Steps to reproduce:
  1. Setup binder according to the table above
  2. Open Compile window and select Assign Section Layouts.
  3. Verify that the POV sections are using Titled Section layout and Scenes are using Section Text Layout.
  4. When done select format type Paperback or Manuscript (Others may have issues but I haven't tested them) and double click to edit.
  5. Select Separators in the navigation window > Select Section Text > in the area titled Separator Between Sections set it to Empty Line or Single Return
  6. Select Titled Section > In the area titled Separator Between Sections set it to Custom and enter "###" without quotes.
  7. Select Save
  8. Select Compile

Expected Behavior:
When the document is compiled a separator is expected between the POV sections but none is displayed. It appears that they only work correctly for the Section Layout titled "Section Text."

rw
rwfranz
Posts: 799
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Wed Oct 23, 2019 7:26 am Post

Change the separator before the layout, not between the layouts.

ze
zeddd
Posts: 12
Joined: Sun Sep 29, 2019 3:42 pm
Platform: Mac + Windows

Wed Oct 23, 2019 3:11 pm Post

rwfranz wrote:Change the separator before the layout, not between the layouts.


Correct me if I'm wrong, but wouldn't that put a separator before the first POV section? i.e. at the start of the chapter. That's definitely not the behavior I'm looking for.

Edit:
Just tested this and can confirm that is exactly how it functions. i.e. it puts a separator at the start of the chapter.

I should note that all my writing is done at the scene level. Putting text at the Chapter level would alleviate this but that's not how I prefer to use Scrivener.

User avatar
tiho_d
Posts: 965
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Oct 23, 2019 8:02 pm Post

In Beta 26 there is a bug, that if the Section Layout does not insert Title, Metadata, Synopsis, Notes or Text the Headings were also not inserted and the document is indeed not compiled. Because of this the Separators are also broken. To workaround the bug, try to include the Title for example for your Section Layout.

This has been fixed and will be available in the next update, within the next few days.

Do
Don deCerveza
Posts: 1
Joined: Tue Jan 14, 2020 12:19 am
Platform: Windows

Tue Jan 14, 2020 12:22 am Post

Has this been resolved?
Metadata, Synopsis and notes do not compile when checked.

Are there no longer label or status placeholders?