[LH4050][LH4233] Continued problems with Lists / Bullets - moving up/down and changing indent [RC1]

ka
kagard
Posts: 4
Joined: Wed Aug 07, 2019 3:33 pm
Platform: Windows

Sat May 23, 2020 3:48 pm Post

Greetings:

Just a confirmation here regarding moving list items. Moving list items up or down (Ctrl+Alt+up/down) creates the following problems:

  • Editor positions to the top of the document.
  • A blank line is created between items after move.
  • Bullet may disappear

I'm working in Win10 (current as of today) on Intel Core i7 processor with 16GB of RAM.

Thanks,

Keith Gardner

Tr
Tridens92
Posts: 72
Joined: Tue Apr 19, 2016 5:43 pm
Platform: Windows

Tue Jun 02, 2020 3:56 pm Post

OP here, reporting back on bugs with vertical move of bullets (with CTRL-ALT-UP ARROW [DOWN ARROW]) in RC6:

SO EXCITED to see such great progress on this key feature for those of us who work in outlines, presentations, etc!

Four of the bugs I reported in an earlier post are resolved (yay!). The following List/Bullets bugs remain with RC6:

1) After using CTRL-ALT-UP ARROW [DOWN ARROW], you must manually deselect text before LEFT ARROW / RIGHT ARROW (or TAB / SHIFT-TAB) operations will work to move bullets left or right. Once text is deselected, sometimes a subsequent left or right move also requires a second keypress before Scrivener responds.

2) If you move an existing bullet vertically to the top or bottom of the window and continue moving it, the window doesn't scroll to keep the cursor visible on the screen.

3) Turning off bullets and turning them back on resets any customized bullet styles in the current list. This is an easy mistake for a user to make if, when attempting to hit the dropdown arrow on the Lists button on the toolbar, you accidentally click on the button itself. Toggling the List button off/on while in a list should respect the current bullet customization of that list.

4) Selecting more than one bullet and attempting to move (up/down, or left/right) doesn’t work. In MS Word, selecting multiple lines with bullets and then moving them will move them all, including respecting the multi-level indentation of the selected bullets.

5) Bullets will occasionally do the "cha cha" when shifting left or right with CTRL-ALT-LEFT/RIGHT. For instance, trying to shift the bullet to the right, the first press will sometimes shift it to the left, and subsequent presses will then shift it right. Maybe this is an Easter Egg? ;)

Scrivener for Windows team, my deepest thanks for giving attention to the Lists feature. It's truly going to transform my teaching and speaking in a way Scriv 1.x couldn't.

Tr
Tridens92
Posts: 72
Joined: Tue Apr 19, 2016 5:43 pm
Platform: Windows

Fri Jul 24, 2020 8:22 pm Post

Bugs update for RC8:

[*]All bugs reported in my above post on RC6 still exist in RC8
[*]NEW with RC7 and RC8- Moving bullets up and down is now flattening the multi-level structure as the seleted bullet moves through it.

Thanks for your continued work.

Tr
Tridens92
Posts: 72
Joined: Tue Apr 19, 2016 5:43 pm
Platform: Windows

Fri Aug 14, 2020 10:09 pm Post

Bugs update for RC9:

CTRL-ALT-[UP, DOWN, LEFT, or RIGHT ARROW] functionality is completely removed in RC9. I hope this is because it's being worked on and not because the feature is being removed entirely from Scrivener 3?

:shock:

bi
biblioman
Posts: 115
Joined: Sat May 26, 2018 11:08 pm
Platform: Windows

Sat Aug 15, 2020 4:18 pm Post

Tridens92 wrote:Bugs update for RC9:

CTRL-ALT-[UP, DOWN, LEFT, or RIGHT ARROW] functionality is completely removed in RC9. I hope this is because it's being worked on and not because the feature is being removed entirely from Scrivener 3?


(1) It is perfectly right thing that functionality working wrong was removed—hopefully until not later than the next release.

(2) Some minor technical problems, less notable, but seemingly connected with some persistent and more fundamental error, are still present in Lists.

If you press Enter to create a new numbered entry, and then press Ctrl+V to paste some text, and there is no any symbol in the newly created entry, i.e. the cursor is on the end-of-line position, then pasting will remove numbering. What is more, Ctrl+Z will be unable to restore the document to the previous state (i.e. the one before pasting).

Tr
Tridens92
Posts: 72
Joined: Tue Apr 19, 2016 5:43 pm
Platform: Windows

Thu Sep 17, 2020 4:48 pm Post

Bug update for RC10:

CTRL-ALT-[UP, DOWN, LEFT, or RIGHT ARROW] functionality is still completely removed in RC10, as it was in RC9.

Hoping for a resurrection of this anticipated feature for outlining/teaching/presentations.

Tr
Tridens92
Posts: 72
Joined: Tue Apr 19, 2016 5:43 pm
Platform: Windows

Sun Oct 18, 2020 3:43 pm Post

Bug update for RC11:

CTRL-ALT-[UP, DOWN, LEFT, or RIGHT ARROW] functionality is still completely removed in RC11, as it has been since the unannounced removal in RC9.

Can you tell me if this feature, so useful for presenters and teachers, has been permanently removed from Scrivener 3?

Thank you again for your time and work.

St
SteveCoombes
Posts: 19
Joined: Wed May 27, 2015 3:31 am
Platform: Windows

Tue Oct 20, 2020 12:53 am Post

I'm having a weird issue in bullet lists but only when using styles. In case it's related I'm reporting it in this thread.

Case A: No Style
Bullets work as expected.

Case B: Style Applied
When a style is applied (in my case a custom style of Calibri, Regular, 12pt), when I click the bullet toolbar button a bullet is created for the first line. After hitting Enter, the bullet disappears for the second line when I expect a new bullet should be present as is the case when using bullets in text without styles applied.

I'm using Windows 10 Home, fully updated, with Scrivener Version: 2.9.9.11 Beta (1078037) 64-bit - 14 Oct 2020

se
serabale
Posts: 14
Joined: Tue Oct 20, 2020 11:48 pm
Platform: Windows

Sun Oct 25, 2020 5:54 pm Post

SteveCoombes wrote:I'm having a weird issue in bullet lists but only when using styles. In case it's related I'm reporting it in this thread.

Case A: No Style
Bullets work as expected.

Case B: Style Applied
When a style is applied (in my case a custom style of Calibri, Regular, 12pt), when I click the bullet toolbar button a bullet is created for the first line. After hitting Enter, the bullet disappears for the second line when I expect a new bullet should be present as is the case when using bullets in text without styles applied.

I'm using Windows 10 Home, fully updated, with Scrivener Version: 2.9.9.11 Beta (1078037) 64-bit - 14 Oct 2020



The same thing happens with numbered lists.

And one more thing.

1. Made a numbered list with No style
2. Selected 3.4.5 and applied my own style. Numbers dissapiered and my list changed

Windows 10 Pro, Scrivener Version: 2.9.9.11 Beta (1078406) 64-bit - 14 окт 2020
Attachments
2020-10-25_19-54-16.png
2020-10-25_19-54-16.png (1.53 KiB) Viewed 991 times

User avatar
Scribblette
Posts: 58
Joined: Fri Jul 26, 2019 10:49 pm
Platform: Windows

Tue Dec 08, 2020 3:44 am Post

Version 2.9.9.13 on 64 bit Windows 10.

Bullets are borked again. Or still borked.

When a project is saved and re-opened it seems as if bullet placement is forgotten. New sub-items when tabbed in will be placed at the wrong level of indentation. Old or new sub-items when tabbed back will also be placed wrong. This is shown in the picture below.

buggybullets.png
buggybullets.png (13.53 KiB) Viewed 819 times


Sometimes the bullet/list icon type is forgotten altogether. I have a series of solid circles at any indentation and then a series of squares at any indentation, rather than one icon type per level of indentation.

borkedbullets.png
borkedbullets.png (27.57 KiB) Viewed 819 times


The combination of these bugs is bad.

User avatar
Scribblette
Posts: 58
Joined: Fri Jul 26, 2019 10:49 pm
Platform: Windows

Wed Dec 16, 2020 5:07 am Post

Edit: Sorry, this and my previous post were meant as an update to a different thread. I can't update the old post above, sorry, but I've removed my post from here, see viewtopic.php?f=57&t=61203&p=327772#p327772 instead if you want to see problems with how they indent.
Attachments
BulletsAreMad.png
BulletsAreMad.png (11.73 KiB) Viewed 739 times

Tr
Tridens92
Posts: 72
Joined: Tue Apr 19, 2016 5:43 pm
Platform: Windows

Thu Jan 14, 2021 1:35 am Post

With RC14, I'm excited to see the moving bullets / changing indent features coming along.

CTRL-ALT-SHIFT + [UP, DOWN, LEFT, or RIGHT ARROW] is working with these caveats:

1) Moving a bullet up or down sometimes flattens any existing multi-level indentation as the moving bullet passes by. Haven't figured out why it doesn't do this every time.

2) Moving text up and down results in text being selected, which needs to be deselected with mouse click or arrow key stroke before text will continue to move.

3) Multiple bullets can be selected and moved up and down (yay!), but not left or right.

Thanks again for putting energy into this useful feature for those of us who present, teach, etc.

br
brinkbart
Posts: 40
Joined: Mon Oct 29, 2018 5:50 pm
Platform: Windows

Thu Jan 14, 2021 9:22 am Post

Wow, thank you Tridens for carrying this torch for us. And thank you to the developers, for whom I’m certain this wasn’t easy.

I’ve been away from the forums (and writing) for a couple years now, and I was floored to return and find bullets and lists were still an issue. Holy shit, Microsoft.

But intuitive list controls and beautiful, consistent results are so necessary, and I’m convinced it’ll be worth the wait.

de
defman
Posts: 17
Joined: Thu May 30, 2013 10:02 am
Platform: Windows

Sun Jan 17, 2021 7:48 pm Post

I am using Scrivener 3 Beta, latest. So far no bugs, yet.

My problem: I'm using the tedious Format/ Paragraph/ Increase/Decrease Indents/ and select either Increase Indents or Decrease Indents as I needed.

I looks to customising the toolbar and add the Increase and Decrease Indent buttons in the toolbar, but I don't see these buttons in the Customising Toolbar dialog. Confusing..

I searched online, no one got any clue, so I searched here, and found this one after hours of searching. Seems like right place to ask my question: I'm wondering when the I/D indents buttons be back soon?

I find I uses the mouse a lot more than anything else. I'm proofreading huge stacks of stuff, editing as I go. The I/D indents buttons would makes my work a lot easier.

Thanks for making Scrivener awesome, everyone, much obliged.

ra
rachc659
Posts: 13
Joined: Wed Jul 08, 2020 5:26 pm
Platform: Windows

Tue Jan 19, 2021 1:53 pm Post

I can confirm I am still having issues with inconsistent list indentation in RC15; when I carry on a list with indentation from an old session, the indentation of the new lines is inconsistent with the old ones, despite not changing any margins.
Image