[Bug] Scrivener 3.0 Beta 18. White Background in Editor in Dark Mode Theme...

ji
jimkricket
Posts: 13
Joined: Thu Feb 01, 2018 11:48 pm
Platform: Windows

Fri Jul 12, 2019 4:20 pm Post

Version: Scrivener 3.0 Beta 18. Windows 64-bit.
OS: Windows 10 Home. 64-bit. Build 18362.

Bug:
White Background in the Editor using Dark Mode Theme, while selecting the top most Folder(from Binder) with Sub-Folders and Text Documents nested inside, while in Scrivenings view mode.

Steps to Replicate the bug:
1. Change themes to Dark Mode.
2. Select the premade default Draft Folder(There should already be one Text document nested in it).
3. Now select Scrivenings view mode. The background will be entirely white in the Editor.

Note:
This bug works with any top most layer Folder, with Sub-Folders or Text documents nestled inside it, by selecting it from the Binder and switching to Scrivenings view mode.

Additional Information:
I don't know if this information will help or not, but I had re-tried all the themes to view what they all looked like when I installed this latest update. Maybe because I tried other themes, the white background in the Editor when in Scrivenings mode changed to white color at some point and wouldn't switch back.

ji
jimkricket
Posts: 13
Joined: Thu Feb 01, 2018 11:48 pm
Platform: Windows

Sun Aug 04, 2019 1:59 pm Post

Update.

I'm in Scrivener 3.0 Beta 20 now, and I know a way to produce and fix the bug.

The reason I'm writing this separately is so people can still use my original post as a reference.

How to produce the bug:
1. Change theme to Default and restart Scrivener.
2. Change theme to Dark Theme and restart Scrivener.

In scrivenings mode(where all your documents are attached together vertically and separated by broken lines), you will see white backgrounds along the sides of your documents if you have the topmost folder highlighted in the Binder.

How to fix the bug:

WARNING: This will require you to save your options preferences and reload it again!

1. Be in Dark Theme.
2. Go to File > Options > Manage > Save Options to File > Then save your settings somewhere.
3. Go to File > Options > Defaults > OK
4. Go to File > Options > Manage > Load Options from File > Then load the options preference file you saved in step 2.

Now the white side backgrounds will be gone when viewing a folder with documents in scrivenings mode. You'll be in a fully Dark Theme again!