Compile problems with front matter

Ma
Manni
Posts: 193
Joined: Mon Dec 12, 2011 10:18 am
Platform: Mac + Windows

Thu Dec 05, 2019 12:28 pm Post

rwfranz wrote:
Manni wrote:
thePhilosoraptor wrote:As for the cover issue, it looks like cover images for pdfs was a more recent addition to the Mac program that was not present when it launched. I am unable to say whether or not that ability will be added to the Windows version before or after launch.


Hi Bryan,

Just to say that I have tried your workaround for the special elite issue, and at least here it doesn't work (this was using beta 30).

I created a new section (text) in my test document, and formatted some new text with Special Elite. It looked fine in the editor, but still had the wrong spacing when compiled.

I even tried to create a brand new test document, using the fiction template, and a standard compile format (I used paperback 6"x9") and the output was still incorrect.

For your information, the test page uses the "as is" format, in case it makes a difference.

So please could you log this bug and bump this up, as it's not an issue that can be solved with your workaround.


Does this behavior change when you enable Print and PDF Hinting? (file> Options> Editing> Options> several lines down, right side of the page) When I set this to default, everything's fine, but on my machine, default has some form of hinting. If I turn hinting to "No Hinting" I see the behavior you're seeing.


Thanks. Both hinting options are set to default (another user suggested I check this in a different thread). Also I only have this issue with Special Elite, not with any other font.

rw
rwfranz
Posts: 976
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Fri Dec 06, 2019 8:11 pm Post

Manni wrote:
rwfranz wrote:
Manni wrote:Just to say that I have tried your workaround for the special elite issue, and at least here it doesn't work (this was using beta 30).

I created a new section (text) in my test document, and formatted some new text with Special Elite. It looked fine in the editor, but still had the wrong spacing when compiled.


Does this behavior change when you enable Print and PDF Hinting? (file> Options> Editing> Options> several lines down, right side of the page) When I set this to default, everything's fine, but on my machine, default has some form of hinting. If I turn hinting to "No Hinting" I see the behavior you're seeing.


Thanks. Both hinting options are set to default (another user suggested I check this in a different thread). Also I only have this issue with Special Elite, not with any other font.

Sounds like the font may have some special characteristics to it.

If you change the Hinting to "Full Hinting" (for Print and PDF), does the behavior change? I'm not sure of the algorithm Scrivener uses to choose its default, but it may set it differently for different computers.
Just another user.