[B17] Dark mode?

User avatar
jje
Posts: 369
Joined: Sun Jul 06, 2014 5:57 pm
Platform: Windows
Location: Sussex, UK

Tue May 14, 2019 8:17 am Post

According to your release notes for B17, "Dark Mode is now a theme", applied by selecting "Dark Mode in Windows > Themes menu". However, there's no such item under Windows Themes on my PC. There's a "Dark" option (under "Personalisation | Colours"), which makes the default menus, etc., black, but has no effect on Scrivener (even after closing and restarting the new beta).

Am I missing something, or is this a bug?

ad
adrm
Posts: 126
Joined: Sun Dec 02, 2018 11:58 am
Platform: Windows

Tue May 14, 2019 8:45 am Post

jje wrote:According to your release notes for B17, "Dark Mode is now a theme", applied by selecting "Dark Mode in Windows > Themes menu". However, there's no such item under Windows Themes on my PC. There's a "Dark" option (under "Personalisation | Colours"), which makes the default menus, etc., black, but has no effect on Scrivener (even after closing and restarting the new beta).

Am I missing something, or is this a bug?


FYI, I see Dark Mode as the second item in the Themes menu list. After a restart, Scrivener shows up dark.
I.e. it seems to work on my machine.

User avatar
tiho_d
Posts: 1541
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Tue May 14, 2019 8:55 am Post

The menu Window > Themes is under the Scrivener menu bar, not inside the Windows OS Appearance options.

User avatar
jje
Posts: 369
Joined: Sun Jul 06, 2014 5:57 pm
Platform: Windows
Location: Sussex, UK

Tue May 14, 2019 10:02 am Post

tiho_d wrote:The menu Windows > Themes is under the Scrivener menu bar, not inside the Windows OS Appearance options.

Thanks -- I found it (it's on the "Window" menu).

User avatar
jje
Posts: 369
Joined: Sun Jul 06, 2014 5:57 pm
Platform: Windows
Location: Sussex, UK

Tue May 14, 2019 10:20 am Post

Having played with dark mode and decided it's not for me, I switched back to default. However, the full screen composition mode (F11) remains stuck in dark mode even after I switch back and I have to manually edit the preference settings to regain black text on a white background.

pa
paravel
Posts: 17
Joined: Wed Apr 24, 2013 3:51 pm
Platform: Windows

Tue May 14, 2019 12:55 pm Post

I had exactly the same when I first used this version. I have to manually change the default for Composition mode on the Default Layout or it is illegible - if I then switch back to the Default after trying another Layout the "fault" recurs and Composition mode is illegible until I manually alter the setting.

Co
Collider
Posts: 92
Joined: Mon Jul 28, 2014 2:52 pm
Platform: Windows

Tue May 14, 2019 1:14 pm Post

Can confirm this as well -- I don't generally use Composition Mode in the beta, but I played around with the themes in the latest version, switching back to default each time; on double-checking the behaviour in Composition mode after seeing this thread, mine too remains 'stuck' in whichever theme I last loaded, despite having long since reverted to default.

th
thePhilosoraptor
Posts: 1298
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Tue May 14, 2019 6:24 pm Post

Hi all,

Changing to a new "Theme" sets the defaults to the new colour scheme for that theme, so altering the theme will reset the colours each time. Under the "Default" settings, Composition mode is set to have a black background with a gray text, this is behaving as expected.

If you wish to maintain your settings between experimenting with Themes, I would suggest saving your options using the Manage button in File > Options, that way you can easily restore your preferred colouring.

Hope this helps!
Bryan Bender