[LH3133] Default Text Colors Not Sticking on Create New Paragraph

rg
rgletter
Posts: 139
Joined: Mon Aug 14, 2017 9:45 pm
Platform: Win + iOS

Sat Jul 21, 2018 7:56 pm Post

I changed the default text color for each text file to white. I use styles and also have that set to white. However, creating a new paragraph defaults the text color to black and not the default color "white". It gets very annoying having to reset the colors each time.

On another note, formatting is disabled inside the form Project Settings->Formatting:
1. New Documents Use Paragraph Style
2. Main Text Formatting

rw
rwfranz
Posts: 783
Joined: Thu May 28, 2015 9:41 pm
Platform: Windows

Wed Jul 25, 2018 5:54 am Post

rgletter wrote:I changed the default text color for each text file to white. I use styles and also have that set to white. However, creating a new paragraph defaults the text color to black and not the default color "white". It gets very annoying having to reset the colors each time.

Hmm. Where are you setting this?

Options | Editing | formatting
or
Options | Appearance | Colors | Editor | Text ?
or are you setting text color via context menu in the editor itself, and then setting the style to that, and choosing a default style?

If you want your text always in white, and your background always in black, when in the editor, setting those in options | appearance | colors |editor | text (and 'editor' for the background) might work better than setting a style.

However, if you're using highlighting as background (which is what you set in Options | Editing | formatting), you'd have to highlight the text to get the background correct. Or am I missing something? (always possible)

On another note, formatting is disabled inside the form Project Settings->Formatting:
1. New Documents Use Paragraph Style
2. Main Text Formatting


That problem is known, or at least part of it.
https://www.literatureandlatte.com/foru ... 57&t=52744
You should be able to set the default style in Project Settings, exit scriv, re-enter, and it should show the change. It's just not updating the display, for some reason.

rg
rgletter
Posts: 139
Joined: Mon Aug 14, 2017 9:45 pm
Platform: Win + iOS

Thu Aug 09, 2018 4:02 pm Post

rwfranz wrote:
rgletter wrote:I changed the default text color for each text file to white. I use styles and also have that set to white. However, creating a new paragraph defaults the text color to black and not the default color "white". It gets very annoying having to reset the colors each time.

Hmm. Where are you setting this?

Options | Editing | formatting
or
Options | Appearance | Colors | Editor | Text ?
or are you setting text color via context menu in the editor itself, and then setting the style to that, and choosing a default style?

If you want your text always in white, and your background always in black, when in the editor, setting those in options | appearance | colors |editor | text (and 'editor' for the background) might work better than setting a style.

However, if you're using highlighting as background (which is what you set in Options | Editing | formatting), you'd have to highlight the text to get the background correct. Or am I missing something? (always possible)

On another note, formatting is disabled inside the form Project Settings->Formatting:
1. New Documents Use Paragraph Style
2. Main Text Formatting


That problem is known, or at least part of it.
https://www.literatureandlatte.com/foru ... 57&t=52744
You should be able to set the default style in Project Settings, exit scriv, re-enter, and it should show the change. It's just not updating the display, for some reason.


The color problem was resolved in beta 7/8. HOWEVER, when I go to File->Options->Editing->Formatting, the text color displayed in the style bar ("A") is always "Black" no matter what color I select and save. Instead, the color displayed should always be the one last saved, otherwise default to black.

ScrivenerDefaultColor.jpg
ScrivenerDefaultColor.jpg (115.9 KiB) Viewed 464 times

th
thePhilosoraptor
Posts: 1224
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Thu Aug 09, 2018 4:23 pm Post

rgletter wrote:
The color problem was resolved in beta 7/8. HOWEVER, when I go to File->Options->Editing->Formatting, the text color displayed in the style bar ("A") is always "Black" no matter what color I select and save. Instead, the color displayed should always be the one last saved, otherwise default to black.


This has been filed as a bug, as you are correct that the ui should be updating. Thanks.
Bryan Bender