[LH2892] Font back to bold

jl
jljovano
Posts: 86
Joined: Tue May 06, 2014 9:08 am
Platform: Linux + Windows

Thu Mar 15, 2018 8:14 am Post

A strange bug with only one of my font, Bookman Old Style : I use it in "normal", save, quit, but it allways turn back to "bold" when I open my project. Tried many fonts, only do this with this one.

th
thePhilosoraptor
Posts: 1293
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Thu Mar 15, 2018 9:32 pm Post

Thanks. This has been filed.
Bryan Bender

Je
Jez
Posts: 34
Joined: Mon Sep 15, 2014 1:28 am
Platform: Windows
Location: Gold Coast Australia

Wed Apr 25, 2018 4:59 am Post

Also happening with a font I downloaded: TypewriterScribbled.ttf

After applying this font to six docs and setting to regular (unbolded), oddly two docs retained regular rendering whilst the rest jumped to bold after closing and reopening Scrivener.

Also, within a document with font set to regular, when I copy and past a piece of text into another section within the same doc, this pops up as bolded when pasted.

Je
Jez
Posts: 34
Joined: Mon Sep 15, 2014 1:28 am
Platform: Windows
Location: Gold Coast Australia

Wed May 30, 2018 8:16 pm Post

2.9.0.5 Beta (64-bit) - After reopening Scrivener, plain font still reverts to bold in certain documents (but not all). Not mentioned as a "Known Issue". Any update on this issue?
Thanks

th
thePhilosoraptor
Posts: 1293
Joined: Sat Feb 13, 2016 3:28 am
Platform: Windows

Wed May 30, 2018 8:27 pm Post

Hi. Any bug that has been filed but does not appear in the list of fixed bugs ( viewtopic.php?f=57&t=40621 ) can be considered a known issue. The "known issues" that are specifically mentioned are areas that we simply haven't implemented fully yet, as opposed to bugs, which are implemented features that are not behaving correctly.

Thanks!
Bryan Bender

Je
Jez
Posts: 34
Joined: Mon Sep 15, 2014 1:28 am
Platform: Windows
Location: Gold Coast Australia

Fri Jun 01, 2018 11:51 pm Post

Hi - thanks for your reply. I ran a couple of test on a blank project which may be useful. With 'TypewriterScribbled' font and a line of text typed in standard format (no bold set), I get the following results:

test_a: placing the cursor anywhere on the line, the Bold toolbar button is highlighted (active)

test_b: selecting a chunk of text, the Bold button is not highlighted

test_c: Using Calibri font, bolding behaves normally

(Note you may ignore the comment in the text itself as I did not need to close the project or reopen in order to get these results).
Attachments
bold test_c.jpg
bold test_c.jpg (37.19 KiB) Viewed 924 times
bold test_a.jpg
bold test_a.jpg (43.24 KiB) Viewed 924 times
bold test_b.jpg
bold test_b.jpg (35.36 KiB) Viewed 924 times