[JH] Fullscreen errors

Ri
Rithe
Posts: 133
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Wed Mar 14, 2018 3:11 am Post

I've got a Composition Mode error. As far as I'm aware, I've got all the defaults set. The project I'm working on is one that was converted to Scriv 3 from Win 1.9.7.

On one document only, the styling of the words is screwed up. By default, it is set to dark screen with white/grey text? That's what it looked like in the settings, I check there to make sure I didn't change something. When I opened this document and pulled it up in fullscreen, the lines of text I started typing were coming out black. All the other words were white still.

Thinking resetting the style would fix it, I did that. I had to fiddle with it a bit because the settings weren't what I had set (no tabs, Courier, size. I like it simple). Now when I go in, the background is dark, like I expect. But the words are all black with white background. So far, the other documents that I've checked look normal.

Sorry if I missed this report already.

Edit: I forgot to mention that the document in question had been edited in iOS Scrivener as well. It was after that when the oddity happened.

User avatar
MimeticMouton
Posts: 8718
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Wed Mar 14, 2018 4:58 am Post

There is a bug in Composition Mode whereby the text appears all black, but it's a temporary display issue triggered by switching documents while in Composition Mode, and if you exited Composition Mode and returned, the text would appear correctly. It sounds like that's not what you're seeing, if it's just the one document and persists even when you exit and return to composition mode.

What happens if you select all the text in the problem document and choose Format > Text Color > Remove Color or Text Color > Remove Color from the context menu? (You'll need to use the context menu if doing this in composition mode.) iOS and macOS don't have a "no colour" option but always use black text, so that may be the problem you're seeing--that the text is coloured black, and currently the composition mode text colour is only "showing through" uncoloured text, so in this case, the black would be overriding that. Scrivener on Windows normally strips the black text colour from documents synced from iOS, but there may be something particular to this document or how the sync went that caused that not to happen.

Also try Highlight Color > Remove Highlight to get rid of the white background behind the text.
Jennifer Hughes
(MM for short)

Ri
Rithe
Posts: 133
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Wed Mar 14, 2018 11:42 am Post

Maybe it was that bug. I'm checking it now, and everything looks normal. That's after shutting it down overnight. I didn't switch documents because I had another open in split screen. That one was working fine. It sounds like I should have opened another in the panel with the one not working well and checked it that way.

I'll keep an eye on it. Otherwise, it sounds like you know about this one.