2.9.0.2 (x64) - Split Screen Focus

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Sat Dec 23, 2017 4:06 am Post

I've been (slowly) rolling through the tutorial. In "Splitting the Editor" it mentions that we should be able to change the focus from one screen to another. That part works. But when I click on an item to open in the "secondary" screen, it opens in the "main" instead.

I've checked to make sure I selected the other pane. The title area is blue when I do so. I've tried the picture, pdf, video/audio, and normal document. All are doing this. Dragging a file to the title area works fine, though.

I didn't see this mentioned in the main thread, but I could have missed it somewhere. So, sorry if it's been mentioned already.

User avatar
Aurion
Posts: 24
Joined: Tue Nov 21, 2017 2:05 am
Platform: Windows

Sat Dec 23, 2017 6:13 am Post

In "Navigate > Binder Selection Affects", check what the setting is on. It sounds like your current setting is "Other Editor" (the editor that's not currently selected) and you would like it on "Current Editor" (the selected editor highlighted in blue).

po
postiffm
Posts: 4
Joined: Sun Dec 03, 2017 8:12 pm
Platform: Windows

Sat Dec 23, 2017 11:58 am Post

Had the same problem (x64), and that setting change seems to fix it. Strange, however, since I never touched that setting in the 2901 beta, nor after the transition to 2902. It should have always been currrent editor.

Related problem doing the tutorial. When I'm looking at "The Outliner" and then split the window, the second "The Outliner" window is blank. If I click the Toggle Split button on the blank one, it stays blank as it goes to un-split mode. If I click the Toggle Split button again, then the top one has the outliner text in it, and the bottom one is still blank. This means that it is almost impossible to make forward progress doing the tutorial. This bug is not present in the 32-bit version of Scrivener.

Ri
Rithe
Posts: 147
Joined: Fri Dec 10, 2010 2:32 am
Platform: Linux + Windows

Sat Dec 23, 2017 7:37 pm Post

Yep, you're both right. Thanks! Wouldn't have thought to look there. Might want to check that default, then.

User avatar
MimeticMouton
Posts: 9049
Joined: Wed May 05, 2010 5:39 am
Platform: Mac + Windows
Location: city of rain
Contact:

Sat Dec 23, 2017 8:36 pm Post

This was mentioned in the beta 2 notes but perhaps not clear--the changes made for Beta 2 to fix an upgrade bug related to the Binder Affects setting caused internal settings to change such that projects created in or edited in Beta 1 might have the wrong Binder Affects setting when opened in Beta 2. So those projects likely need this setting fixed even if you hadn't touched it previously. Just one of those bits of beta fun. :)

Postiffm wrote:Related problem doing the tutorial. When I'm looking at "The Outliner" and then split the window, the second "The Outliner" window is blank. If I click the Toggle Split button on the blank one, it stays blank as it goes to un-split mode. If I click the Toggle Split button again, then the top one has the outliner text in it, and the bottom one is still blank. This means that it is almost impossible to make forward progress doing the tutorial. This bug is not present in the 32-bit version of Scrivener.


This sounds like an entirely separate issue, related to toggling the split editor rather than binder clicks loading, but I'm not entirely clear what you're describing or how it compares to the expected behaviour. If you're following the tutorial step by step, the editor is already split by the Outliner step and it isn't closed in that part, so I'm not sure where you're starting out with the split editor contents. Could you please create a new topic in the forum with some step-by-step instructions for seeing the issue, so we can be sure to take a look at it after the holidays? Thanks!
Jennifer Hughes
(MM for short)