Footnotes compiled to PDF corrupted

mk
mk14steve

Wed Dec 23, 2020 6:33 am Post

Having been previously "told off" for posting a "bug" in the wrong forum, I do hope I have it right this time! :wink:

Windows 10 Version: 2004 (OS Build 19041.685)
Scrivenor 3 version: 2.9.9.13 Beta (1129554) 64-bit - 04 Dec 2020

Test text: "Now include a footnote and see how this version of Scrivener Beta release handles footnotes and also rtf formatting.[ This is a footnote] "

Compile Format: Manuscript Courier
Compile to PDF. The resulting footer comes out as:
-* Pden en ] bjjïijïa
and the word "formatting" with superscript appears on page two.

Export to rtf works ok.

My understanding is Scrivenor first exports to rtf then does a conversion so the error might be in the conversion.
The workaraound is to export to pdf via rtf and use a word processor (word or libreoffice) to do the conversion.

User avatar
tiho_d
Posts: 1548
Joined: Tue Sep 13, 2011 1:14 pm
Platform: Linux + Windows

Wed Dec 23, 2020 11:15 am Post

Hi mk14steve, I believe you have the same problem as discussed in: "Garbled Text when Compiling using Manuscript (Courier)" - viewtopic.php?f=57&t=64279

The following might help you too:
If you are using Courier Prime, try removing(move into a different folder) the system Courier Prime fonts from the Windows/Fonts folder. Scrivener comes with Courier Prime in its installation folder. Restart Scrivener and recompile again. Hopefully the PDF contents will be as expected this time.

If this helps install the Courier Prime fonts from the Scrivener installation folder, although this is not needed. Do this only if you need Courier Prime in other applications too.

mk
mk14steve

Thu Dec 24, 2020 6:19 am Post

Yeah, ok. That works. :wink:

User avatar
devinganger
Posts: 2669
Joined: Sat Nov 06, 2010 1:55 pm
Platform: Mac, Win + iOS
Location: Monroe, WA 98272
Contact:

Thu Dec 24, 2020 8:21 am Post

Welcome to the Windows Beta forum, BTW! Happy bug-squashing!
--
Devin L. Ganger
Not a L&L employee; opinions are those of my cat
Life has a way of moving you past wants and hopes -- Kevin Flynn

User avatar
DragonToe
Posts: 72
Joined: Thu Jan 07, 2021 9:02 am
Platform: Windows

Tue Apr 13, 2021 8:49 am Post

Not working for me. The garbled text has gone, but it has been replaced by italics as the standard.

Why is such a major and fundamental bug still present in a professional writing software? I don't get it.

User avatar
DragonToe
Posts: 72
Joined: Thu Jan 07, 2021 9:02 am
Platform: Windows

Mon Apr 19, 2021 7:08 am Post

It seems to me that the only workaround to this is to use Courier Screenplay font instead of Courier Prime.

This is a very odd situation having to veto the industry standard font, but at least this alterative is feasible until it is fixed - which it will have to be if Scrivener wants screenwriters to use this software.

I really hope it will be fixed for the new Windows release.